]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
mutt (1.5.15+20070515-1) experimental; urgency=low
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 82da4bd88b9f244b4c9537f9d579f4cddee2ae61..186428dc7b9bf862f79e3019e5123e5ae39bd227 100644 (file)
@@ -16,12 +16,14 @@ The home page for this patch is:
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
   - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
   - 2007-03-20 myon: conflict in mx.c resolved (BUFFY_SIZE is gone)
+  - 2007-05-16 myon: conflict in flags.c resolved, adjusted mutt_FormatString
+    call and compresshook_format_str in compress.c
 
 == END PATCH
 Index: debian-mutt/compress.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c     2007-04-12 18:56:02.000000000 +0200
++++ debian-mutt/compress.c     2007-05-17 00:11:39.000000000 +0200
 @@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -195,7 +197,7 @@ Index: debian-mutt/compress.c
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op, const char *src,
 +                       const char *fmt, const char *ifstring,
 +                       const char *elsestring, unsigned long data,
 +                       format_flag flags)
@@ -229,7 +231,7 @@ Index: debian-mutt/compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, compresshook_format_str,
 +                   (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
@@ -525,7 +527,7 @@ Index: debian-mutt/compress.c
 Index: debian-mutt/compress.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h     2007-04-12 18:56:02.000000000 +0200
++++ debian-mutt/compress.h     2007-05-16 23:54:01.000000000 +0200
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -556,9 +558,9 @@ Index: debian-mutt/compress.h
 +void mutt_fast_close_compressed (CONTEXT *);
 Index: debian-mutt/configure.ac
 ===================================================================
---- debian-mutt.orig/configure.ac      2007-04-12 18:15:14.000000000 +0200
-+++ debian-mutt/configure.ac   2007-04-12 18:56:02.000000000 +0200
-@@ -803,6 +803,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- debian-mutt.orig/configure.ac      2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/configure.ac   2007-05-16 23:54:02.000000000 +0200
+@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -572,9 +574,9 @@ Index: debian-mutt/configure.ac
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 Index: debian-mutt/curs_main.c
 ===================================================================
---- debian-mutt.orig/curs_main.c       2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/curs_main.c    2007-04-12 18:56:02.000000000 +0200
-@@ -1096,6 +1096,11 @@ int mutt_index_menu (void)
+--- debian-mutt.orig/curs_main.c       2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/curs_main.c    2007-05-17 00:13:50.000000000 +0200
+@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
          {
          int check;
  
@@ -588,8 +590,8 @@ Index: debian-mutt/curs_main.c
  
 Index: debian-mutt/doc/manual.xml.head
 ===================================================================
---- debian-mutt.orig/doc/manual.xml.head       2007-04-07 14:44:33.000000000 +0200
-+++ debian-mutt/doc/manual.xml.head    2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/doc/manual.xml.head       2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/doc/manual.xml.head    2007-05-17 00:13:50.000000000 +0200
 @@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
  
  </chapter>
@@ -798,8 +800,8 @@ Index: debian-mutt/doc/manual.xml.head
  
 Index: debian-mutt/doc/muttrc.man.head
 ===================================================================
---- debian-mutt.orig/doc/muttrc.man.head       2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/doc/muttrc.man.head    2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/doc/muttrc.man.head       2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/doc/muttrc.man.head    2007-05-16 23:54:01.000000000 +0200
 @@ -345,6 +345,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
@@ -827,8 +829,8 @@ Index: debian-mutt/doc/muttrc.man.head
  This command adds the named \fIstring\fP to the keyboard buffer.
 Index: debian-mutt/hook.c
 ===================================================================
---- debian-mutt.orig/hook.c    2007-04-12 18:15:14.000000000 +0200
-+++ debian-mutt/hook.c 2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/hook.c    2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/hook.c 2007-05-16 23:54:01.000000000 +0200
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -859,9 +861,9 @@ Index: debian-mutt/hook.c
        )
 Index: debian-mutt/init.h
 ===================================================================
---- debian-mutt.orig/init.h    2007-04-12 18:15:14.000000000 +0200
-+++ debian-mutt/init.h 2007-04-12 18:56:02.000000000 +0200
-@@ -3128,6 +3128,11 @@ struct command_t Commands[] = {
+--- debian-mutt.orig/init.h    2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/init.h 2007-05-17 00:13:50.000000000 +0200
+@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -875,8 +877,8 @@ Index: debian-mutt/init.h
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 Index: debian-mutt/main.c
 ===================================================================
---- debian-mutt.orig/main.c    2007-04-12 18:15:14.000000000 +0200
-+++ debian-mutt/main.c 2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/main.c    2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/main.c 2007-05-16 23:54:01.000000000 +0200
 @@ -401,6 +401,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
@@ -892,8 +894,8 @@ Index: debian-mutt/main.c
        "+HAVE_WC_FUNCS  "
 Index: debian-mutt/Makefile.am
 ===================================================================
---- debian-mutt.orig/Makefile.am       2007-04-07 14:44:20.000000000 +0200
-+++ debian-mutt/Makefile.am    2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/Makefile.am       2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/Makefile.am    2007-05-16 23:54:01.000000000 +0200
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
@@ -914,8 +916,8 @@ Index: debian-mutt/Makefile.am
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
 Index: debian-mutt/mbox.c
 ===================================================================
---- debian-mutt.orig/mbox.c    2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/mbox.c 2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/mbox.c    2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/mbox.c 2007-05-16 23:54:01.000000000 +0200
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -942,8 +944,8 @@ Index: debian-mutt/mbox.c
    return 0;
 Index: debian-mutt/mutt.h
 ===================================================================
---- debian-mutt.orig/mutt.h    2007-04-12 18:15:14.000000000 +0200
-+++ debian-mutt/mutt.h 2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/mutt.h    2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/mutt.h 2007-05-17 00:13:50.000000000 +0200
 @@ -160,6 +160,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
@@ -970,8 +972,8 @@ Index: debian-mutt/mutt.h
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
 Index: debian-mutt/mx.c
 ===================================================================
---- debian-mutt.orig/mx.c      2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/mx.c   2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/mx.c      2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/mx.c   2007-05-17 00:13:49.000000000 +0200
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -1072,8 +1074,8 @@ Index: debian-mutt/mx.c
      if (ctx->locked) lock = 0;
 Index: debian-mutt/mx.h
 ===================================================================
---- debian-mutt.orig/mx.h      2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/mx.h   2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/mx.h      2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/mx.h   2007-05-16 23:54:01.000000000 +0200
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
@@ -1087,13 +1089,13 @@ Index: debian-mutt/mx.h
 Index: debian-mutt/PATCHES
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES        2007-04-12 18:56:02.000000000 +0200
++++ debian-mutt/PATCHES        2007-05-17 00:13:50.000000000 +0200
 @@ -0,0 +1 @@
 +patch-1.5.14.rr.compressed.1
 Index: debian-mutt/po/de.po
 ===================================================================
---- debian-mutt.orig/po/de.po  2007-04-07 14:44:33.000000000 +0200
-+++ debian-mutt/po/de.po       2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/po/de.po  2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/po/de.po       2007-05-16 23:54:01.000000000 +0200
 @@ -1280,6 +1280,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
@@ -1164,8 +1166,8 @@ Index: debian-mutt/po/de.po
  #. * never happen, is we presume it is a bug in mutt.
 Index: debian-mutt/po/POTFILES.in
 ===================================================================
---- debian-mutt.orig/po/POTFILES.in    2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/po/POTFILES.in 2007-04-12 18:56:02.000000000 +0200
+--- debian-mutt.orig/po/POTFILES.in    2007-05-16 23:53:59.000000000 +0200
++++ debian-mutt/po/POTFILES.in 2007-05-16 23:54:01.000000000 +0200
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
@@ -1176,9 +1178,9 @@ Index: debian-mutt/po/POTFILES.in
  cryptglue.c
 Index: debian-mutt/status.c
 ===================================================================
---- debian-mutt.orig/status.c  2007-04-03 21:43:38.000000000 +0200
-+++ debian-mutt/status.c       2007-04-12 18:56:02.000000000 +0200
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+--- debian-mutt.orig/status.c  2007-05-16 23:53:58.000000000 +0200
++++ debian-mutt/status.c       2007-05-17 00:13:49.000000000 +0200
+@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);