== END PATCH
--- a/commands.c
+++ b/commands.c
-@@ -688,6 +688,7 @@ int _mutt_save_message (HEADER *h, CONTE
+@@ -693,6 +693,7 @@
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, h, M_TAG, 0);
}
}
--- a/flags.c
+++ b/flags.c
-@@ -69,7 +69,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -65,7 +65,13 @@
{
h->deleted = 0;
update = 1;
#ifdef USE_IMAP
/* see my comment above */
if (ctx->magic == M_IMAP)
-@@ -91,6 +97,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -87,6 +93,17 @@
}
break;
if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
--- a/globals.h
+++ b/globals.h
-@@ -142,6 +142,7 @@ WHERE char *StChars;
+@@ -138,6 +138,7 @@
WHERE char *Status;
WHERE char *Tempdir;
WHERE char *Tochars;
WHERE char *XtermTitle;
--- a/imap/message.c
+++ b/imap/message.c
-@@ -816,6 +816,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -859,6 +859,7 @@
if (ctx->hdrs[n]->tagged)
{
mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
}
-@@ -823,6 +824,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -866,6 +867,7 @@
else
{
mutt_set_flag (ctx, h, M_DELETE, 1);
}
--- a/init.h
+++ b/init.h
-@@ -2881,6 +2881,16 @@ struct option_t MuttVars[] = {
+@@ -3138,6 +3138,16 @@
** by \fIyou\fP. The sixth character is used to indicate when a mail
- ** was sent to a mailing-list you subscribe to (default: L).
+ ** was sent to a mailing-list you subscribe to.
*/
+ { "trash", DT_PATH, R_NONE, UL &TrashPath, 0 },
+ /*
/*
--- a/mutt.h
+++ b/mutt.h
-@@ -201,6 +201,7 @@ enum
+@@ -181,6 +181,7 @@
M_DELETE,
M_UNDELETE,
M_DELETED,
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -712,6 +713,7 @@ typedef struct header
+@@ -693,6 +694,7 @@
unsigned int mime : 1; /* has a MIME-Version header? */
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int deleted : 1;
unsigned int changed : 1;
unsigned int attach_del : 1; /* has an attachment marked for deletion */
-@@ -883,6 +885,7 @@ typedef struct _context
+@@ -864,6 +866,7 @@
int new; /* how many new messages? */
int unread; /* how many unread messages? */
int deleted; /* how many deleted messages */
--- a/muttlib.c
+++ b/muttlib.c
-@@ -1430,7 +1430,9 @@ int mutt_save_confirm (const char *s, st
+@@ -1445,7 +1445,9 @@
if (magic > 0 && !mx_access (s, W_OK))
{
if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
--- a/mx.c
+++ b/mx.c
-@@ -803,6 +803,53 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -803,6 +803,53 @@
return rc;
}
/* save changes and close mailbox */
int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
{
-@@ -938,6 +985,7 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -938,6 +985,7 @@
if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
{
mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
}
else
{
-@@ -959,6 +1007,14 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -959,6 +1007,14 @@
return 0;
}
#ifdef USE_IMAP
/* allow IMAP to preserve the deleted flag across sessions */
if (ctx->magic == M_IMAP)
-@@ -1154,6 +1210,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
+@@ -1154,6 +1210,12 @@
msgcount = ctx->msgcount;
deleted = ctx->deleted;
rc = imap_sync_mailbox (ctx, purge, index_hint);
--- a/postpone.c
+++ b/postpone.c
-@@ -279,6 +279,9 @@ int mutt_get_postponed (CONTEXT *ctx, HE
+@@ -276,6 +276,9 @@
/* finished with this message, so delete it. */
mutt_set_flag (PostContext, h, M_DELETE, 1);