---- a/doc/Muttrc
-+++ b/doc/Muttrc
-@@ -657,6 +657,26 @@
- # $crypt_autosign, $crypt_replysign and $smime_is_default.
- #
- #
-+# set sidebar_visible=no
-+#
-+# Name: sidebar_visible
-+# Type: boolean
-+# Default: no
-+#
-+#
-+# This specifies whether or not to show sidebar (left-side list of folders).
-+#
-+#
-+# set sidebar_width=0
-+#
-+# Name: sidebar_width
-+# Type: number
-+# Default: 0
-+#
-+#
-+# The width of the sidebar.
-+#
-+#
- # set crypt_autosign=no
- #
- # Name: crypt_autosign
---- a/imap/imap.c
-+++ b/imap/imap.c
-@@ -1527,7 +1527,7 @@
-
- imap_munge_mbox_name (munged, sizeof (munged), name);
- snprintf (command, sizeof (command),
-- "STATUS %s (UIDNEXT UIDVALIDITY UNSEEN RECENT)", munged);
-+ "STATUS %s (UIDNEXT UIDVALIDITY UNSEEN RECENT MESSAGES)", munged);
-
- if (imap_exec (idata, command, IMAP_CMD_QUEUE) < 0)
- {
---- a/imap/command.c
-+++ b/imap/command.c
-@@ -1011,6 +1011,13 @@
- opened */
- status->uidnext = oldun;
-
-+ /* Added to make the sidebar show the correct numbers */
-+ if (status->messages)
-+ {
-+ inc->msgcount = status->messages;
-+ inc->msg_unread = status->unseen;
-+ }
-+
- FREE (&value);
- return;
- }