for (i = 0; i < strlen(tmp->path) - strlen(Maildir); i++) {
- if (tmp_folder_name[i] == '/') sidebar_folder_depth++;
+ if (tmp_folder_name[i] == '/' || tmp_folder_name[i] == '.') sidebar_folder_depth++;
- }
+ }
if (sidebar_folder_depth > 0) {
- sidebar_folder_name = malloc(strlen(basename(tmp->path)) + sidebar_folder_depth + 1);
+ if (option(OPTSIDEBARSHORTPATH)) {
+ if (tmp_folder_name == NULL)
+ tmp_folder_name = tmp->path;
+ else
-+ tmp_folder_name++;
++ tmp_folder_name++;
+ }
+ else
+ tmp_folder_name = tmp->path;
printw( "%.*s", SidebarWidth - delim_len + 1,
--- a/init.h
+++ b/init.h
-@@ -1979,6 +1979,11 @@
+@@ -1981,6 +1981,11 @@
** .pp
** The width of the sidebar.
*/
** .pp
--- a/mutt.h
+++ b/mutt.h
-@@ -427,6 +427,7 @@
+@@ -432,6 +432,7 @@
OPTSAVENAME,
OPTSCORE,
OPTSIDEBAR,