]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-sorted
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-sorted
index dbfa3cf6baeadfbe9cdfeaa7b6b0cc9d0fa9f1da..df4c6726891cebc31748fba04c16d937e2184f7c 100644 (file)
@@ -26,7 +26,7 @@ should be easy to adopt it to a vanilla mutt.
 +                      needsort=0;
 +                      tmp = Incoming;
 +                      for ( ; tmp ; tmp=tmp->next ) {
-+                              if (tmp->next != NULL && strcmp(tmp->path, tmp->next->path) > 0) {
++                              if (tmp->next != NULL && strcoll(tmp->path, tmp->next->path) > 0) {
 +                                      needsort=1;
 +                                      prev = tmp->prev;
 +                                      next = tmp->next;
@@ -51,7 +51,7 @@ should be easy to adopt it to a vanilla mutt.
        if ( BottomBuffy == 0 ) {
 --- a/init.h
 +++ b/init.h
-@@ -1984,6 +1984,11 @@
+@@ -1986,6 +1986,11 @@
    ** .pp
    ** Should the sidebar shorten the path showed.
    */
@@ -65,7 +65,7 @@ should be easy to adopt it to a vanilla mutt.
    ** .pp
 --- a/mutt.h
 +++ b/mutt.h
-@@ -428,6 +428,7 @@
+@@ -433,6 +433,7 @@
    OPTSCORE,
    OPTSIDEBAR,
    OPTSIDEBARSHORTPATH,