+# vim:ft=diff
+
+ * 2009-01-15 myon: refreshed for mutt-1.5.19; drop our list of ignored headers
+ in favor of upstream's new unignore list
+
--- a/doc/Muttrc.head
+++ b/doc/Muttrc.head
-@@ -6,6 +6,36 @@
- #
- ignore "from " received content- mime-version status x-status message-id
- ignore sender references return-path lines
-+ignore date delivered-to precedence errors-to in-reply-to user-agent
-+ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
-+ignore x-accept-language x-authentication-warning thread- priority importance
-+ignore x-original-to domainkey-signature dkim-signature
-+
+@@ -12,6 +12,34 @@
+ # Display the fields in this order
+ hdr_order date from to cc subject
+
+# emacs-like bindings
+bind editor "\e<delete>" kill-word
+bind editor "\e<backspace>" kill-word
+# Specifies how to sort messages in the index menu.
+set sort=threads
+
-+# Uncomment if your MTA does not strip Bcc: headers.
-+# (exim4 and postfix strip them, exim(3) does not.)
++# The behavior of this option on the Debian mutt package is
++# not the original one because exim4, the default SMTP on Debian
++# does not strip bcc headers so this can cause privacy problems;
++# see man muttrc for more info
+#unset write_bcc
+# Postfix and qmail use Delivered-To for detecting loops
+unset bounce_delivered
+
+# System-wide CA file managed by the ca-certificates package
+set ssl_ca_certificates_file="/etc/ssl/certs/ca-certificates.crt"
-
++
# imitate the old search-body function
macro index \eb "<search>~b " "search in message bodies"
-@@ -18,7 +48,7 @@ macro index,pager,attach,compose \cb "\
+
+@@ -23,14 +51,14 @@
"call urlview to extract URLs out of a message"
# Show documentation when pressing F1
# show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
-@@ -30,7 +60,7 @@ bind browser y exit
- # append-hook \\.gz$ "gzip -c %t >> %f"
+ bind browser y exit
# If Mutt is unable to determine your site's domain name correctly, you can
-# set the default here.
#
# set hostname=cs.hmc.edu
-@@ -92,6 +122,9 @@ attachments +I text/plain
- attachments -A message/external-body
- attachments -I message/external-body
+@@ -42,6 +70,10 @@
+ # be undone with unmime_lookup.
+ mime_lookup application/octet-stream
-+# enable mime lookup by extension
-+mime_lookup application/octet-stream
++# Upgrade the progress counter every 250ms, good for mutt over SSH
++# see http://bugs.debian.org/537746
++set time_inc=250
+
##
- ## More settings
+ ## *** DEFAULT SETTINGS FOR THE ATTACHMENTS PATCH ***
##