]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
Refresh patch
[software/mutt-debian.git] / debian / rules
index 0deaca25ad57ace98cc3ee3040ac641e6cdd15cf..05b512f85cb137473ec20533be9019129e92e2b1 100755 (executable)
@@ -71,16 +71,30 @@ endif
 # Directory to make the build on
 objdir = $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE)
 
-configure: $(objdir)/configure-stamp
-$(objdir)/configure-stamp: $(QUILT_STAMPFN)
+$(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        dh_testdir
+       dh_clean
+       
+       ###################### building mutt-patched ######################
+       autoreconf --install --include=m4
+       -mkdir $(objdir)-patched
+       cd $(objdir)-patched && \
+       env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+       ../configure $(confflags)
+       
+       echo '#include "config-debian.h"' >> $(objdir)-patched/config.h
        
-       #ln -sf /usr/share/misc/config.sub .
-       #ln -sf /usr/share/misc/config.guess .
+       # we should just "make mutt" here, but that doesn't work yet
+       cd $(objdir)-patched && $(MAKE) CFLAGS="$(CFLAGS)"
        
-       # do not rebuild these files
-       touch configure.ac aclocal.m4 Makefile.in configure config.h.in
+       touch $@
+
+build build-arch: $(objdir)/build-stamp
+$(objdir)/build-stamp: $(objdir)-patched/build-stamp
+       ###################### building mutt ######################
+       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
        
+       autoreconf --install --include=m4
        -mkdir $(objdir)
        cd $(objdir) && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -88,18 +102,13 @@ $(objdir)/configure-stamp: $(QUILT_STAMPFN)
        
        echo '#include "config-debian.h"' >>$(objdir)/config.h
        
-       touch $@
-
-build build-arch: $(objdir)/build-stamp
-$(objdir)/build-stamp: $(objdir)/configure-stamp
        cd $(objdir) && $(MAKE) CFLAGS="$(CFLAGS)"
+       
        touch $@
 
-install: debian/tmp/install-stamp
-debian/tmp/install-stamp: $(objdir)/build-stamp
-       dh_testdir
-       dh_testroot
-       dh_clean
+install: build
+       ###################### install ######################
+       dh_clean -k
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
@@ -110,18 +119,21 @@ debian/tmp/install-stamp: $(objdir)/build-stamp
        
        chmod +x debian/extra/lib/*
        chmod +x debian/header.awk
-       debian/header.awk debian/patches/features/* >debian/tmp/README.Patches
+       debian/header.awk debian/patches/features/* \
+               debian/patches/mutt-patched/* > debian/tmp/README.Patches
        
-       ( sed -e '/## More settings/,$$d' $(objdir)/Muttrc || exit 1 ; \
+       ( sed -e '/## More settings/,$$d' $(objdir)/doc/Muttrc || exit 1 ; \
          cat debian/extra/rc/Muttrc.foot ) > debian/tmp/Muttrc
        
        ( echo "# GnuPG configuration"; \
          grep '^set' contrib/gpg.rc; \
          echo ) > debian/tmp/gpg.rc
        
-       touch $@
+       # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
+       install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
 
-binary binary-arch: build install
+binary binary-arch: install
+       ###################### binary ######################
        dh_testdir
        dh_testroot
        
@@ -132,9 +144,14 @@ binary binary-arch: build install
        dh_installdocs
        dh_installexamples
        dh_installchangelogs ChangeLog
+       install -m644 debian/mutt.lintian $(CURDIR)/debian/mutt/usr/share/lintian/overrides/mutt
+       
+       dh_strip --dbg-package=mutt-dbg
+       rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
+               $(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
+       mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
        
        dh_link
-       dh_strip
        dh_compress --exclude usr/share/doc/mutt/README.Patches
        dh_fixperms --exclude usr/bin/mutt_dotlock
        dh_installdeb
@@ -143,20 +160,27 @@ binary binary-arch: build install
        dh_md5sums
        dh_builddeb
 
-binary-indep:
+build-indep binary-indep:
        @echo "Nothing to do."
 
 clean: unpatch
+       ###################### clean ######################
        dh_testdir
        dh_testroot
        
        # please dpkg-source
        rm -f po/*.gmo
-       #rm -f config.guess config.sub
        touch PATCHES
        
-       # remove build tree
-       rm -rf $(objdir)
+       # remove build trees
+       rm -rf $(objdir) $(objdir)-patched
+       
+       # remove autotool-generated files so they don't show up in the diff.gz
+       rm -f configure config.h.in
+       rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
+       
+       # clean PATCHES hunks (blame quilt refresh)
+       for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
        
        dh_clean