- 2008-08-02 myon: Refreshed patch using quilt push -f to remove hunks we do
not need (Makefile.in).
---- a/buffy.c
-+++ b/buffy.c
-@@ -292,6 +292,7 @@
+Index: mutt/buffy.c
+===================================================================
+--- mutt.orig/buffy.c 2009-06-25 12:36:44.000000000 +0200
++++ mutt/buffy.c 2009-06-25 12:36:53.000000000 +0200
+@@ -289,6 +289,7 @@
char path[_POSIX_PATH_MAX];
struct stat contex_sb;
time_t t;
sb.st_size=0;
contex_sb.st_dev=0;
-@@ -331,6 +332,8 @@
+@@ -328,6 +329,8 @@
for (tmp = Incoming; tmp; tmp = tmp->next)
{
#ifdef USE_IMAP
if (tmp->magic != M_IMAP)
#endif
-@@ -388,10 +391,27 @@
+@@ -384,10 +387,27 @@
case M_MBOX:
case M_MMDF:
}
else if (option(OPTCHECKMBOXSIZE))
{
-@@ -401,35 +421,86 @@
+@@ -397,35 +417,86 @@
if (tmp->newly_created &&
(sb.st_ctime != sb.st_mtime || sb.st_ctime != sb.st_atime))
tmp->newly_created = 0;
break;
}
}
---- a/buffy.h
-+++ b/buffy.h
+Index: mutt/buffy.h
+===================================================================
+--- mutt.orig/buffy.h 2009-06-24 19:37:58.000000000 +0200
++++ mutt/buffy.h 2009-06-25 12:36:53.000000000 +0200
@@ -25,7 +25,12 @@
char path[_POSIX_PATH_MAX];
off_t size;
short notified; /* user has been notified */
short magic; /* mailbox type */
short newly_created; /* mbox or mmdf just popped into existence */
---- a/color.c
-+++ b/color.c
+Index: mutt/color.c
+===================================================================
+--- mutt.orig/color.c 2009-06-24 19:37:58.000000000 +0200
++++ mutt/color.c 2009-06-25 12:36:53.000000000 +0200
@@ -93,6 +93,8 @@
{ "bold", MT_COLOR_BOLD },
{ "underline", MT_COLOR_UNDERLINE },
{ NULL, 0 }
};
---- a/compose.c
-+++ b/compose.c
+Index: mutt/compose.c
+===================================================================
+--- mutt.orig/compose.c 2009-06-24 19:37:58.000000000 +0200
++++ mutt/compose.c 2009-06-25 12:36:53.000000000 +0200
@@ -72,7 +72,7 @@
#define HDR_XOFFSET 10
mutt_paddstr (W, fcc);
fccSet = 1;
}
---- a/curs_main.c
-+++ b/curs_main.c
+Index: mutt/curs_main.c
+===================================================================
+--- mutt.orig/curs_main.c 2009-06-25 12:36:26.000000000 +0200
++++ mutt/curs_main.c 2009-06-25 12:36:53.000000000 +0200
@@ -26,7 +26,9 @@
#include "mailbox.h"
#include "mapping.h"
default:
if (menu->menu == MENU_MAIN)
km_error_key (MENU_MAIN);
---- a/flags.c
-+++ b/flags.c
+Index: mutt/flags.c
+===================================================================
+--- mutt.orig/flags.c 2009-06-25 12:36:14.000000000 +0200
++++ mutt/flags.c 2009-06-25 12:36:53.000000000 +0200
@@ -22,8 +22,10 @@
#include "mutt.h"
}
void mutt_tag_set_flag (int flag, int bf)
---- a/functions.h
-+++ b/functions.h
+Index: mutt/functions.h
+===================================================================
+--- mutt.orig/functions.h 2009-06-25 12:36:35.000000000 +0200
++++ mutt/functions.h 2009-06-25 12:36:53.000000000 +0200
@@ -169,6 +169,11 @@
{ "decrypt-save", OP_DECRYPT_SAVE, NULL },
{ NULL, 0, NULL }
};
---- a/globals.h
-+++ b/globals.h
+Index: mutt/globals.h
+===================================================================
+--- mutt.orig/globals.h 2009-06-25 12:36:22.000000000 +0200
++++ mutt/globals.h 2009-06-25 12:36:53.000000000 +0200
@@ -117,6 +117,7 @@
WHERE char *SendCharset;
WHERE char *Sendmail;
#ifdef USE_IMAP
WHERE short ImapKeepalive;
WHERE short ImapPipelineDepth;
---- a/init.h
-+++ b/init.h
-@@ -1963,6 +1963,22 @@
+Index: mutt/init.h
+===================================================================
+--- mutt.orig/init.h 2009-06-25 12:36:40.000000000 +0200
++++ mutt/init.h 2009-06-25 12:36:53.000000000 +0200
+@@ -1953,6 +1953,22 @@
** not used.
** (PGP only)
*/
{ "pgp_use_gpg_agent", DT_BOOL, R_NONE, OPTUSEGPGAGENT, 0},
/*
** .pp
---- a/mailbox.h
-+++ b/mailbox.h
+Index: mutt/mailbox.h
+===================================================================
+--- mutt.orig/mailbox.h 2009-06-24 19:37:58.000000000 +0200
++++ mutt/mailbox.h 2009-06-25 12:36:53.000000000 +0200
@@ -27,6 +27,7 @@
#define M_NEWFOLDER (1<<4) /* create a new folder - same as M_APPEND, but uses
* safe_fopen() for mbox-style folders.
/* mx_open_new_message() */
#define M_ADD_FROM 1 /* add a From_ line */
---- a/Makefile.am
-+++ b/Makefile.am
+Index: mutt/Makefile.am
+===================================================================
+--- mutt.orig/Makefile.am 2009-06-25 12:36:26.000000000 +0200
++++ mutt/Makefile.am 2009-06-25 12:36:53.000000000 +0200
@@ -29,7 +29,8 @@
score.c send.c sendlib.c signal.c sort.c \
status.c system.c thread.c charset.c history.c lib.c \
nodist_mutt_SOURCES = $(BUILT_SOURCES)
---- a/mbox.c
-+++ b/mbox.c
+Index: mutt/mbox.c
+===================================================================
+--- mutt.orig/mbox.c 2009-06-25 12:36:45.000000000 +0200
++++ mutt/mbox.c 2009-06-25 12:36:53.000000000 +0200
@@ -104,6 +104,7 @@
mutt_perror (ctx->path);
return (-1);
#ifdef NFS_ATTRIBUTE_HACK
if (sb.st_mtime > sb.st_atime)
---- a/menu.c
-+++ b/menu.c
+Index: mutt/menu.c
+===================================================================
+--- mutt.orig/menu.c 2009-06-25 12:36:19.000000000 +0200
++++ mutt/menu.c 2009-06-25 12:36:53.000000000 +0200
@@ -24,6 +24,7 @@
#include "mutt_curses.h"
#include "mutt_menu.h"
else if (option (OPTBRAILLEFRIENDLY))
move (menu->current - menu->top + menu->offset, 0);
else
---- a/mutt_curses.h
-+++ b/mutt_curses.h
+Index: mutt/mutt_curses.h
+===================================================================
+--- mutt.orig/mutt_curses.h 2009-06-24 19:37:58.000000000 +0200
++++ mutt/mutt_curses.h 2009-06-25 12:36:53.000000000 +0200
@@ -64,6 +64,7 @@
#undef lines
#endif /* lines */
MT_COLOR_MAX
};
---- a/mutt.h
-+++ b/mutt.h
-@@ -426,6 +426,7 @@
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h 2009-06-25 12:36:26.000000000 +0200
++++ mutt/mutt.h 2009-06-25 12:36:53.000000000 +0200
+@@ -425,6 +425,7 @@
OPTSAVEEMPTY,
OPTSAVENAME,
OPTSCORE,
OPTSIGDASHES,
OPTSIGONTOP,
OPTSORTRE,
-@@ -865,6 +866,7 @@
+@@ -864,6 +865,7 @@
{
char *path;
FILE *fp;
time_t mtime;
off_t size;
off_t vsize;
-@@ -905,6 +907,7 @@
+@@ -904,6 +906,7 @@
unsigned int quiet : 1; /* inhibit status messages? */
unsigned int collapsed : 1; /* are all threads collapsed? */
unsigned int closing : 1; /* mailbox is being closed */
/* driver hooks */
void *data; /* driver specific data */
---- a/muttlib.c
-+++ b/muttlib.c
+Index: mutt/muttlib.c
+===================================================================
+--- mutt.orig/muttlib.c 2009-06-25 12:35:48.000000000 +0200
++++ mutt/muttlib.c 2009-06-25 12:36:53.000000000 +0200
@@ -1232,6 +1232,8 @@
pl = pw = 1;
break; /* skip rest of input */
}
else if (ch == '|')
---- a/mx.c
-+++ b/mx.c
+Index: mutt/mx.c
+===================================================================
+--- mutt.orig/mx.c 2009-06-25 12:36:45.000000000 +0200
++++ mutt/mx.c 2009-06-25 12:36:53.000000000 +0200
@@ -595,6 +595,7 @@
* M_APPEND open mailbox for appending
* M_READONLY open mailbox in read-only mode
if (ctx->mx_close)
ctx->mx_close (ctx);
---- a/OPS
-+++ b/OPS
+Index: mutt/OPS
+===================================================================
+--- mutt.orig/OPS 2009-06-25 12:36:14.000000000 +0200
++++ mutt/OPS 2009-06-25 12:36:53.000000000 +0200
@@ -179,3 +179,8 @@
OP_MAIN_SHOW_LIMIT "show currently active limit pattern"
OP_MAIN_COLLAPSE_THREAD "collapse/uncollapse current thread"
+OP_SIDEBAR_NEXT "go down to next mailbox"
+OP_SIDEBAR_PREV "go to previous mailbox"
+OP_SIDEBAR_OPEN "open hilighted mailbox"
---- a/pager.c
-+++ b/pager.c
+Index: mutt/pager.c
+===================================================================
+--- mutt.orig/pager.c 2009-06-25 12:36:14.000000000 +0200
++++ mutt/pager.c 2009-06-25 12:36:53.000000000 +0200
@@ -29,6 +29,7 @@
#include "pager.h"
#include "attach.h"
default:
ch = -1;
break;
---- /dev/null
-+++ b/sidebar.c
+Index: mutt/sidebar.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ mutt/sidebar.c 2009-06-25 12:36:53.000000000 +0200
@@ -0,0 +1,333 @@
+/*
+ * Copyright (C) ????-2004 Justin Hibbits <jrh29@po.cwru.edu>
+ draw_sidebar(menu);
+}
+
---- /dev/null
-+++ b/sidebar.h
+Index: mutt/sidebar.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ mutt/sidebar.h 2009-06-25 12:36:53.000000000 +0200
@@ -0,0 +1,36 @@
+/*
+ * Copyright (C) ????-2004 Justin Hibbits <jrh29@po.cwru.edu>
+void set_buffystats(CONTEXT*);
+
+#endif /* SIDEBAR_H */
---- a/doc/Muttrc
-+++ b/doc/Muttrc
+Index: mutt/doc/Muttrc
+===================================================================
+--- mutt.orig/doc/Muttrc 2009-06-24 19:37:58.000000000 +0200
++++ mutt/doc/Muttrc 2009-06-25 12:36:53.000000000 +0200
@@ -657,6 +657,26 @@
# $crypt_autosign, $crypt_replysign and $smime_is_default.
#
# set crypt_autosign=no
#
# Name: crypt_autosign
---- a/imap/imap.c
-+++ b/imap/imap.c
+Index: mutt/imap/imap.c
+===================================================================
+--- mutt.orig/imap/imap.c 2009-06-24 19:37:58.000000000 +0200
++++ mutt/imap/imap.c 2009-06-25 12:36:53.000000000 +0200
@@ -1521,7 +1521,7 @@
imap_munge_mbox_name (munged, sizeof (munged), name);
if (imap_exec (idata, command, IMAP_CMD_QUEUE) < 0)
{
---- a/imap/command.c
-+++ b/imap/command.c
+Index: mutt/imap/command.c
+===================================================================
+--- mutt.orig/imap/command.c 2009-06-24 19:37:58.000000000 +0200
++++ mutt/imap/command.c 2009-06-25 12:36:53.000000000 +0200
@@ -1009,6 +1009,13 @@
opened */
status->uidnext = oldun;