]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar
debian/patches/mutt-patched/sidebar: added a closedir() so the fds will not be starve...
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar
index be531bccce028ca17a72858b4b947de1b1819782..c48148fc3e5d7b6f1a64a9c9ce7eeae799b4b17b 100644 (file)
@@ -31,151 +31,135 @@ in the "mutt-patched" package.
 
 --- a/buffy.c
 +++ b/buffy.c
-@@ -261,7 +261,7 @@
-   char path[_POSIX_PATH_MAX];
-   struct stat contex_sb;
-   time_t t;
--
-+  CONTEXT *ctx;
- #ifdef USE_IMAP
-   /* update postponed count as well, on force */
-   if (force)
-@@ -296,6 +296,8 @@
-   
-   for (tmp = Incoming; tmp; tmp = tmp->next)
+@@ -312,6 +312,10 @@
+     return 0;
+   }
++  mailbox->msgcount = 0;
++  mailbox->msg_unread = 0;
++  mailbox->msg_flagged = 0;
++
+   while ((de = readdir (dirp)) != NULL)
    {
-+    if ( tmp->new == 1 )
-+      tmp->has_new = 1;
- #ifdef USE_IMAP
-     if (tmp->magic != M_IMAP)
- #endif
-@@ -353,10 +355,27 @@
-       case M_MBOX:
-       case M_MMDF:
+     if (*de->d_name == '.')
+@@ -329,7 +333,9 @@
+         continue;
+       }
+       /* one new and undeleted message is enough */
+-      mailbox->new = 1;
++      mailbox->has_new = mailbox->new = 1;
++      mailbox->msgcount++;
++      mailbox->msg_unread++;
+       rc = 1;
+       break;
+     }
+@@ -337,6 +343,34 @@
  
--      if (STAT_CHECK)
-+        {
-+      if (STAT_CHECK || tmp->msgcount == 0)
-       {
--        BuffyCount++;
--        tmp->new = 1;
-+        BUFFY b = *tmp;
+   closedir (dirp);
++  /*
++   * count read messages (for folderlist (sidebar) we also need to count
++   * messages in cur so that we the total number of messages
++   */
++  snprintf (path, sizeof (path), "%s/cur", mailbox->path);
++  if ((dirp = opendir (path)) == NULL)
++  {
++    mailbox->magic = 0;
++  }
++  while ((de = readdir (dirp)) != NULL)
++  {
++    char *p;
++    if (*de->d_name != '.') {
++      if ((p = strstr (de->d_name, ":2,"))) {
++        if (!strchr (p + 3, 'T')) {
++          mailbox->msgcount++;
++          if ( !strchr (p + 3, 'S'))
++            mailbox->msg_unread++;
++          if (strchr(p + 3, 'F'))
++            mailbox->msg_flagged++;
++        }
++      } else
++        mailbox->msgcount++;
++    }
++  }
++
++  closedir (dirp);
++
+   return rc;
+ }
+@@ -345,14 +379,33 @@
+ {
+   int rc = 0;
+   int statcheck;
++  CONTEXT *ctx;
+   if (option (OPTCHECKMBOXSIZE))
+     statcheck = sb->st_size > mailbox->size;
+   else
+     statcheck = sb->st_mtime > sb->st_atime
+       || (mailbox->newly_created && sb->st_ctime == sb->st_mtime && sb->st_ctime == sb->st_atime);
+-  if (statcheck)
++  if (statcheck || mailbox->msgcount == 0)
+   {
++        BUFFY b = *mailbox;
 +        int msgcount = 0;
 +        int msg_unread = 0;
 +        /* parse the mailbox, to see how much mail there is */
-+        ctx = mx_open_mailbox( tmp->path, M_READONLY | M_QUIET | M_NOSORT | M_PEEK, NULL);
++        ctx = mx_open_mailbox( mailbox->path, M_READONLY | M_QUIET | M_NOSORT | M_PEEK, NULL);
 +        if(ctx)
 +        {
-+            msgcount = ctx->msgcount;
++        msgcount = ctx->msgcount;
 +          msg_unread = ctx->unread;
 +          mx_close_mailbox(ctx, 0);
 +        }
-+        *tmp = b;
-+        tmp->msgcount = msgcount;
-+        tmp->msg_unread = msg_unread;
-+        if(STAT_CHECK) {
-+          tmp->has_new = tmp->new = 1;
-+          BuffyCount++;
-+          }
-       }
-       else if (option(OPTCHECKMBOXSIZE))
-       {
-@@ -366,35 +385,86 @@
-       if (tmp->newly_created &&
-           (sb.st_ctime != sb.st_mtime || sb.st_ctime != sb.st_atime))
-         tmp->newly_created = 0;
--
-+        }
-       break;
-       case M_MAILDIR:
-+        /* count new message */
-       snprintf (path, sizeof (path), "%s/new", tmp->path);
-       if ((dirp = opendir (path)) == NULL)
-       {
-         tmp->magic = 0;
-         break;
-       }
-+      tmp->msgcount = 0;
-+      tmp->msg_unread = 0;
-+      tmp->msg_flagged = 0;
-       while ((de = readdir (dirp)) != NULL)
-       {
-         char *p;
-         if (*de->d_name != '.' && 
-             (!(p = strstr (de->d_name, ":2,")) || !strchr (p + 3, 'T')))
-         {
--          /* one new and undeleted message is enough */
--          BuffyCount++;
--          tmp->new = 1;
--          break;
-+          tmp->has_new = tmp->new = 1;
-+            tmp->msgcount++;
-+            tmp->msg_unread++;
-+        }
-+      }
-+        if(tmp->msg_unread)
-+          BuffyCount++;
-+
-+      closedir (dirp);
-+
-+        /*
-+         * count read messages (for folderlist (sidebar) we also need to count
-+         * messages in cur so that we the total number of messages
-+         */
-+      snprintf (path, sizeof (path), "%s/cur", tmp->path);
-+      if ((dirp = opendir (path)) == NULL)
-+      {
-+        tmp->magic = 0;
-+        break;
-+      }
-+      while ((de = readdir (dirp)) != NULL)
-+      {
-+        char *p;
-+          if (*de->d_name != '.') {
-+                  if ((p = strstr (de->d_name, ":2,"))) {
-+                          if (!strchr (p + 3, 'T')) {
-+                                  tmp->msgcount++;
-+                                  if ( !strchr (p + 3, 'S'))
-+                                          tmp->msg_unread++;
-+                                  if (strchr(p + 3, 'F'))
-+                                          tmp->msg_flagged++;
-+                          }
-+                  } else
-+                          tmp->msgcount++;
-         }
-       }
-       closedir (dirp);
-       break;
++        *mailbox = b;
++        mailbox->msgcount = msgcount;
++        mailbox->msg_unread = msg_unread;
++        if(statcheck)
++      {
++          mailbox->has_new = mailbox->new = 1;
++      }
+     if (!option(OPTMAILCHECKRECENT) || sb->st_mtime > mailbox->last_visited)
+     {
+       rc = 1;
+@@ -374,9 +427,11 @@
+ int mutt_buffy_check (int force)
+ {
+   BUFFY *tmp;
++  struct dirent *de, *dp;
+   struct stat sb;
+   struct stat contex_sb;
+   time_t t;
++  CONTEXT *ctx;
  
+   sb.st_size=0;
+   contex_sb.st_dev=0;
+@@ -456,6 +511,20 @@
        case M_MH:
-+      {
-+      DIR *dp;
-+      struct dirent *de;
        if ((tmp->new = mh_buffy (tmp->path)) > 0)
          BuffyCount++;
 +
-+      if ((dp = opendir (path)) == NULL)
-+        break;
-+      tmp->msgcount = 0;
-+      while ((de = readdir (dp)))
-+      {
-+        if (mh_valid_message (de->d_name))
-+        {
-+        tmp->msgcount++;
-+        tmp->has_new = tmp->new = 1;
-+        }
-+      }
-+      closedir (dp);
-+      }
++  if ((dp = opendir (tmp->path)) == NULL)
++    break;
++  tmp->msgcount = 0;
++  while ((de = readdir (dp)))
++  {
++    if (mh_valid_message (de->d_name))
++    {
++      tmp->msgcount++;
++      tmp->has_new = tmp->new = 1;
++    }
++  }
++  closedir (dp);
++
        break;
        }
      }
 --- a/buffy.h
 +++ b/buffy.h
 @@ -25,7 +25,12 @@
-   char *path;
+   char path[_POSIX_PATH_MAX];
    off_t size;
    struct buffy_t *next;
 +  struct buffy_t *prev;
@@ -209,38 +193,25 @@ in the "mutt-patched" package.
  
  static char *Prompts[] =
  {
-@@ -115,16 +115,16 @@
-   if ((WithCrypto & APPLICATION_PGP) && (WithCrypto & APPLICATION_SMIME))
-   {     
-     if (!msg->security)
--      mvaddstr (HDR_CRYPT, 0,     "Security: ");
-+      mvaddstr (HDR_CRYPT, SidebarWidth,     "Security: ");
-     else if (msg->security & APPLICATION_SMIME)
--      mvaddstr (HDR_CRYPT, 0,     "  S/MIME: ");
-+      mvaddstr (HDR_CRYPT, SidebarWidth,     "  S/MIME: ");
-     else if (msg->security & APPLICATION_PGP)
--      mvaddstr (HDR_CRYPT, 0,     "     PGP: ");
-+      mvaddstr (HDR_CRYPT, SidebarWidth,     "     PGP: ");
+@@ -112,7 +112,7 @@
+ {
+   int off = 0;
+-  mvaddstr (HDR_CRYPT, 0, "Security: ");
++  mvaddstr (HDR_CRYPT, SidebarWidth,     "Security: ");
+   if ((WithCrypto & (APPLICATION_PGP | APPLICATION_SMIME)) == 0)
+   {
+@@ -144,7 +144,7 @@
    }
-   else if ((WithCrypto & APPLICATION_SMIME))
--    mvaddstr (HDR_CRYPT, 0,     "  S/MIME: ");
-+    mvaddstr (HDR_CRYPT, SidebarWidth,     "  S/MIME: ");
-   else if ((WithCrypto & APPLICATION_PGP))
--    mvaddstr (HDR_CRYPT, 0,     "     PGP: ");
-+    mvaddstr (HDR_CRYPT, SidebarWidth,     "     PGP: ");
-   else
-     return;
  
-@@ -148,7 +148,7 @@
-     }
    clrtoeol ();
 -  move (HDR_CRYPTINFO, 0);
 +  move (HDR_CRYPTINFO, SidebarWidth);
    clrtoeol ();
    if ((WithCrypto & APPLICATION_PGP)
-       && msg->security & APPLICATION_PGP  && msg->security & SIGN)
-@@ -164,7 +164,7 @@
+@@ -161,7 +161,7 @@
        && (msg->security & ENCRYPT)
        && SmimeCryptAlg
        && *SmimeCryptAlg) {
@@ -249,7 +220,7 @@ in the "mutt-patched" package.
                NONULL(SmimeCryptAlg));
        off = 20;
    }
-@@ -178,7 +178,7 @@
+@@ -175,7 +175,7 @@
    int c;
    char *t;
  
@@ -258,7 +229,7 @@ in the "mutt-patched" package.
  
    if (!chain)
    {
-@@ -193,7 +193,7 @@
+@@ -190,7 +190,7 @@
      if (t && t[0] == '0' && t[1] == '\0')
        t = "<random>";
      
@@ -267,7 +238,7 @@ in the "mutt-patched" package.
        break;
  
      addstr (NONULL(t));
-@@ -245,7 +245,7 @@
+@@ -242,7 +242,7 @@
  
    buf[0] = 0;
    rfc822_write_address (buf, sizeof (buf), addr, 1);
@@ -276,7 +247,7 @@ in the "mutt-patched" package.
    mutt_paddstr (W, buf);
  }
  
-@@ -255,10 +255,10 @@
+@@ -252,10 +252,10 @@
    draw_envelope_addr (HDR_TO, msg->env->to);
    draw_envelope_addr (HDR_CC, msg->env->cc);
    draw_envelope_addr (HDR_BCC, msg->env->bcc);
@@ -289,7 +260,7 @@ in the "mutt-patched" package.
    mutt_paddstr (W, fcc);
  
    if (WithCrypto)
-@@ -269,7 +269,7 @@
+@@ -266,7 +266,7 @@
  #endif
  
    SETCOLOR (MT_COLOR_STATUS);
@@ -298,7 +269,7 @@ in the "mutt-patched" package.
    BKGDSET (MT_COLOR_STATUS);
    clrtoeol ();
  
-@@ -307,7 +307,7 @@
+@@ -304,7 +304,7 @@
    /* redraw the expanded list so the user can see the result */
    buf[0] = 0;
    rfc822_write_address (buf, sizeof (buf), *addr, 1);
@@ -307,7 +278,7 @@ in the "mutt-patched" package.
    mutt_paddstr (W, buf);
    
    return 0;
-@@ -552,7 +552,7 @@
+@@ -549,7 +549,7 @@
        if (mutt_get_field ("Subject: ", buf, sizeof (buf), 0) == 0)
        {
          mutt_str_replace (&msg->env->subject, buf);
@@ -316,7 +287,7 @@ in the "mutt-patched" package.
          clrtoeol ();
          if (msg->env->subject)
            mutt_paddstr (W, msg->env->subject);
-@@ -569,7 +569,7 @@
+@@ -566,7 +566,7 @@
        {
          strfcpy (fcc, buf, fcclen);
          mutt_pretty_mailbox (fcc, fcclen);
@@ -337,7 +308,7 @@ in the "mutt-patched" package.
  
  #ifdef USE_POP
  #include "pop.h"
-@@ -536,8 +538,12 @@
+@@ -532,8 +534,12 @@
         menu->redraw |= REDRAW_STATUS;
       if (do_buffy_notify)
       {
@@ -352,7 +323,7 @@ in the "mutt-patched" package.
       }
       else
         do_buffy_notify = 1;
-@@ -549,6 +555,7 @@
+@@ -545,6 +551,7 @@
      if (menu->redraw & REDRAW_FULL)
      {
        menu_redraw_full (menu);
@@ -360,9 +331,9 @@ in the "mutt-patched" package.
        mutt_show_error ();
      }
  
-@@ -571,10 +578,13 @@
+@@ -567,10 +574,13 @@
  
-       if (menu->redraw & REDRAW_STATUS) 
+       if (menu->redraw & REDRAW_STATUS)
        {
 +        DrawFullLine = 1;
        menu_status_line (buf, sizeof (buf), menu, NONULL (Status));
@@ -374,7 +345,7 @@ in the "mutt-patched" package.
        mutt_paddstr (COLS, buf);
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
-@@ -595,7 +605,7 @@
+@@ -591,7 +601,7 @@
        menu->oldcurrent = -1;
  
        if (option (OPTARROWCURSOR))
@@ -383,15 +354,15 @@ in the "mutt-patched" package.
        else if (option (OPTBRAILLEFRIENDLY))
        move (menu->current - menu->top + menu->offset, 0);
        else
-@@ -1068,6 +1078,7 @@
+@@ -1089,6 +1099,7 @@
          menu->redraw = REDRAW_FULL;
        break;
  
 +      case OP_SIDEBAR_OPEN:
        case OP_MAIN_CHANGE_FOLDER:
        case OP_MAIN_NEXT_UNREAD_MAILBOX:
-       
-@@ -1099,7 +1110,11 @@
+@@ -1120,7 +1131,11 @@
        {
          mutt_buffy (buf, sizeof (buf));
  
@@ -404,7 +375,7 @@ in the "mutt-patched" package.
          {
            if (menu->menu == MENU_PAGER)
            {
-@@ -1117,6 +1132,7 @@
+@@ -1138,6 +1153,7 @@
        }
  
        mutt_expand_path (buf, sizeof (buf));
@@ -412,7 +383,7 @@ in the "mutt-patched" package.
        if (mx_get_magic (buf) <= 0)
        {
          mutt_error (_("%s is not a mailbox."), buf);
-@@ -2209,6 +2225,12 @@
+@@ -2241,6 +2257,12 @@
        mutt_what_key();
        break;
  
@@ -448,7 +419,7 @@ in the "mutt-patched" package.
  void mutt_tag_set_flag (int flag, int bf)
 --- a/functions.h
 +++ b/functions.h
-@@ -169,6 +169,11 @@
+@@ -170,6 +170,11 @@
    { "decrypt-save",           OP_DECRYPT_SAVE,                NULL },
  
  
@@ -460,7 +431,7 @@ in the "mutt-patched" package.
    { NULL,                     0,                              NULL }
  };
  
-@@ -268,6 +273,11 @@
+@@ -274,6 +279,11 @@
  
    { "what-key",               OP_WHAT_KEY,            NULL },
  
@@ -474,7 +445,7 @@ in the "mutt-patched" package.
  
 --- a/globals.h
 +++ b/globals.h
-@@ -116,6 +116,7 @@
+@@ -117,6 +117,7 @@
  WHERE char *SendCharset;
  WHERE char *Sendmail;
  WHERE char *Shell;
@@ -482,7 +453,7 @@ in the "mutt-patched" package.
  WHERE char *Signature;
  WHERE char *SimpleSearch;
  #if USE_SMTP
-@@ -208,6 +209,9 @@
+@@ -210,6 +211,9 @@
  WHERE short ScoreThresholdRead;
  WHERE short ScoreThresholdFlag;
  
@@ -494,9 +465,9 @@ in the "mutt-patched" package.
  WHERE short ImapPipelineDepth;
 --- a/init.h
 +++ b/init.h
-@@ -1594,6 +1594,22 @@
-   ** you may \fIunset\fP this setting.
-   ** (Crypto only)
+@@ -1965,6 +1965,22 @@
+   ** not used.
+   ** (PGP only)
    */
 +  {"sidebar_delim", DT_STR, R_BOTH, UL &SidebarDelim, "|"},
 +  /*
@@ -529,13 +500,13 @@ in the "mutt-patched" package.
  #define M_ADD_FROM    1       /* add a From_ line */
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -29,7 +29,8 @@
+@@ -33,7 +33,8 @@
        score.c send.c sendlib.c signal.c sort.c \
        status.c system.c thread.c charset.c history.c lib.c \
        muttlib.c editmsg.c mbyte.c \
--      url.c ascii.c crypt-mod.c crypt-mod.h
-+      url.c ascii.c crypt-mod.c crypt-mod.h \
-+        sidebar.c
+-      url.c ascii.c crypt-mod.c crypt-mod.h safe_asprintf.c
++      url.c ascii.c crypt-mod.c crypt-mod.h safe_asprintf.c \
++    sidebar.c
  
  nodist_mutt_SOURCES = $(BUILT_SOURCES)
  
@@ -549,7 +520,7 @@ in the "mutt-patched" package.
    ctx->mtime = sb.st_mtime;
    ctx->size = sb.st_size;
  
-@@ -259,6 +260,7 @@
+@@ -255,6 +256,7 @@
  
    ctx->size = sb.st_size;
    ctx->mtime = sb.st_mtime;
@@ -653,7 +624,7 @@ in the "mutt-patched" package.
    menu_make_entry (buf, sizeof (buf), menu, menu->current);
    menu_pad_string (buf, sizeof (buf));
  
-@@ -886,7 +888,7 @@
+@@ -884,7 +886,7 @@
      
      
      if (option (OPTARROWCURSOR))
@@ -683,7 +654,7 @@ in the "mutt-patched" package.
  
 --- a/mutt.h
 +++ b/mutt.h
-@@ -417,6 +417,7 @@
+@@ -431,6 +431,7 @@
    OPTSAVEEMPTY,
    OPTSAVENAME,
    OPTSCORE,
@@ -691,7 +662,7 @@ in the "mutt-patched" package.
    OPTSIGDASHES,
    OPTSIGONTOP,
    OPTSORTRE,
-@@ -854,6 +855,7 @@
+@@ -874,6 +875,7 @@
  {
    char *path;
    FILE *fp;
@@ -699,7 +670,7 @@ in the "mutt-patched" package.
    time_t mtime;
    off_t size;
    off_t vsize;
-@@ -894,6 +896,7 @@
+@@ -914,6 +916,7 @@
    unsigned int quiet : 1;     /* inhibit status messages? */
    unsigned int collapsed : 1;   /* are all threads collapsed? */
    unsigned int closing : 1;   /* mailbox is being closed */
@@ -709,7 +680,7 @@ in the "mutt-patched" package.
    void *data;                 /* driver specific data */
 --- a/muttlib.c
 +++ b/muttlib.c
-@@ -1217,6 +1217,8 @@
+@@ -1286,6 +1286,8 @@
          pl = pw = 1;
  
        /* see if there's room to add content, else ignore */
@@ -718,7 +689,7 @@ in the "mutt-patched" package.
        if ((col < COLS && wlen < destlen) || soft)
        {
          int pad;
-@@ -1259,6 +1261,52 @@
+@@ -1329,6 +1331,52 @@
          col += wid;
          src += pl;
        }
@@ -773,7 +744,7 @@ in the "mutt-patched" package.
        else if (ch == '|')
 --- a/mx.c
 +++ b/mx.c
-@@ -626,6 +626,7 @@
+@@ -595,6 +595,7 @@
   *            M_APPEND        open mailbox for appending
   *            M_READONLY      open mailbox in read-only mode
   *            M_QUIET         only print error messages
@@ -781,7 +752,7 @@ in the "mutt-patched" package.
   *    ctx     if non-null, context struct to use
   */
  CONTEXT *mx_open_mailbox (const char *path, int flags, CONTEXT *pctx)
-@@ -648,6 +649,8 @@
+@@ -617,6 +618,8 @@
      ctx->quiet = 1;
    if (flags & M_READONLY)
      ctx->readonly = 1;
@@ -790,7 +761,7 @@ in the "mutt-patched" package.
  
    if (flags & (M_APPEND|M_NEWFOLDER))
    {
-@@ -752,9 +755,21 @@
+@@ -721,9 +724,21 @@
  void mx_fastclose_mailbox (CONTEXT *ctx)
  {
    int i;
@@ -810,11 +781,11 @@ in the "mutt-patched" package.
 +  }
 +#endif
  
-   if (ctx->mx_close)
-     ctx->mx_close (ctx);
+   /* never announce that a mailbox we've just left has new mail. #3290
+    * XXX: really belongs in mx_close_mailbox, but this is a nice hook point */
 --- a/OPS
 +++ b/OPS
-@@ -179,3 +179,8 @@
+@@ -180,3 +180,8 @@
  OP_MAIN_SHOW_LIMIT "show currently active limit pattern"
  OP_MAIN_COLLAPSE_THREAD "collapse/uncollapse current thread"
  OP_MAIN_COLLAPSE_ALL "collapse/uncollapse all threads"
@@ -833,16 +804,15 @@ in the "mutt-patched" package.
  
  #include "mutt_crypt.h"
  
-@@ -1060,6 +1061,8 @@
-   mbstate_t mbstate;
+@@ -1099,6 +1100,7 @@
+   if (check_attachment_marker ((char *)buf) == 0)
+     wrap_cols = COLS;
  
-   int wrap_cols = mutt_term_width ((flags & M_PAGER_NOWRAP) ? 0 : Wrap);
-+
 +  wrap_cols -= SidebarWidth;
-   
    /* FIXME: this should come from lineInfo */
    memset(&mbstate, 0, sizeof(mbstate));
-@@ -1694,7 +1697,7 @@
+@@ -1745,7 +1747,7 @@
      if ((redraw & REDRAW_BODY) || topline != oldtopline)
      {
        do {
@@ -851,7 +821,7 @@ in the "mutt-patched" package.
        curline = oldtopline = topline;
        lines = 0;
        force_redraw = 0;
-@@ -1707,6 +1710,7 @@
+@@ -1758,6 +1760,7 @@
                            &QuoteList, &q_level, &force_redraw, &SearchRE) > 0)
            lines++;
          curline++;
@@ -859,7 +829,7 @@ in the "mutt-patched" package.
        }
        last_offset = lineInfo[curline].offset;
        } while (force_redraw);
-@@ -1720,6 +1724,7 @@
+@@ -1771,6 +1774,7 @@
          addch ('~');
        addch ('\n');
        lines++;
@@ -867,34 +837,30 @@ in the "mutt-patched" package.
        }
        /* We are going to update the pager status bar, so it isn't
         * necessary to reset to normal color now. */
-@@ -1743,22 +1748,22 @@
+@@ -1794,11 +1798,11 @@
        /* print out the pager status bar */
        SETCOLOR (MT_COLOR_STATUS);
        BKGDSET (MT_COLOR_STATUS);
 -      CLEARLINE (statusoffset);
 +      CLEARLINE_WIN (statusoffset);
-       if (IsHeader (extra))
+       if (IsHeader (extra) || IsMsgAttach (extra))
        {
 -      size_t l1 = COLS * MB_LEN_MAX;
-+      size_t l1 = (COLS-SidebarWidth) * MB_LEN_MAX;
++      size_t l1 = (COLS-SidebarWidth) * MB_LEN_MAX;
        size_t l2 = sizeof (buffer);
-       hfi.hdr = extra->hdr;
+       hfi.hdr = (IsHeader (extra)) ? extra->hdr : extra->bdy->hdr;
        mutt_make_string_info (buffer, l1 < l2 ? l1 : l2, NONULL (PagerFmt), &hfi, M_FORMAT_MAKEPRINT);
-       }
-       else if (IsMsgAttach (extra))
+@@ -1808,7 +1812,7 @@
        {
--      size_t l1 = COLS * MB_LEN_MAX;
-+      size_t l1 = (COLS-SidebarWidth) * MB_LEN_MAX;
-       size_t l2 = sizeof (buffer);
-       hfi.hdr = extra->bdy->hdr;
-       mutt_make_string_info (buffer, l1 < l2 ? l1 : l2, NONULL (PagerFmt), &hfi, M_FORMAT_MAKEPRINT);
+       char bn[STRING];
+       snprintf (bn, sizeof (bn), "%s (%s)", banner, pager_progress_str);
+-      mutt_paddstr (COLS, bn);
++        mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
        }
--      mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
-+      mutt_paddstr (COLS-SidebarWidth, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
-       if (option(OPTXTERMSETTITLES))
-@@ -1775,18 +1780,23 @@
+@@ -1826,18 +1830,23 @@
        /* redraw the pager_index indicator, because the
         * flags for this message might have changed. */
        menu_redraw_current (index);
@@ -920,7 +886,7 @@ in the "mutt-patched" package.
      redraw = 0;
  
      if (option(OPTBRAILLEFRIENDLY)) {
-@@ -2684,6 +2694,13 @@
+@@ -2769,6 +2778,13 @@
        mutt_what_key ();
        break;
  
@@ -1311,8 +1277,8 @@ in the "mutt-patched" package.
 +#endif /* SIDEBAR_H */
 --- a/doc/Muttrc
 +++ b/doc/Muttrc
-@@ -2167,6 +2167,26 @@
- # function.
+@@ -657,6 +657,26 @@
+ # $crypt_autosign, $crypt_replysign and $smime_is_default.
  # 
  # 
 +# set sidebar_visible=no
@@ -1340,7 +1306,7 @@ in the "mutt-patched" package.
  # Name: crypt_autosign
 --- a/imap/imap.c
 +++ b/imap/imap.c
-@@ -1513,7 +1513,7 @@
+@@ -1527,7 +1527,7 @@
  
      imap_munge_mbox_name (munged, sizeof (munged), name);
      snprintf (command, sizeof (command),
@@ -1351,7 +1317,7 @@ in the "mutt-patched" package.
      {
 --- a/imap/command.c
 +++ b/imap/command.c
-@@ -1009,6 +1009,13 @@
+@@ -1011,6 +1011,13 @@
             opened */
          status->uidnext = oldun;
  
@@ -1365,7 +1331,3 @@ in the "mutt-patched" package.
          FREE (&value);
          return;
        }
---- a/PATCHES
-+++ b/PATCHES
-@@ -0,0 +1 @@
-+patch-1.5.19.sidebar.20090522.txt