1 changeset: 5421:f5fe657f0633
3 user: Brendan Cully <brendan@kublai.com>
4 date: Tue Jun 24 23:12:02 2008 -0700
5 summary: Make multipart decoding a little more forgiving.
7 #diff -r a2e8f6fab8d3 -r f5fe657f0633 ChangeLog
8 #--- a/ChangeLog Thu Jan 01 00:00:00 1970 +0000
9 #+++ b/ChangeLog Tue Jun 24 23:12:02 2008 -0700
11 #+1970-01-01 00:00 +0000 Brendan Cully <brendan@kublai.com> (a2e8f6fab8d3)
13 #+ * smtp.c: Test that envelope from or from is set before attempting
14 #+ SMTP delivery. Closes #3079.
16 #+2008-06-14 18:23 -0700 Christoph Berg <cb@df7cb.de> (4b790909a037)
18 #+ * doc/mbox.man: Document that From_ lines use asctime-style dates,
19 #+ not RFC2822 dates. Closes #3077.
21 # 2008-06-11 22:45 -0700 Alexey I. Froloff <raorn@altlinux.org> (1e8ca708a52f)
23 # * attach.c: Do not attempt to close invalid descriptors. Closes #3075
24 diff -r a2e8f6fab8d3 -r f5fe657f0633 handler.c
25 --- a/handler.c Thu Jan 01 00:00:00 1970 +0000
26 +++ b/handler.c Tue Jun 24 23:12:02 2008 -0700
27 @@ -1199,11 +1199,12 @@
31 + mutt_error ("One or more parts of this message could not be displayed");
32 dprint (1, (debugfile, "Failed on attachment #%d, type %s/%s.\n", count, TYPE(p), NONULL (p->subtype)));
35 - if (rc || ((s->flags & M_REPLYING)
36 - && (option (OPTINCLUDEONLYFIRST)) && (s->flags & M_FIRSTDONE)))
37 + if ((s->flags & M_REPLYING)
38 + && (option (OPTINCLUDEONLYFIRST)) && (s->flags & M_FIRSTDONE))
42 @@ -1564,6 +1565,14 @@
45 handler = multipart_handler;
47 + if (b->encoding != ENC7BIT && b->encoding != ENC8BIT
48 + && b->encoding != ENCBINARY)
50 + dprint (1, (debugfile, "Bad encoding type %d for multipart entity, "
51 + "assuming 7 bit\n", b->encoding));
52 + b->encoding = ENC7BIT;
55 else if (WithCrypto && b->type == TYPEAPPLICATION)