1 patch to escape all hyphen so they will be interpreted as minus
2 signs and lintian will not complain
7 lines by prepending a '>' (i.e. ">From ", ">>From ", ...). The later
8 has the advantage that lines like
10 ->From the command line you can use the '-p' option
11 +>From the command line you can use the '\-p' option
13 aren't dequoted wrongly as a \fBMBOXRD\fP-MDA would turn the line
16 ->>From the command line you can use the '-p' option
17 +>>From the command line you can use the '\-p' option
19 before storing it. Besides \fBMBOXO\fP and \fBMBOXRD\fP there is also
20 -\fBMBOXCL\fP which is \fBMBOXO\fP with a "Content-Length:"-field with the
21 +\fBMBOXCL\fP which is \fBMBOXO\fP with a "Content-Length:"\-field with the
22 number of bytes in the message body; some MUAs (like
24 do automatically transform \fBMBOXO\fP mailboxes into \fBMBOXCL\fP ones when
29 >From what I learned about the MMDF-format:
36 In contrast to most other single file mailbox formats like
39 -there is no need to quote/dequote "From "-lines in
40 +there is no need to quote/dequote "From "\-lines in
42 mailboxes as such lines have no special meaning in this format.
51 -[-e \fIcmd\fP] [-F \fIfile\fP] [-m \fItype\fP] [-f \fIfile\fP]
53 +[\-e \fIcmd\fP] [\-F \fIfile\fP] [\-m \fItype\fP] [\-f \fIfile\fP]
72 [\-a \fIfile\fP [...]]
89 [\-a \fIfile\fP [...]]
95 -[-n] [-e \fIcmd\fP] [-F \fIfile\fP] -p
96 +[\-n] [\-e \fIcmd\fP] [\-F \fIfile\fP] \-p
99 -[-n] [-e \fIcmd\fP] [-F \fIfile\fP] -A \fIalias\fP
100 +[\-n] [\-e \fIcmd\fP] [\-F \fIfile\fP] \-A \fIalias\fP
103 -[-n] [-e \fIcmd\fP] [-F \fIfile\fP] -Q \fIquery\fP
104 +[\-n] [\-e \fIcmd\fP] [\-F \fIfile\fP] \-Q \fIquery\fP
115 Mutt is a small but very powerful text based program for reading and sending electronic
116 @@ -134,12 +134,12 @@
117 Start Mutt with a listing of all mailboxes specified by the \fImailboxes\fP
120 -When used with -f, causes Mutt not to start if there are no messages in the
121 +When used with \-f, causes Mutt not to start if there are no messages in the
124 Causes Mutt to open the first mailbox specified by the \fImailboxes\fP
125 command which contains new mail.
128 Treat remaining arguments as \fIaddr\fP even if they start with a dash.
129 See also "\-a" above.
131 --- a/doc/dotlock.man
132 +++ b/doc/dotlock.man
137 -[-t|-f|-u|-d] [-p] [-r \fIretries\fP] \fIfile\fP
138 +[\-t|\-f|\-u|\-d] [\-p] [\-r \fIretries\fP] \fIfile\fP
144 @@ -2874,7 +2874,7 @@
145 ** smtp[s]://[user[:pass]@]host[:port]/
148 - ** ... where ``[...]'' denotes an optional part.
149 + ** \.\.\. where ``[...]'' denotes an optional part.
150 ** Setting this variable overrides the value of the $$sendmail
156 fputs ("\\(rq", out);
159 + else if (*v == '-')
160 + fputs ("\\-", out);
165 man_print_strval (val, out);
166 fputs ("\\(rq\n", out);
169 - fprintf (out, "Default: %s\n", val);
171 + fputs ("Default: ", out);
172 + man_print_strval (val, out);
178 @@ -1040,6 +1045,8 @@
179 fputs ("\\(rq", out);
180 else if (*str == '\\')
182 + else if (*str == '-')
183 + fputs ("\\-", out);
184 else if (!strncmp (str, "``", 2))
186 fputs ("\\(lq", out);