]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/530887-dovecot-imap.patch
fixes two problems with subdirs on dovecot (Closes: 530671, 530887)
[software/mutt-debian.git] / debian / patches / upstream / 530887-dovecot-imap.patch
1 --- a/imap/util.c
2 +++ b/imap/util.c
3 @@ -393,19 +393,19 @@
4      size_t plen)
5  {
6    int i = 0;
7 -  char delim;
8 +  char delim = '\0';
9    
10    if (idata)
11      delim = idata->delim;
12 -  else if (ImapDelimChars && ImapDelimChars[0])
13 -    delim = ImapDelimChars[0];
14 -  else
15 -    delim = '/';
16  
17    while (mailbox && *mailbox && i < plen - 1)
18    {
19 -    if (strchr(ImapDelimChars, *mailbox) || *mailbox == delim)
20 +    if ((ImapDelimChars && strchr(ImapDelimChars, *mailbox)) 
21 +        || *mailbox == delim)
22      {
23 +      /* use connection delimiter if known. Otherwise use user delimiter */
24 +      if (!idata)
25 +        delim = *mailbox; 
26        while (*mailbox &&
27              (strchr(ImapDelimChars, *mailbox) || *mailbox == delim))
28          mailbox++;