]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/Muttrc
New upstream version.
[software/mutt-debian.git] / debian / patches / debian-specific / Muttrc
1 # vim:ft=diff
2
3  * 2009-01-15 myon: refreshed for mutt-1.5.19; drop our list of ignored headers
4    in favor of upstream's new unignore list
5
6 --- a/doc/Muttrc.head
7 +++ b/doc/Muttrc.head
8 @@ -12,6 +12,32 @@ unignore from: subject to cc date x-mail
9  # Display the fields in this order
10  hdr_order date from to cc subject
11  
12 +# emacs-like bindings
13 +bind editor    "\e<delete>"    kill-word
14 +bind editor    "\e<backspace>" kill-word
15 +
16 +# map delete-char to a sane value
17 +bind editor     <delete>  delete-char
18 +
19 +# some people actually like these settings
20 +#set pager_stop
21 +#bind pager <up> previous-line
22 +#bind pager <down> next-line
23 +
24 +# Specifies how to sort messages in the index menu.
25 +set sort=threads
26 +
27 +# Uncomment if your MTA does not strip Bcc: headers.
28 +# (exim4 and postfix strip them, exim(3) does not.)
29 +#unset write_bcc
30 +# Postfix and qmail use Delivered-To for detecting loops
31 +unset bounce_delivered
32 +
33 +set mixmaster="mixmaster-filter"
34 +
35 +# System-wide CA file managed by the ca-certificates package
36 +set ssl_ca_certificates_file="/etc/ssl/certs/ca-certificates.crt"
37 +
38  # imitate the old search-body function
39  macro index \eb "<search>~b " "search in message bodies"
40  
41 @@ -23,7 +49,7 @@ macro index,pager,attach,compose \cb "\
42  "call urlview to extract URLs out of a message"
43  
44  # Show documentation when pressing F1
45 -macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
46 +macro generic,pager <F1> "<shell-escape> zcat @docdir@/mutt/manual.txt.gz | sensible-pager<enter>" "show Mutt documentation"
47  
48  # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
49  macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
50 @@ -35,7 +61,7 @@ bind browser y exit
51  # append-hook \\.gz$ "gzip -c %t >> %f"
52  
53  # If Mutt is unable to determine your site's domain name correctly, you can
54 -# set the default here.
55 +# set the default here. (better: fix /etc/mailname)
56  #
57  # set hostname=cs.hmc.edu
58  
59 @@ -101,6 +127,9 @@ attachments   +I text/plain
60  attachments   -A message/external-body
61  attachments   -I message/external-body
62  
63 +# enable mime lookup by extension
64 +mime_lookup application/octet-stream
65 +
66  ##
67  ## More settings
68  ##