]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/use_usr_bin_editor.diff
refreshed a bunch of patches against 1.5.19
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
1 --- a/init.c
2 +++ b/init.c
3 @@ -3114,7 +3114,7 @@ void mutt_init (int skip_sys_rc, LIST *c
4    {
5      p = getenv ("EDITOR");
6      if (!p)
7 -      p = "vi";
8 +      p = "/usr/bin/editor";
9    }
10    Editor = safe_strdup (p);
11    Visual = safe_strdup (p);
12 --- a/init.h
13 +++ b/init.h
14 @@ -589,7 +589,7 @@ struct option_t MuttVars[] = {
15    ** .pp
16    ** This variable specifies which editor is used by mutt.
17    ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
18 -  ** variable, or to the string ``vi'' if neither of those are set.
19 +  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
20    */
21    { "encode_from",     DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
22    /*