]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/mutt-patched/sidebar-compat-revert.debian
typo in my patch :-(
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-compat-revert.debian
1 # vim:ft=diff:
2 The sidebar and maildir-mtime patches touch the same part of buffy.c and
3 generate a non-trivial conflict. This patch reverts the affected hunk from the
4 maildir-mtime patch so we can cleanly apply the sidebar patch from the patch
5 upstream site. While we are at it, we also revert the trivial buffy.h change.
6
7 Previously, the mutt maintainer would manually re-resolve the conflict for each
8 new sidebar patch version which turned out to be too error-prone.
9 (cf. #484537, #484538)
10
11 [see sidebar-compat-apply for part 2]
12 --- a/buffy.c
13 +++ b/buffy.c
14 @@ -418,20 +418,10 @@
15           if (*de->d_name != '.' && 
16               (!(p = strstr (de->d_name, ":2,")) || !strchr (p + 3, 'T')))
17           {
18 -           if (!tmp->new)
19 -           {
20 -             /* one new and undeleted message is enough */
21 -             BuffyCount++;
22 -             tmp->new = 1;
23 -
24 -             if (! option (OPTMAILDIRMTIME)) /* prevent stat calls */
25 -               break;
26 -           }
27 -           snprintf (path, sizeof (path), "%s/new/%s", tmp->path, de->d_name);
28 -           if (!stat (path, &smd) && smd.st_mtime > tmp->mtime)
29 -           {
30 -             tmp->mtime = smd.st_mtime;
31 -           }
32 +           /* one new and undeleted message is enough */
33 +           BuffyCount++;
34 +           tmp->new = 1;
35 +           break;
36           }
37         }
38         closedir (dirp);
39 --- a/buffy.h
40 +++ b/buffy.h
41 @@ -25,7 +25,6 @@
42    char path[_POSIX_PATH_MAX];
43    off_t size;
44    struct buffy_t *next;
45 -  time_t mtime;                        /* for maildirs...time of newest entry */
46    short new;                   /* mailbox has new mail */
47    short notified;              /* user has been notified */
48    short magic;                 /* mailbox type */