1 This patch fixes the following two bugs:
2 *) http://bugs.debian.org/530887
3 mutt: fails to move read messages even with move=yes
5 *) http://bugs.debian.org/530671
6 mutt: does not want to open dot subdirs via imap anymore
8 the second one happens with dovecot which uses / as a delimeter for mailbox,
9 so without this patch is not possible to access subdirs on imap accounts
23 - else if (ImapDelimChars && ImapDelimChars[0])
24 - delim = ImapDelimChars[0];
28 while (mailbox && *mailbox && i < plen - 1)
30 - if (strchr(ImapDelimChars, *mailbox) || *mailbox == delim)
31 + if ((ImapDelimChars && strchr(ImapDelimChars, *mailbox))
32 + || *mailbox == delim)
34 + /* use connection delimiter if known. Otherwise use user delimiter */
38 (strchr(ImapDelimChars, *mailbox) || *mailbox == delim))