]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/530887-dovecot-imap.patch
upstream/543467-thread-segfault.patch: patch to prevent mutt from segfaulting when...
[software/mutt-debian.git] / debian / patches / upstream / 530887-dovecot-imap.patch
1 This patch fixes the following two bugs:
2 *) http://bugs.debian.org/530887 
3    mutt: fails to move read messages even with move=yes
4
5 *) http://bugs.debian.org/530671
6    mutt: does not want to open dot subdirs via imap anymore
7
8 the second one happens with dovecot which uses / as a delimeter for mailbox,
9 so without this patch is not possible to access subdirs on imap accounts
10 hosted on dovecot
11
12 --- a/imap/util.c
13 +++ b/imap/util.c
14 @@ -393,19 +393,19 @@
15      size_t plen)
16  {
17    int i = 0;
18 -  char delim;
19 +  char delim = '\0';
20    
21    if (idata)
22      delim = idata->delim;
23 -  else if (ImapDelimChars && ImapDelimChars[0])
24 -    delim = ImapDelimChars[0];
25 -  else
26 -    delim = '/';
27  
28    while (mailbox && *mailbox && i < plen - 1)
29    {
30 -    if (strchr(ImapDelimChars, *mailbox) || *mailbox == delim)
31 +    if ((ImapDelimChars && strchr(ImapDelimChars, *mailbox))
32 +        || *mailbox == delim)
33      {
34 +      /* use connection delimiter if known. Otherwise use user delimiter */
35 +      if (!idata)
36 +        delim = *mailbox;
37        while (*mailbox &&
38              (strchr(ImapDelimChars, *mailbox) || *mailbox == delim))
39          mailbox++;