1 message cache partially invalid after network problem
2 fixed by http://dev.mutt.org/trac/ticket/3163
3 changeset http://dev.mutt.org/trac/changeset/da94a92c3ba0
4 resolves http://bugs.debian.org/500016
6 --- mutt-1.5.19/bcache.c 2009-01-05 19:20:53.000000000 +0000
7 +++ mutt-7ddf1d1cc490/bcache.c 2009-01-27 20:58:15.000000000 +0000
9 snprintf (path, sizeof (path), "%s%s%s", bcache->path, id,
12 + if ((fp = safe_fopen (path, "w+")))
15 + if (errno == EEXIST)
16 + /* clean up leftover tmp file */
19 s = strchr (path + 1, '/');
20 while (!(fp = safe_fopen (path, "w+")) && errno == ENOENT && s)
23 s = strchr (s + 1, '/');
27 dprint (3, (debugfile, "bcache: put: '%s'\n", path));