]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/542817-smimekeys-tmpdir.patch
adding a missing bug number
[software/mutt-debian.git] / debian / patches / upstream / 542817-smimekeys-tmpdir.patch
1 skip the configured tmpdir if it contains '=', that convention is used only by
2 mutt, see upstream http://bugs.mutt.org/3324
3
4 --- a/smime_keys.pl
5 +++ b/smime_keys.pl
6 @@ -946,6 +946,7 @@
7         $option = "notemp" if (not defined($option));
8         if (! $tmpdir and $option eq "temp") {
9                 $tmpdir = mutt_Q 'tmpdir';
10 +                $tmpdir = '/tmp' if ($tmpdir =~ m/=/); # if the tmpdir contains '=', use the default
11                 $tmpdir = newfile("$tmpdir/smime");
12                 mkdir $tmpdir, 0700 || die "Can't create $tmpdir: $!\n";
13         }