]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features/compressed-folders
mutt (1.5.13-1.1) unstable; urgency=high
[software/mutt-debian.git] / debian / patches / features / compressed-folders
1 # vi: ft=diff
2 This is the compressed folders patch by Roland Rosenfeld
3 <roland@spinnaker.de>.
4
5 The home page for this patch is:
6
7   http://www.spinnaker.de/mutt/compressed/
8
9 * Patch last synced with upstream:
10   - Date: 2005-09-29
11   - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
12
13 * Changes made:
14   - filterdiff -p1 \
15     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
16       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
17   - adjust the init.h hunk to the presence of group & ungroup
18   - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
19   - 2006-08-16: adjust Makefile.am mutt-1.5.13
20
21 == END PATCH
22 --- /dev/null
23 +++ compress.c
24 @@ -0,0 +1,487 @@
25 +/*
26 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
27 + *
28 + *     This program is free software; you can redistribute it and/or modify
29 + *     it under the terms of the GNU General Public License as published by
30 + *     the Free Software Foundation; either version 2 of the License, or
31 + *     (at your option) any later version.
32 + *
33 + *     This program is distributed in the hope that it will be useful,
34 + *     but WITHOUT ANY WARRANTY; without even the implied warranty of
35 + *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
36 + *     GNU General Public License for more details.
37 + *
38 + *     You should have received a copy of the GNU General Public License
39 + *     along with this program; if not, write to the Free Software
40 + *     Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
41 + */
42 +
43 +#if HAVE_CONFIG_H
44 +# include "config.h"
45 +#endif
46 +
47 +#include "mutt.h"
48 +
49 +#ifdef USE_COMPRESSED
50 +
51 +#include "mx.h"
52 +#include "mailbox.h"
53 +#include "mutt_curses.h"
54 +
55 +#include <errno.h>
56 +#include <string.h>
57 +#include <unistd.h>
58 +#include <sys/stat.h>
59 +
60 +typedef struct
61 +{
62 +  const char *close;   /* close-hook  command */
63 +  const char *open;    /* open-hook   command */
64 +  const char *append;  /* append-hook command */
65 +  off_t size;          /* size of real folder */
66 +} COMPRESS_INFO;
67 +
68 +
69 +/*
70 + * ctx - context to lock
71 + * excl - exclusive lock?
72 + * retry - should retry if unable to lock?
73 + */
74 +int mbox_lock_compressed (CONTEXT *ctx, FILE *fp, int excl, int retry)
75 +{
76 +  int r;
77 +
78 +  if ((r = mx_lock_file (ctx->realpath, fileno (fp), excl, 1, retry)) == 0)
79 +    ctx->locked = 1;
80 +  else if (retry && !excl)
81 +  {
82 +    ctx->readonly = 1;
83 +    return 0;
84 +  }
85 +
86 +  return (r);
87 +}
88 +
89 +void mbox_unlock_compressed (CONTEXT *ctx, FILE *fp)
90 +{
91 +  if (ctx->locked)
92 +  {
93 +    fflush (fp);
94 +
95 +    mx_unlock_file (ctx->realpath, fileno (fp), 1);
96 +    ctx->locked = 0;
97 +  }
98 +}
99 +
100 +static int is_new (const char *path)
101 +{
102 +  return (access (path, W_OK) != 0 && errno == ENOENT) ? 1 : 0;
103 +}
104 +
105 +static const char* find_compress_hook (int type, const char *path)
106 +{
107 +  const char* c = mutt_find_hook (type, path);
108 +  return (!c || !*c) ? NULL : c;
109 +}
110 +
111 +int mutt_can_read_compressed (const char *path)
112 +{
113 +  return find_compress_hook (M_OPENHOOK, path) ? 1 : 0;
114 +}
115 +
116 +/*
117 + * if the file is new, we really do not append, but create, and so use
118 + * close-hook, and not append-hook
119 + */
120 +static const char* get_append_command (const char *path, const CONTEXT* ctx)
121 +{
122 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
123 +  return (is_new (path)) ? ci->close : ci->append;
124 +}
125 +
126 +int mutt_can_append_compressed (const char *path)
127 +{
128 +  int magic;
129 +
130 +  if (is_new (path))
131 +    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
132 +
133 +  magic = mx_get_magic (path);
134 +
135 +  if (magic != 0 && magic != M_COMPRESSED)
136 +    return 0;
137 +
138 +  return (find_compress_hook (M_APPENDHOOK, path)
139 +         || (find_compress_hook (M_OPENHOOK, path)
140 +             && find_compress_hook (M_CLOSEHOOK, path))) ? 1 : 0;
141 +}
142 +
143 +/* open a compressed mailbox */
144 +static COMPRESS_INFO *set_compress_info (CONTEXT *ctx)
145 +{
146 +  COMPRESS_INFO *ci;
147 +
148 +  /* Now lets uncompress this thing */
149 +  ci = safe_malloc (sizeof (COMPRESS_INFO));
150 +  ctx->compressinfo = (void*) ci;
151 +  ci->append = find_compress_hook (M_APPENDHOOK, ctx->path);
152 +  ci->open = find_compress_hook (M_OPENHOOK, ctx->path);
153 +  ci->close = find_compress_hook (M_CLOSEHOOK, ctx->path);
154 +  return ci;
155 +}
156 +
157 +static void set_path (CONTEXT* ctx)
158 +{
159 +  char tmppath[_POSIX_PATH_MAX];
160 +
161 +  /* Setup the right paths */
162 +  ctx->realpath = ctx->path;
163 +
164 +  /* Uncompress to /tmp */
165 +  mutt_mktemp (tmppath);
166 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
167 +  strcpy (ctx->path, tmppath);
168 +}
169 +
170 +static int get_size (const char* path)
171 +{
172 +  struct stat sb;
173 +  if (stat (path, &sb) != 0)
174 +    return 0;
175 +  return (sb.st_size);
176 +}
177 +
178 +static void store_size (CONTEXT* ctx)
179 +{
180 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
181 +  ci->size = get_size (ctx->realpath);
182 +}
183 +
184 +static const char *
185 +compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
186 +                        const char *fmt, const char *ifstring,
187 +                        const char *elsestring, unsigned long data,
188 +                        format_flag flags)
189 +{
190 +  char tmp[SHORT_STRING];
191 +
192 +  CONTEXT *ctx = (CONTEXT *) data;
193 +  switch (op)
194 +  {
195 +  case 'f':
196 +    snprintf (tmp, sizeof (tmp), "%%%ss", fmt);
197 +    snprintf (dest, destlen, tmp, ctx->realpath);
198 +    break;
199 +  case 't':
200 +    snprintf (tmp, sizeof (tmp), "%%%ss", fmt);
201 +    snprintf (dest, destlen, tmp, ctx->path);
202 +    break;
203 +  }
204 +  return (src);
205 +}
206 +
207 +/*
208 + * check that the command has both %f and %t
209 + * 0 means OK, -1 means error
210 + */
211 +int mutt_test_compress_command (const char* cmd)
212 +{
213 +  return (strstr (cmd, "%f") && strstr (cmd, "%t")) ? 0 : -1;
214 +}
215 +
216 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
217 +{
218 +  char expanded[_POSIX_PATH_MAX];
219 +  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
220 +                    (unsigned long) ctx, 0);
221 +  return safe_strdup (expanded);
222 +}
223 +
224 +int mutt_check_mailbox_compressed (CONTEXT* ctx)
225 +{
226 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
227 +  if (ci->size != get_size (ctx->realpath))
228 +  {
229 +    FREE (&ctx->compressinfo);
230 +    FREE (&ctx->realpath);
231 +    mutt_error _("Mailbox was corrupted!");
232 +    return (-1);
233 +  }
234 +  return (0);
235 +}
236 +
237 +int mutt_open_read_compressed (CONTEXT *ctx)
238 +{
239 +  char *cmd;
240 +  FILE *fp;
241 +  int rc;
242 +
243 +  COMPRESS_INFO *ci = set_compress_info (ctx);
244 +  if (!ci->open) {
245 +    ctx->magic = 0;
246 +    FREE (ctx->compressinfo);
247 +    return (-1);
248 +  }
249 +  if (!ci->close || access (ctx->path, W_OK) != 0)
250 +    ctx->readonly = 1;
251 +
252 +  set_path (ctx);
253 +  store_size (ctx);
254 +
255 +  if (!ctx->quiet)
256 +    mutt_message (_("Decompressing %s..."), ctx->realpath);
257 +
258 +  cmd = get_compression_cmd (ci->open, ctx);
259 +  if (cmd == NULL)
260 +    return (-1);
261 +  dprint (2, (debugfile, "DecompressCmd: '%s'\n", cmd));
262 +
263 +  if ((fp = fopen (ctx->realpath, "r")) == NULL)
264 +  {
265 +    mutt_perror (ctx->realpath);
266 +    FREE (&cmd);
267 +    return (-1);
268 +  }
269 +  mutt_block_signals ();
270 +  if (mbox_lock_compressed (ctx, fp, 0, 1) == -1)
271 +  {
272 +    fclose (fp);
273 +    mutt_unblock_signals ();
274 +    mutt_error _("Unable to lock mailbox!");
275 +    FREE (&cmd);
276 +    return (-1);
277 +  }
278 +
279 +  endwin ();
280 +  fflush (stdout);
281 +  fprintf (stderr, _("Decompressing %s...\n"),ctx->realpath);
282 +  rc = mutt_system (cmd);
283 +  mbox_unlock_compressed (ctx, fp);
284 +  mutt_unblock_signals ();
285 +  fclose (fp);
286 +
287 +  if (rc)
288 +  {
289 +    mutt_any_key_to_continue (NULL);
290 +    ctx->magic = 0;
291 +    FREE (ctx->compressinfo);
292 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
293 +  }
294 +  FREE (&cmd);
295 +  if (rc)
296 +    return (-1);
297 +
298 +  if (mutt_check_mailbox_compressed (ctx))
299 +    return (-1);
300 +
301 +  ctx->magic = mx_get_magic (ctx->path);
302 +
303 +  return (0);
304 +}
305 +
306 +void restore_path (CONTEXT* ctx)
307 +{
308 +  FREE (&ctx->path);
309 +  ctx->path = ctx->realpath;
310 +}
311 +
312 +/* remove the temporary mailbox */
313 +void remove_file (CONTEXT* ctx)
314 +{
315 +  if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
316 +    remove (ctx->path);
317 +}
318 +
319 +int mutt_open_append_compressed (CONTEXT *ctx)
320 +{
321 +  FILE *fh;
322 +  COMPRESS_INFO *ci = set_compress_info (ctx);
323 +
324 +  if (!get_append_command (ctx->path, ctx))
325 +  {
326 +    if (ci->open && ci->close)
327 +      return (mutt_open_read_compressed (ctx));
328 +
329 +    ctx->magic = 0;
330 +    FREE (&ctx->compressinfo);
331 +    return (-1);
332 +  }
333 +
334 +  set_path (ctx);
335 +
336 +  ctx->magic = DefaultMagic;
337 +
338 +  if (!is_new (ctx->realpath))
339 +    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
340 +      if ((fh = fopen (ctx->path, "w")))
341 +       fclose (fh);
342 +  /* No error checking - the parent function will catch it */
343 +
344 +  return (0);
345 +}
346 +
347 +/* close a compressed mailbox */
348 +void mutt_fast_close_compressed (CONTEXT *ctx)
349 +{
350 +  dprint (2, (debugfile, "mutt_fast_close_compressed called on '%s'\n",
351 +             ctx->path));
352 +
353 +  if (ctx->compressinfo)
354 +  {
355 +    if (ctx->fp)
356 +      fclose (ctx->fp);
357 +    ctx->fp = NULL;
358 +    /* if the folder was removed, remove the gzipped folder too */
359 +    if ((ctx->magic > 0) 
360 +       && (access (ctx->path, F_OK) != 0) 
361 +       && ! option (OPTSAVEEMPTY))
362 +      remove (ctx->realpath);
363 +    else
364 +      remove_file (ctx);
365 +
366 +    restore_path (ctx);
367 +    FREE (&ctx->compressinfo);
368 +  }
369 +}
370 +
371 +/* return 0 on success, -1 on failure */
372 +int mutt_sync_compressed (CONTEXT* ctx)
373 +{
374 +  char *cmd;
375 +  int rc = 0;
376 +  FILE *fp;
377 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
378 +
379 +  if (!ctx->quiet)
380 +    mutt_message (_("Compressing %s..."), ctx->realpath);
381 +
382 +  cmd = get_compression_cmd (ci->close, ctx);
383 +  if (cmd == NULL)
384 +    return (-1);
385 +
386 +  if ((fp = fopen (ctx->realpath, "a")) == NULL)
387 +  {
388 +    mutt_perror (ctx->realpath);
389 +    FREE (&cmd);
390 +    return (-1);
391 +  }
392 +  mutt_block_signals ();
393 +  if (mbox_lock_compressed (ctx, fp, 1, 1) == -1)
394 +  {
395 +    fclose (fp);
396 +    mutt_unblock_signals ();
397 +    mutt_error _("Unable to lock mailbox!");
398 +    store_size (ctx);
399 +    FREE (&cmd);
400 +    return (-1);
401 +  }
402 +
403 +  dprint (2, (debugfile, "CompressCommand: '%s'\n", cmd));
404 +
405 +  endwin ();
406 +  fflush (stdout);
407 +  fprintf (stderr, _("Compressing %s...\n"), ctx->realpath);
408 +  if (mutt_system (cmd))
409 +  {
410 +    mutt_any_key_to_continue (NULL);
411 +    mutt_error (_("%s: Error compressing mailbox! Original mailbox deleted, uncompressed one kept!\n"), ctx->path);
412 +    rc = -1;
413 +  }
414 +
415 +  mbox_unlock_compressed (ctx, fp);
416 +  mutt_unblock_signals ();
417 +  fclose (fp);
418 +
419 +  FREE (&cmd);
420 +
421 +  store_size (ctx);
422 +
423 +  return (rc);
424 +}
425 +
426 +int mutt_slow_close_compressed (CONTEXT *ctx)
427 +{
428 +  FILE *fp;
429 +  const char *append;
430 +  char *cmd;
431 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
432 +
433 +  dprint (2, (debugfile, "mutt_slow_close_compressed called on '%s'\n",
434 +             ctx->path));
435 +
436 +  if (! (ctx->append
437 +        && ((append = get_append_command (ctx->realpath, ctx))
438 +            || (append = ci->close))))
439 +  { 
440 +    /* if we can not or should not append, we only have to remove the */
441 +    /* compressed info, because sync was already called               */
442 +    mutt_fast_close_compressed (ctx);
443 +    return (0);
444 +  }
445 +
446 +  if (ctx->fp)
447 +    fclose (ctx->fp);
448 +  ctx->fp = NULL;
449 +
450 +  if (!ctx->quiet)
451 +  {
452 +    if (append == ci->close)
453 +      mutt_message (_("Compressing %s..."), ctx->realpath);
454 +    else
455 +      mutt_message (_("Compressed-appending to %s..."), ctx->realpath);
456 +  }
457 +
458 +  cmd = get_compression_cmd (append, ctx);
459 +  if (cmd == NULL)
460 +    return (-1);
461 +
462 +  if ((fp = fopen (ctx->realpath, "a")) == NULL)
463 +  {
464 +    mutt_perror (ctx->realpath);
465 +    FREE (&cmd);
466 +    return (-1);
467 +  }
468 +  mutt_block_signals ();
469 +  if (mbox_lock_compressed (ctx, fp, 1, 1) == -1)
470 +  {
471 +    fclose (fp);
472 +    mutt_unblock_signals ();
473 +    mutt_error _("Unable to lock mailbox!");
474 +    FREE (&cmd);
475 +    return (-1);
476 +  }
477 +
478 +  dprint (2, (debugfile, "CompressCmd: '%s'\n", cmd));
479 +
480 +  endwin ();
481 +  fflush (stdout);
482 +
483 +  if (append == ci->close)
484 +    fprintf (stderr, _("Compressing %s...\n"), ctx->realpath);
485 +  else
486 +    fprintf (stderr, _("Compressed-appending to %s...\n"), ctx->realpath);
487 +
488 +  if (mutt_system (cmd))
489 +  {
490 +    mutt_any_key_to_continue (NULL);
491 +    mutt_error (_(" %s: Error compressing mailbox!  Uncompressed one kept!\n"),
492 +               ctx->path);
493 +    FREE (&cmd);
494 +    mbox_unlock_compressed (ctx, fp);
495 +    mutt_unblock_signals ();
496 +    fclose (fp);
497 +    return (-1);
498 +  }
499 +
500 +  mbox_unlock_compressed (ctx, fp);
501 +  mutt_unblock_signals ();
502 +  fclose (fp);
503 +  remove_file (ctx);
504 +  restore_path (ctx);
505 +  FREE (&cmd);
506 +  FREE (&ctx->compressinfo);
507 +
508 +  return (0);
509 +}
510 +
511 +#endif /* USE_COMPRESSED */
512 --- /dev/null
513 +++ compress.h
514 @@ -0,0 +1,27 @@
515 +/*
516 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
517 + *
518 + *     This program is free software; you can redistribute it and/or modify
519 + *     it under the terms of the GNU General Public License as published by
520 + *     the Free Software Foundation; either version 2 of the License, or
521 + *     (at your option) any later version.
522 + *
523 + *     This program is distributed in the hope that it will be useful,
524 + *     but WITHOUT ANY WARRANTY; without even the implied warranty of
525 + *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
526 + *     GNU General Public License for more details.
527 + *
528 + *     You should have received a copy of the GNU General Public License
529 + *     along with this program; if not, write to the Free Software
530 + *     Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
531 + */
532 +
533 +int mutt_can_read_compressed (const char *);
534 +int mutt_can_append_compressed (const char *);
535 +int mutt_open_read_compressed (CONTEXT *);
536 +int mutt_open_append_compressed (CONTEXT *);
537 +int mutt_slow_close_compressed (CONTEXT *);
538 +int mutt_sync_compressed (CONTEXT *);
539 +int mutt_test_compress_command (const char *);
540 +int mutt_check_mailbox_compressed (CONTEXT *);
541 +void mutt_fast_close_compressed (CONTEXT *);
542 --- configure.in.orig
543 +++ configure.in
544 @@ -798,6 +798,11 @@
545                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
546          fi])
547  
548 +AC_ARG_ENABLE(compressed, AC_HELP_STRING([--enable-compressed], [Enable compressed folders support]),
549 +       [if test x$enableval = xyes; then
550 +                AC_DEFINE(USE_COMPRESSED,1, [ Define to support compressed folders. ])
551 +        fi])
552 +
553  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
554          [if test $withval != yes; then
555                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
556 --- curs_main.c.orig
557 +++ curs_main.c
558 @@ -1096,6 +1096,11 @@
559          {
560           int check;
561  
562 +#ifdef USE_COMPRESSED
563 +         if (Context->compressinfo && Context->realpath)
564 +           mutt_str_replace (&LastFolder, Context->realpath);
565 +         else
566 +#endif
567           mutt_str_replace (&LastFolder, Context->path);
568           oldcount = Context ? Context->msgcount : 0;
569  
570 --- doc/manual.xml.head.orig
571 +++ doc/manual.xml.head
572 @@ -4749,6 +4749,205 @@
573  
574  </sect1>
575  
576 +<sect1 id="compressedfolders">
577 +<title>Compressed folders Support (OPTIONAL)</title>
578 +
579 +<para>
580 +If Mutt was compiled with compressed folders support (by running the
581 +<emphasis>configure</emphasis> script with the
582 +<emphasis>--enable-compressed</emphasis> flag), Mutt can open folders
583 +stored in an arbitrary format, provided that the user has a script to
584 +convert from/to this format to one of the accepted.
585 +
586 +The most common use is to open compressed archived folders e.g. with
587 +gzip.
588 +
589 +In addition, the user can provide a script that gets a folder in an
590 +accepted format and appends its context to the folder in the
591 +user-defined format, which may be faster than converting the entire
592 +folder to the accepted format, appending to it and converting back to
593 +the user-defined format.
594 +
595 +There are three hooks defined (<link
596 +linkend="open-hook">open-hook</link>, <link
597 +linkend="close-hook">close-hook</link> and <link
598 +linkend="append-hook">append-hook</link>) which define commands to
599 +uncompress and compress a folder and to append messages to an existing
600 +compressed folder respectively.
601 +
602 +For example:
603 +
604 +<screen>
605 +open-hook \\.gz$ "gzip -cd %f &gt; %t" 
606 +close-hook \\.gz$ "gzip -c %t &gt; %f"
607 +append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
608 +</screen>
609 +
610 +You do not have to specify all of the commands. If you omit <link
611 +linkend="append-hook">append-hook</link>, the folder will be open and
612 +closed again each time you will add to it. If you omit <link
613 +linkend="close-hook">close-hook</link> (or give empty command) , the
614 +folder will be open in the mode. If you specify <link
615 +linkend="append-hook">append-hook</link> though you'll be able to
616 +append to the folder.
617 +
618 +Note that Mutt will only try to use hooks if the file is not in one of
619 +the accepted formats. In particular, if the file is empty, mutt
620 +supposes it is not compressed. This is important because it allows the
621 +use of programs that do not have well defined extensions. Just use
622 +&quot;.&quot; as a regexp. But this may be surprising if your
623 +compressing script produces empty files. In this situation, unset
624 +<link linkend="save-empty">&dollar;save&lowbar;empty</link>, so that
625 +the compressed file will be removed if you delete all of the messages.
626 +</para>
627 +
628 +<sect2 id="open-hook">
629 +<title>Open a compressed mailbox for reading</title>
630 +
631 +<para>
632 +Usage: <literal>open-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
633 +
634 +The <emphasis>command</emphasis> is the command that can be used for
635 +opening the folders whose names match <emphasis>regexp</emphasis>.
636 +
637 +The <emphasis>command</emphasis> string is the printf-like format
638 +string, and it should accept two parameters: &percnt;f, which is
639 +replaced with the (compressed) folder name, and &percnt;t which is
640 +replaced with the name of the temporary folder to which to write.
641 +
642 +&percnt;f and &percnt;t can be repeated any number of times in the
643 +command string, and all of the entries are replaced with the
644 +appropriate folder name. In addition, &percnt;&percnt; is replaced by
645 +&percnt;, as in printf, and any other &percnt;anything is left as is.
646 +
647 +The <emphasis>command</emphasis> should <emphasis
648 +role="bold">not</emphasis> remove the original compressed file.  The
649 +<emphasis>command</emphasis> should return non-zero exit status if it
650 +fails, so mutt knows something's wrong.
651 +
652 +Example:
653 +
654 +<screen>
655 +open-hook \\.gz$ "gzip -cd %f &gt; %t" 
656 +</screen>
657 +
658 +If the <emphasis>command</emphasis> is empty, this operation is
659 +disabled for this file type.
660 +</para>
661 +</sect2>
662 +
663 +<sect2 id="close-hook">
664 +<title>Write a compressed mailbox</title>
665 +
666 +<para>
667 +Usage: <literal>close-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
668 +
669 +This is used to close the folder that was open with the <link
670 +linkend="open-hook">open-hook</link> command after some changes were
671 +made to it.
672 +
673 +The <emphasis>command</emphasis> string is the command that can be
674 +used for closing the folders whose names match
675 +<emphasis>regexp</emphasis>. It has the same format as in the <link
676 +linkend="open-hook">open-hook</link> command. Temporary folder in this
677 +case is the folder previously produced by the <link
678 +linkend="open-hook">open-hook</link> command.
679 +
680 +The <emphasis>command</emphasis> should <emphasis
681 +role="bold">not</emphasis> remove the decompressed file. The
682 +<emphasis>command</emphasis> should return non-zero exit status if it
683 +fails, so mutt knows something's wrong.
684 +
685 +Example:
686 +
687 +<screen>
688 +close-hook \\.gz$ "gzip -c %t &gt; %f"
689 +</screen>
690 +
691 +If the <emphasis>command</emphasis> is empty, this operation is
692 +disabled for this file type, and the file can only be open in the
693 +read-only mode.
694 +
695 +<link linkend="close-hook">close-hook</link> is not called when you
696 +exit from the folder if the folder was not changed.
697 +</para>
698 +</sect2>
699 +
700 +<sect2 id="append-hook">
701 +<title>Append a message to a compressed mailbox</title>
702 +
703 +<para>
704 +Usage: <literal>append-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
705 +
706 +This command is used for saving to an existing compressed folder.  The
707 +<emphasis>command</emphasis> is the command that can be used for
708 +appending to the folders whose names match
709 +<emphasis>regexp</emphasis>. It has the same format as in the <link
710 +linkend="open-hook">open-hook</link> command.  The temporary folder in
711 +this case contains the messages that are being appended.
712 +
713 +The <emphasis>command</emphasis> should <emphasis
714 +role="bold">not</emphasis> remove the decompressed file. The
715 +<emphasis>command</emphasis> should return non-zero exit status if it
716 +fails, so mutt knows something's wrong.
717 +
718 +Example:
719 +
720 +<screen>
721 +append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
722 +</screen>
723 +
724 +When <link linkend="append-hook">append-hook</link> is used, the folder
725 +is not opened, which saves time, but this means that we can not find
726 +out what the folder type is. Thus the default (<link
727 +linkend="mbox-type">&dollar;mbox&lowbar;type</link>) type is always
728 +supposed (i.e.  this is the format used for the temporary folder).
729 +
730 +If the file does not exist when you save to it, <link
731 +linkend="close-hook">close-hook</link> is called, and not <link
732 +linkend="append-hook">append-hook</link>. <link
733 +linkend="append-hook">append-hook</link> is only for appending to
734 +existing folders.
735 +
736 +If the <emphasis>command</emphasis> is empty, this operation is
737 +disabled for this file type. In this case, the folder will be open and
738 +closed again (using <link linkend="open-hook">open-hook</link> and
739 +<link linkend="close-hook">close-hook</link>respectively) each time you
740 +will add to it.
741 +</para>
742 +</sect2>
743 +
744 +<sect2>
745 +<title>Encrypted folders</title>
746 +
747 +<para>
748 +The compressed folders support can also be used to handle encrypted
749 +folders. If you want to encrypt a folder with PGP, you may want to use
750 +the following hooks:
751 +
752 +<screen>
753 +open-hook  \\.pgp$ "pgp -f &lt; %f &gt; %t"
754 +close-hook \\.pgp$ "pgp -fe YourPgpUserIdOrKeyId &lt; %t &gt; %f"
755 +</screen>
756 +
757 +Please note, that PGP does not support appending to an encrypted
758 +folder, so there is no append-hook defined.
759 +
760 +If you are using GnuPG instead of PGP, you may use the following hooks
761 +instead:
762 +
763 +<screen>
764 +open-hook  \\.gpg$ "gpg --decrypt &lt; %f &gt; %t"
765 +close-hook \\.gpg$ "gpg --encrypt --recipient YourGpgUserIdOrKeyId &lt; %t &gt; %f"
766 +</screen>
767 +
768 +<emphasis role="bold">Note:</emphasis> the folder is temporary stored
769 +decrypted in the /tmp directory, where it can be read by your system
770 +administrator. So think about the security aspects of this.
771 +</para>
772 +</sect2>
773 +</sect1>
774 +
775  </chapter>
776  
777  <chapter id="mimesupport">
778 --- doc/muttrc.man.head.orig
779 +++ doc/muttrc.man.head
780 @@ -316,6 +316,24 @@
781  to a certain recipient.  The meaning of "key ID" is to be taken
782  broadly: This can be a different e-mail address, a numerical key ID,
783  or even just an arbitrary search string.
784 +.PP
785 +.nf
786 +\fBopen-hook\fP \fIregexp\fP "\fIcommand\fP"
787 +\fBclose-hook\fP \fIregexp\fP "\fIcommand\fP"
788 +\fBappend-hook\fP \fIregexp\fP "\fIcommand\fP"
789 +.fi
790 +.IP
791 +These commands provide a way to handle compressed folders. The given
792 +\fBregexp\fP specifies which folders are taken as compressed (e.g.
793 +"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
794 +(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
795 +compressed mail to a compressed folder (\fBappend-hook\fP). The
796 +\fIcommand\fP string is the 
797 +.BR printf (3)
798 +like format string, and it should accept two parameters: \fB%f\fP,
799 +which is replaced with the (compressed) folder name, and \fB%t\fP
800 +which is replaced with the name of the temporary folder to which to
801 +write.
802  .TP
803  \fBpush\fP \fIstring\fP
804  This command adds the named \fIstring\fP to the keyboard buffer.
805 --- hook.c.orig
806 +++ hook.c
807 @@ -24,6 +24,10 @@
808  #include "mailbox.h"
809  #include "mutt_crypt.h"
810  
811 +#ifdef USE_COMPRESSED
812 +#include "compress.h"
813 +#endif
814 +
815  #include <limits.h>
816  #include <string.h>
817  #include <stdlib.h>
818 @@ -92,6 +96,16 @@
819      memset (&pattern, 0, sizeof (pattern));
820      pattern.data = safe_strdup (path);
821    }
822 +#ifdef USE_COMPRESSED
823 +  else if (data & (M_APPENDHOOK | M_OPENHOOK | M_CLOSEHOOK))
824 +  {
825 +    if (mutt_test_compress_command (command.data))
826 +    {
827 +      strfcpy (err->data, _("bad formatted command string"), err->dsize);
828 +      return (-1);
829 +    }
830 +  }
831 +#endif
832    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
833             && (!WithCrypto || !(data & M_CRYPTHOOK))
834        )
835 --- init.h.orig
836 +++ init.h
837 @@ -3119,6 +3119,11 @@
838    { "folder-hook",     mutt_parse_hook,        M_FOLDERHOOK },
839    { "group",           parse_group,            0 },
840    { "ungroup",         parse_ungroup,          0 },
841 +#ifdef USE_COMPRESSED
842 +  { "open-hook",       mutt_parse_hook,        M_OPENHOOK },
843 +  { "close-hook",      mutt_parse_hook,        M_CLOSEHOOK },
844 +  { "append-hook",     mutt_parse_hook,        M_APPENDHOOK },
845 +#endif
846    { "hdr_order",       parse_list,             UL &HeaderOrderList },
847  #ifdef HAVE_ICONV
848    { "iconv-hook",      mutt_parse_hook,        M_ICONVHOOK }, 
849 --- main.c.orig
850 +++ main.c
851 @@ -398,6 +398,12 @@
852  #else
853         "-LOCALES_HACK  "
854  #endif
855 +
856 +#ifdef USE_COMPRESSED
857 +       "+COMPRESSED  "
858 +#else
859 +       "-COMPRESSED  "
860 +#endif
861               
862  #ifdef HAVE_WC_FUNCS
863         "+HAVE_WC_FUNCS  "
864 --- Makefile.am.orig
865 +++ Makefile.am
866 @@ -18,7 +18,7 @@
867  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
868  mutt_SOURCES = $(BUILT_SOURCES) \
869         addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
870 -       crypt.c cryptglue.c \
871 +       crypt.c cryptglue.c compress.c \
872         commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
873         edit.c enter.c flags.c init.c filter.c from.c \
874         getdomain.c group.c \
875 @@ -66,7 +66,7 @@
876         crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
877  
878  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
879 -       configure account.h \
880 +       configure account.h compress.h \
881         attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
882         globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
883         mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
884 --- mbox.c.orig
885 +++ mbox.c
886 @@ -28,6 +28,10 @@
887  #include "sort.h"
888  #include "copy.h"
889  
890 +#ifdef USE_COMPRESSED
891 +#include "compress.h"
892 +#endif
893 +
894  #include <sys/stat.h>
895  #include <dirent.h>
896  #include <string.h>
897 @@ -1014,6 +1018,12 @@
898  int mbox_close_mailbox (CONTEXT *ctx)
899  {
900    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
901 +
902 +#ifdef USE_COMPRESSED
903 +  if (ctx->compressinfo)
904 +    mutt_slow_close_compressed (ctx);
905 +#endif
906 +
907    mutt_unblock_signals ();
908    mx_fastclose_mailbox (ctx);
909    return 0;
910 --- mutt.h.orig
911 +++ mutt.h
912 @@ -157,6 +157,11 @@
913  #define M_ACCOUNTHOOK  (1<<9)
914  #define M_REPLYHOOK    (1<<10)
915  #define M_SEND2HOOK     (1<<11)
916 +#ifdef USE_COMPRESSED
917 +#define M_OPENHOOK     (1<<12)
918 +#define M_APPENDHOOK   (1<<13)
919 +#define M_CLOSEHOOK    (1<<14)
920 +#endif
921  
922  /* tree characters for linearize_tree and print_enriched_string */
923  #define M_TREE_LLCORNER                1
924 @@ -864,6 +869,11 @@
925    void *data;                  /* driver specific data */
926  #endif /* USE_IMAP */
927  
928 +#ifdef USE_COMPRESSED
929 +  void *compressinfo;          /* compressed mbox module private data */
930 +  char *realpath;              /* path to compressed mailbox */
931 +#endif /* USE_COMPRESSED */
932 +
933    short magic;                 /* mailbox type */
934  
935    unsigned int locked : 1;     /* is the mailbox locked? */
936 --- mx.c.orig
937 +++ mx.c
938 @@ -30,6 +30,10 @@
939  #include "keymap.h"
940  #include "url.h"
941  
942 +#ifdef USE_COMPRESSED
943 +#include "compress.h"
944 +#endif
945 +
946  #ifdef USE_IMAP
947  #include "imap.h"
948  #endif
949 @@ -454,6 +458,10 @@
950      return (-1);
951    }
952  
953 +#ifdef USE_COMPRESSED
954 +  if (magic == 0 && mutt_can_read_compressed (path))
955 +    return M_COMPRESSED;
956 +#endif
957    return (magic);
958  }
959  
960 @@ -493,6 +501,13 @@
961  {
962    struct stat sb;
963  
964 +#ifdef USE_COMPRESSED
965 +  /* special case for appending to compressed folders -
966 +   * even if we can not open them for reading */
967 +  if (mutt_can_append_compressed (ctx->path))
968 +    mutt_open_append_compressed (ctx);
969 +#endif
970 +
971    ctx->append = 1;
972  
973  #ifdef USE_IMAP
974 @@ -653,7 +668,12 @@
975    }
976  
977    ctx->magic = mx_get_magic (path);
978 -  
979 +
980 +#ifdef USE_COMPRESSED
981 +  if (ctx->magic == M_COMPRESSED)
982 +    mutt_open_read_compressed (ctx);
983 +#endif
984 +
985    if(ctx->magic == 0)
986      mutt_error (_("%s is not a mailbox."), path);
987  
988 @@ -759,6 +779,10 @@
989      mutt_free_header (&ctx->hdrs[i]);
990    FREE (&ctx->hdrs);
991    FREE (&ctx->v2r);
992 +#ifdef USE_COMPRESSED
993 +  if (ctx->compressinfo)
994 +    mutt_fast_close_compressed (ctx);
995 +#endif
996    FREE (&ctx->path);
997    FREE (&ctx->pattern);
998    if (ctx->limit_pattern) 
999 @@ -816,6 +840,12 @@
1000    if (tmp && tmp->new == 0)
1001      mutt_update_mailbox (tmp);
1002  #endif
1003 +
1004 +#ifdef USE_COMPRESSED
1005 +  if (rc == 0 && ctx->compressinfo)
1006 +    return mutt_sync_compressed (ctx);
1007 +#endif
1008 +
1009    return rc;
1010  }
1011  
1012 @@ -1017,6 +1047,11 @@
1013        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
1014      mx_unlink_empty (ctx->path);
1015  
1016 +#ifdef USE_COMPRESSED
1017 +  if (ctx->compressinfo && mutt_slow_close_compressed (ctx))
1018 +    return (-1);
1019 +#endif
1020 +
1021    mx_fastclose_mailbox (ctx);
1022  
1023    return 0;
1024 @@ -1326,6 +1361,11 @@
1025  {
1026    int rc;
1027  
1028 +#ifdef USE_COMPRESSED
1029 +  if (ctx->compressinfo)
1030 +    return mutt_check_mailbox_compressed (ctx);
1031 +#endif
1032 +
1033    if (ctx)
1034    {
1035      if (ctx->locked) lock = 0;
1036 --- mx.h.orig
1037 +++ mx.h
1038 @@ -40,6 +40,9 @@
1039  #ifdef USE_POP
1040    , M_POP
1041  #endif
1042 +#ifdef USE_COMPRESSED
1043 +  , M_COMPRESSED
1044 +#endif
1045  };
1046  
1047  WHERE short DefaultMagic INITVAL (M_MBOX);
1048 --- PATCHES.orig
1049 +++ PATCHES
1050 @@ -1,2 +1,3 @@
1051 +patch-1.5.11.rr.compressed.1
1052  patch-1.5.6.tt.assumed_charset.1
1053  patch-1.5.6.dw.maildir-mtime.1
1054 --- po/de.po.orig
1055 +++ po/de.po
1056 @@ -1267,6 +1267,48 @@
1057  msgid "Failed to figure out sender"
1058  msgstr "Kann Absender nicht ermitteln"
1059  
1060 +#: compress.c:203 mbox.c:661
1061 +msgid "Mailbox was corrupted!"
1062 +msgstr "Mailbox wurde zerstört!"
1063 +
1064 +#: compress.c:228 compress.c:253
1065 +#, c-format
1066 +msgid "Decompressing %s...\n"
1067 +msgstr "Entpacke %s...\n"
1068 +
1069 +#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
1070 +msgid "Unable to lock mailbox!"
1071 +msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
1072 +
1073 +#: compress.c:264
1074 +#, c-format
1075 +msgid "Error executing: %s : unable to open the mailbox!\n"
1076 +msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
1077 +
1078 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
1079 +#, c-format
1080 +msgid "Compressing %s...\n"
1081 +msgstr "Komprimiere %s...\n"
1082 +
1083 +#: compress.c:381
1084 +#, c-format
1085 +msgid ""
1086 +"%s: Error compressing mailbox! Original mailbox deleted, uncompressed one "
1087 +"kept!\n"
1088 +msgstr ""
1089 +"%s: Fehler beim Komprimieren der Mailbox! Ursprüngliche Mailbox gelöscht, "
1090 +"entpackte gespeichert!\n"
1091 +
1092 +#: compress.c:425 compress.c:456
1093 +#, c-format
1094 +msgid "Compressed-appending to %s...\n"
1095 +msgstr "Hänge komprimiert an %s... an\n"
1096 +
1097 +#: compress.c:461
1098 +#, c-format
1099 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
1100 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
1101 +
1102  #: crypt.c:69
1103  #, c-format
1104  msgid " (current time: %c)"
1105 @@ -1915,6 +1957,10 @@
1106  msgid "Help for %s"
1107  msgstr "Hilfe für %s"
1108  
1109 +#: hook.c:96
1110 +msgid "bad formatted command string"
1111 +msgstr "Hook enthält nicht die Muster %f und %t"
1112 +
1113  #: hook.c:246
1114  #, c-format
1115  msgid "unhook: Can't do unhook * from within a hook."
1116 @@ -3422,18 +3468,10 @@
1117  msgid "Mailbox is corrupt!"
1118  msgstr "Mailbox fehlerhaft!"
1119  
1120 -#: mbox.c:662
1121 -msgid "Mailbox was corrupted!"
1122 -msgstr "Mailbox wurde zerstört!"
1123 -
1124  #: mbox.c:701 mbox.c:952
1125  msgid "Fatal error!  Could not reopen mailbox!"
1126  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
1127  
1128 -#: mbox.c:710
1129 -msgid "Unable to lock mailbox!"
1130 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
1131 -
1132  #. this means ctx->changed or ctx->deleted was set, but no
1133  #. * messages were found to be changed or deleted.  This should
1134  #. * never happen, is we presume it is a bug in mutt.
1135 --- po/POTFILES.in.orig
1136 +++ po/POTFILES.in
1137 @@ -8,6 +8,7 @@
1138  color.c
1139  commands.c
1140  compose.c
1141 +compress.c
1142  crypt-gpgme.c
1143  crypt.c
1144  cryptglue.c
1145 --- status.c.orig
1146 +++ status.c
1147 @@ -97,6 +97,14 @@
1148  
1149      case 'f':
1150        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
1151 +#ifdef USE_COMPRESSED
1152 +      if (Context && Context->compressinfo && Context->realpath)
1153 +      {
1154 +        strfcpy (tmp, Context->realpath, sizeof (tmp));
1155 +        mutt_pretty_mailbox (tmp);
1156 +      }
1157 +      else
1158 +#endif
1159        if (Context && Context->path)
1160        {
1161         strfcpy (tmp, Context->path, sizeof (tmp));