]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/393926-internal-viewer.patch
incorporating fixes of http://bugs.mutt.org/3308 into the existing patch
[software/mutt-debian.git] / debian / patches / upstream / 393926-internal-viewer.patch
1 Display any text/* part with the internal viewer, see upstream bug
2 http://bugs.mutt.org/3246
3
4 --- a/muttlib.c
5 +++ b/muttlib.c
6 @@ -622,11 +622,8 @@
7    switch (m->type)
8    {
9      case TYPETEXT:
10 -
11 -      if (!ascii_strcasecmp ("plain", m->subtype) ||
12 -         !ascii_strcasecmp ("rfc822-headers", m->subtype) ||
13 -         !ascii_strcasecmp ("enriched", m->subtype))
14 -       return 0;
15 +      /* we can display any text, overridable by auto_view */
16 +      return 0;
17        break;
18  
19      case TYPEAPPLICATION: