]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/537818-emptycharset.patch
incorporating fixes of http://bugs.mutt.org/3308 into the existing patch
[software/mutt-debian.git] / debian / patches / upstream / 537818-emptycharset.patch
1 --- a/init.c
2 +++ b/init.c
3 @@ -1751,6 +1751,9 @@
4    char *p, *q = NULL, *s = safe_strdup (val);
5    int rc = 0, strict = strcmp (opt->option, "send_charset") == 0;
6  
7 +  if (!s)
8 +    return rc;
9 +
10    for (p = strtok_r (s, ":", &q); p; p = strtok_r (NULL, ":", &q))
11    {
12      if (!*p)