]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/fix_cve-2006-3242.diff
Prepare and upload 1.5.11+cvs20060403-2 to fix CVE-2006-3242.
[software/mutt-debian.git] / debian / patches / upstream / fix_cve-2006-3242.diff
1 ------------------------------------------------------------
2 revno: 3939
3 committer: brendan
4 timestamp: Mon 2006-06-19 18:14:03 +0000
5 message:
6   From: TAKAHASHI Tamotsu <tamo@momonga-linux.org>
7   
8   Fix browse_get_namespace() which could overflow ns[LONG_STRING].
9   (Possible remote vulnerability)
10 ------------------------------------------------------------
11 revno: 3940
12 committer: brendan
13 timestamp: Mon 2006-06-19 18:14:54 +0000
14 message:
15   # changelog commit
16 --- ChangeLog.orig
17 +++ ChangeLog
18 @@ -1,3 +1,8 @@
19 +2006-06-19 18:14:03  TAKAHASHI Tamotsu  <tamo@momonga-linux.org>  (brendan)
20 +
21 +       * imap/browse.c: Fix browse_get_namespace() which could overflow
22 +       ns[LONG_STRING].  (Possible remote vulnerability)
23 +
24  2006-04-03 20:26:14  Brendan Cully  <brendan@kublai.com>  (brendan)
25  
26         * imap/command.c: Don't pass a null destination to imap_fix_path
27 --- imap/browse.c.orig
28 +++ imap/browse.c
29 @@ -505,7 +505,7 @@
30             if (*s == '\"')
31             {
32               s++;
33 -             while (*s && *s != '\"') 
34 +             while (*s && *s != '\"' && n < sizeof (ns) - 1) 
35               {
36                 if (*s == '\\')
37                   s++;
38 @@ -516,12 +516,14 @@
39                 s++;
40             }
41             else
42 -             while (*s && !ISSPACE (*s)) 
43 +             while (*s && !ISSPACE (*s) && n < sizeof (ns) - 1)
44               {
45                 ns[n++] = *s;
46                 s++;
47               }
48             ns[n] = '\0';
49 +           if (n == sizeof (ns) - 1)
50 +             dprint (1, (debugfile, "browse_get_namespace: too long: [%s]\n", ns));
51             /* delim? */
52             s = imap_next_word (s);
53             /* delimiter is meaningless if namespace is "". Why does