1 Index: trunk/Muttrc.head
2 ===================================================================
3 --- trunk.orig/Muttrc.head 2007-03-15 16:33:18.000000000 +0100
4 +++ trunk/Muttrc.head 2007-03-15 16:35:15.000000000 +0100
7 ignore "from " received content- mime-version status x-status message-id
8 ignore sender references return-path lines
9 +ignore date delivered-to precedence errors-to in-reply-to user-agent
10 +ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
11 +ignore x-accept-language x-authentication-warning thread- priority importance
12 +ignore x-original-to domainkey-signature dkim-signature
14 +# emacs-like bindings
15 +bind editor "\e<delete>" kill-word
16 +bind editor "\e<backspace>" kill-word
18 +# map delete-char to a sane value
19 +bind editor <delete> delete-char
21 +# some people actually like these settings
23 +#bind pager <up> previous-line
24 +#bind pager <down> next-line
26 +# Specifies how to sort messages in the index menu.
29 +# Uncomment if your MTA does not strip Bcc: headers.
30 +# (exim4 and postfix strip them, exim(3) does not.)
32 +# Postfix and qmail use Delivered-To for detecting loops
33 +unset bounce_delivered
35 +set mixmaster="mixmaster-filter"
37 # imitate the old search-body function
38 macro index \eb "<search>~b " "search in message bodies"
39 @@ -15,14 +42,14 @@ macro index,pager \cb "<pipe-message> ur
40 macro attach,compose \cb "<pipe-entry> urlview<Enter>" "call urlview to extract URLs out of a message"
42 # Show documentation when pressing F1
43 -macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
44 +macro generic,pager <f1> "<shell-escape> zcat @docdir@/mutt/manual.txt.gz | sensible-pager<enter>" "show Mutt documentation"
46 # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
47 macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
50 # If Mutt is unable to determine your site's domain name correctly, you can
51 -# set the default here.
52 +# set the default here. (better: fix /etc/mailname)
54 # set hostname=cs.hmc.edu
56 @@ -84,6 +111,9 @@ attachments +I text/plain
57 attachments -A message/external-body
58 attachments -I message/external-body
60 +# enable mime lookup by extension
61 +mime_lookup application/octet-stream