]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/use_usr_bin_editor.diff
new upstream release, patches refreshed
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
1 Even if EDITOR is not set, mutt will always use /usr/bin/editor (which 
2 is set by update-alternatives), rather than falling back to vi
3
4 --- a/init.c
5 +++ b/init.c
6 @@ -3115,7 +3115,7 @@
7    {
8      p = getenv ("EDITOR");
9      if (!p)
10 -      p = "vi";
11 +      p = "/usr/bin/editor";
12    }
13    Editor = safe_strdup (p);
14    Visual = safe_strdup (p);
15 --- a/init.h
16 +++ b/init.h
17 @@ -686,7 +686,7 @@
18    ** .pp
19    ** This variable specifies which editor is used by mutt.
20    ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
21 -  ** variable, or to the string ``vi'' if neither of those are set.
22 +  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
23    */
24    { "encode_from",     DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
25    /*