1 add a missing manpage for smime_keys
6 noinst_PROGRAMS = makedoc
8 EXTRA_DIST = dotlock.man \
17 -makedoc-all: mutt.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
18 +makedoc-all: mutt.1 smime_keys.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
20 install-data-local: makedoc-all instdoc
21 $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man1
22 $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man5
23 $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
24 ./instdoc mutt.1 $(DESTDIR)$(mandir)/man1/mutt.1
25 + ./instdoc smime_keys.1 $(DESTDIR)$(mandir)/man1/smime_keys.1
26 ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/flea.1
27 ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/muttbug.1
28 test x@DOTLOCK_TARGET@ = x || ./instdoc $(srcdir)/dotlock.man \
33 - for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 ; do \
34 + for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 smime_keys.1; do \
35 rm -f $(DESTDIR)$(mandir)/man1/$$f ; \
37 for f in muttrc.5 mbox.5 mmdf.5 ; do \
39 rm -rf vars.tmp.1 vars.tmp.2
42 - rm -f *~ *.html *.orig *.rej stamp-doc-* *.ps mutt.1 muttrc.man
43 + rm -f *~ *.html *.orig *.rej stamp-doc-* *.ps mutt.1 smime_keys.1 muttrc.man
44 rm -f *.aux *.log *.tex *.out
46 DISTCLEANFILES=manual.txt manual.html manual.xml manual.pdf html \
48 mutt.1: $(srcdir)/mutt.man
49 $(EDIT) $(srcdir)/mutt.man > $@
51 +smime_keys.1: $(srcdir)/smime_keys.man
52 + $(EDIT) $(srcdir)/smime_keys.man > $@
54 stamp-doc-xml: makedoc$(EXEEXT) $(top_srcdir)/init.h \
55 manual.xml.head $(top_srcdir)/functions.h $(top_srcdir)/OPS* manual.xml.tail \
56 $(srcdir)/gen-map-doc $(top_srcdir)/VERSION $(top_srcdir)/ChangeLog
58 +++ b/doc/smime_keys.man
63 +.\" Copyright (C) 2009 Antonio Radici <antonio@dyne.org>
65 +.\" This program is free software; you can redistribute it and/or modify
66 +.\" it under the terms of the GNU General Public License as published by
67 +.\" the Free Software Foundation; either version 2 of the License, or
68 +.\" (at your option) any later version.
70 +.\" This program is distributed in the hope that it will be useful,
71 +.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
72 +.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
73 +.\" GNU General Public License for more details.
75 +.\" You should have received a copy of the GNU General Public License
76 +.\" along with this program; if not, write to the Free Software
77 +.\" Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
79 +.TH smime_keys 1 "May 2009" Unix "User Manuals"
81 +smime_keys \- Utility to add S/MIME certificate to the internal database used by mutt
85 +<operation> [file(s) | keyID [file(s)]]
87 +The purpose of this tool is to manipulate the internal database of S/MIME certificates
88 +used by mutt to sign mail messages which will be sent or to verify mail messages received
89 +and signed with S/MIME
93 +no files needed, inits directory structure.
95 +lists the certificates stored in database.
97 +keyID required. changes/removes/adds label.
101 +1=keyID and optionally 2=CRL
102 +Verifies the certificate chain, and optionally wether
103 +this certificate is included in supplied CRL (PEM format).
104 +Note: to verify all certificates at the same time,
105 +replace keyID with "all"
107 +certificate required.
109 +three files reqd: 1=Key, 2=certificate
110 +plus 3=intermediate certificate(s).
112 +one file reqd. Adds keypair to database.
113 +file is PKCS12 (e.g. export from netscape).
115 +one file reqd. Adds keypair to database.
116 +(file was converted from e.g. PKCS12).
118 +one file reqd. Adds PEM root certificate to the location
119 +specified within muttrc (smime_verify_* command)
121 +This program is distributed in the hope that it will be useful,
122 +but WITHOUT ANY WARRANTY; without even the implied warranty of
123 +MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
124 +GNU General Public License for more details.
126 +Mutt Home Page: http://www.mutt.org/