]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/misc/autotools-update.diff
Merge from sarge branch.
[software/mutt-debian.git] / debian / patches / misc / autotools-update.diff
1 Index: debian-mutt/Makefile.in
2 ===================================================================
3 --- debian-mutt.orig/Makefile.in        2007-06-14 10:47:56.000000000 +0200
4 +++ debian-mutt/Makefile.in     2007-06-14 10:51:17.000000000 +0200
5 @@ -73,10 +73,10 @@ am__objects_1 = patchlist.$(OBJEXT)
6  am_mutt_OBJECTS = $(am__objects_1) addrbook.$(OBJEXT) alias.$(OBJEXT) \
7         attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
8         buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
9 -       cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
10 -       compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
11 -       curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
12 -       enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
13 +       cryptglue.$(OBJEXT) compress.$(OBJEXT) commands.$(OBJEXT) \
14 +       complete.$(OBJEXT) compose.$(OBJEXT) copy.$(OBJEXT) \
15 +       curs_lib.$(OBJEXT) curs_main.$(OBJEXT) date.$(OBJEXT) \
16 +       edit.$(OBJEXT) enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
17         filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
18         group.$(OBJEXT) handler.$(OBJEXT) hash.$(OBJEXT) \
19         hdrline.$(OBJEXT) headers.$(OBJEXT) help.$(OBJEXT) \
20 Index: debian-mutt/config.h.in
21 ===================================================================
22 --- debian-mutt.orig/config.h.in        2007-06-14 10:47:56.000000000 +0200
23 +++ debian-mutt/config.h.in     2007-06-14 10:51:11.000000000 +0200
24 @@ -513,7 +513,7 @@
25  /* Define to enable Sun mailtool attachments support. */
26  #undef SUN_ATTACHMENT
27  
28 -/* Define to enable compressed mailboxes support */
29 +/* Define to support compressed folders. */
30  #undef USE_COMPRESSED
31  
32  /* Define to use dotlocking for mailboxes. */
33 Index: debian-mutt/configure
34 ===================================================================
35 --- debian-mutt.orig/configure  2007-06-14 10:47:56.000000000 +0200
36 +++ debian-mutt/configure       2007-06-14 10:51:11.000000000 +0200
37 @@ -1367,11 +1367,11 @@ Optional Features:
38    --enable-nfs-fix        Work around an NFS with broken attributes caching
39    --enable-mailtool       Enable Sun mailtool attachments support
40    --enable-locales-fix    The result of isprint() is unreliable
41 +  --enable-compressed     Enable compressed folders support
42    --enable-exact-address  Enable regeneration of email addresses
43    --enable-hcache         Enable header caching
44    --disable-iconv         Disable iconv support
45    --disable-nls           Do not use Native Language Support
46 -  --enable-compressed     Enable compressed folders support
47  
48  Optional Packages:
49    --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
50 @@ -15106,9 +15106,9 @@ _ACEOF
51  fi
52  
53  
54 -# Check whether --enable-compressed or --disable-compressed was given.
55 +# Check whether --enable-compressed was given.
56  if test "${enable_compressed+set}" = set; then
57 -  enableval="$enable_compressed"; if test x$enableval = xyes; then
58 +  enableval=$enable_compressed; if test x$enableval = xyes; then
59  
60  cat >>confdefs.h <<\_ACEOF
61  #define USE_COMPRESSED 1
62 @@ -15118,6 +15118,7 @@ _ACEOF
63  fi
64  
65  
66 +
67  # Check whether --with-exec-shell was given.
68  if test "${with_exec_shell+set}" = set; then
69    withval=$with_exec_shell; if test $withval != yes; then