]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features/maildir-mtime
remove bogus file .pc/.version
[software/mutt-debian.git] / debian / patches / features / maildir-mtime
1 # vi: ft=diff
2 This is the maildir mtime patch by Dale Woolridge.
3
4 The home page for this patch is:
5
6   http://www.mutt.ca/maildir-mtime.html
7
8 * Patch last synced with upstream:
9   - Date: 2004-08-10
10   - File: http://www.mutt.ca/patches/patch-1.5.6.dw.maildir-mtime.1
11
12 * Changes made:
13   - removed a spurious const in add_folder() definition.
14   - added a $maildir_mtime option to allow this patch to be disabled at
15     runtime (see Bug#253261, comments from Zephaniah E. Hull).
16   - 2007-04-03 myon: resolved conflict in browser.c
17
18 == END PATCH
19 --- a/buffy.c
20 +++ b/buffy.c
21 @@ -257,6 +257,7 @@
22      (*tmp)->new = 0;
23      (*tmp)->notified = 1;
24      (*tmp)->newly_created = 0;
25 +    (*tmp)->mtime = 0;
26  
27      /* for check_mbox_size, it is important that if the folder is new (tested by
28       * reading it), the size is set to 0 so that later when we check we see
29 @@ -285,6 +286,7 @@
30  {
31    BUFFY *tmp;
32    struct stat sb;
33 +  struct stat smd;
34    struct dirent *de;
35    DIR *dirp;
36    char path[_POSIX_PATH_MAX];
37 @@ -333,6 +335,7 @@
38      if (tmp->magic != M_IMAP)
39  #endif
40      tmp->new = 0;
41 +    tmp->mtime = 0;
42  
43  #ifdef USE_IMAP
44      if (tmp->magic != M_IMAP)
45 @@ -415,10 +418,20 @@
46           if (*de->d_name != '.' && 
47               (!(p = strstr (de->d_name, ":2,")) || !strchr (p + 3, 'T')))
48           {
49 -           /* one new and undeleted message is enough */
50 -           BuffyCount++;
51 -           tmp->new = 1;
52 -           break;
53 +           if (!tmp->new)
54 +           {
55 +             /* one new and undeleted message is enough */
56 +             BuffyCount++;
57 +             tmp->new = 1;
58 +
59 +             if (! option (OPTMAILDIRMTIME)) /* prevent stat calls */
60 +               break;
61 +           }
62 +           snprintf (path, sizeof (path), "%s/new/%s", tmp->path, de->d_name);
63 +           if (!stat (path, &smd) && smd.st_mtime > tmp->mtime)
64 +           {
65 +             tmp->mtime = smd.st_mtime;
66 +           }
67           }
68         }
69         closedir (dirp);
70 --- a/init.h
71 +++ b/init.h
72 @@ -1350,6 +1350,16 @@
73    ** \fBDON'T CHANGE THIS SETTING UNLESS YOU ARE REALLY SURE WHAT YOU ARE
74    ** DOING!\fP
75    */
76 +  { "maildir_mtime", DT_BOOL, R_NONE, OPTMAILDIRMTIME, 0 },
77 +  /*
78 +  ** .pp
79 +  ** If set, the sort-by-date option in the browser will sort maildirs
80 +  ** smartly, not using the mtime of the maildir itself but that of the
81 +  ** newest message in the new subdirectory, making the sorting by
82 +  ** reverse date much more useful. People with maildirs over NFS may
83 +  ** wish to leave this option unset.
84 +  **
85 +  */
86  #ifdef USE_HCACHE
87    { "maildir_header_cache_verify", DT_BOOL, R_NONE, OPTHCACHEVERIFY, 1 },
88    /*
89 --- a/mutt.h
90 +++ b/mutt.h
91 @@ -384,6 +384,7 @@
92    OPTINCLUDEONLYFIRST,
93    OPTKEEPFLAGGED,
94    OPTMAILCAPSANITIZE,
95 +  OPTMAILDIRMTIME,
96    OPTMAILDIRTRASH,
97    OPTMARKERS,
98    OPTMARKOLD,
99 --- a/browser.c
100 +++ b/browser.c
101 @@ -32,6 +32,7 @@
102  #ifdef USE_IMAP
103  #include "imap.h"
104  #endif
105 +#include "mx.h"
106  
107  #include <stdlib.h>
108  #include <dirent.h>
109 @@ -308,8 +309,10 @@
110  }
111  
112  static void add_folder (MUTTMENU *m, struct browser_state *state,
113 -                       const char *name, const struct stat *s, int new)
114 +                       const char *name, /*DEB const IAN*/ struct stat *s, BUFFY *mbuf)
115  {
116 +  int new = (mbuf) ? mbuf->new : 0;
117 +
118    if (state->entrylen == state->entrymax)
119    {
120      /* need to allocate more space */
121 @@ -321,6 +324,9 @@
122        m->data = state->entry;
123    }
124  
125 +  if (mbuf && mbuf->magic == M_MAILDIR && mbuf->mtime)
126 +    s->st_mtime = mbuf->mtime;
127 +
128    if (s != NULL)
129    {
130      (state->entry)[state->entrylen].mode = s->st_mode;
131 @@ -415,7 +421,7 @@
132      tmp = Incoming;
133      while (tmp && mutt_strcmp (buffer, tmp->path))
134        tmp = tmp->next;
135 -    add_folder (menu, state, de->d_name, &s, (tmp) ? tmp->new : 0);
136 +    add_folder (menu, state, de->d_name, &s, tmp);
137    }
138    closedir (dp);  
139    browser_sort (state);
140 @@ -443,14 +449,15 @@
141      if (mx_is_imap (tmp->path))
142      {
143        imap_mailbox_state (tmp->path, &mbox);
144 -      add_folder (menu, state, tmp->path, NULL, mbox.new);
145 +      tmp->new = mbox.new;
146 +      add_folder (menu, state, tmp->path, NULL, tmp);
147        continue;
148      }
149  #endif
150  #ifdef USE_POP
151      if (mx_is_pop (tmp->path))
152      {
153 -      add_folder (menu, state, tmp->path, NULL, tmp->new);
154 +      add_folder (menu, state, tmp->path, NULL, tmp);
155        continue;
156      }
157  #endif
158 @@ -479,7 +486,7 @@
159      strfcpy (buffer, NONULL(tmp->path), sizeof (buffer));
160      mutt_pretty_mailbox (buffer, sizeof (buffer));
161  
162 -    add_folder (menu, state, buffer, &s, tmp->new);
163 +    add_folder (menu, state, buffer, &s, tmp);
164    }
165    while ((tmp = tmp->next));
166    browser_sort (state);
167 --- a/buffy.h
168 +++ b/buffy.h
169 @@ -25,6 +25,7 @@
170    char path[_POSIX_PATH_MAX];
171    off_t size;
172    struct buffy_t *next;
173 +  time_t mtime;                        /* for maildirs...time of newest entry */
174    short new;                   /* mailbox has new mail */
175    short notified;              /* user has been notified */
176    short magic;                 /* mailbox type */