]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/534543-imap-port.patch
upstream/578087-header-strchr.patch: prevent from segfaulting on malformed messages...
[software/mutt-debian.git] / debian / patches / upstream / 534543-imap-port.patch
1 a bug in 1.5.20 upstream prevented mutt from correctly parsing the port
2 in an IMAP url (imap[s]://...:<port>), this was fixed by upstream bug
3 3264 and backported to the Debian package in 534543
4
5 Index: mutt/url.c
6 ===================================================================
7 --- mutt.orig/url.c     2009-06-25 12:37:59.000000000 +0200
8 +++ mutt/url.c  2009-06-25 12:39:05.000000000 +0200
9 @@ -143,9 +143,11 @@
10    
11    if ((p = strchr (t, ':')))
12    {
13 +    int t;
14      *p++ = '\0';
15 -    if (mutt_atos (p, (short*) &ciss->port) < 0)
16 +    if (mutt_atoi (p, &t) < 0 || t < 0 || t > 0xffff)
17        return NULL;
18 +    ciss->port = (unsigned short)t;
19    }
20    else
21      ciss->port = 0;