1 This patch will allow the user to specify a port, as it was before 1.5.20, see
2 upstream bug http://bugs.mutt.org/3322
9 acct->type = M_ACCT_TYPE_POP;
12 c = safe_strdup (path);
13 url_parse_ciss (&url, c);
15 acct->flags |= M_ACCT_SSL;
17 service = getservbyname (url.scheme == U_POP ? "pop3" : "pop3s", "tcp");
19 - acct->port = ntohs (service->s_port);
21 - acct->port = url.scheme == U_POP ? POP_PORT : POP_SSL_PORT;;
24 + acct->port = ntohs (service->s_port);
26 + acct->port = url.scheme == U_POP ? POP_PORT : POP_SSL_PORT;;