1 this fixes a problem with new mail detection on MH folder, for a
2 more detailed history see mutt bugs #3308 and #3312 and debian
8 if ((p = strchr (t, '-')))
11 - if (mutt_atoi (t, first) < 0 || mutt_atoi (t, last) < 0)
12 + if (mutt_atoi (t, first) < 0 || mutt_atoi (p, last) < 0)
20 - int first, last, rc;
21 + int first, last, rc = 0;
23 char pathname[_POSIX_PATH_MAX];
24 snprintf (pathname, sizeof (pathname), "%s/.mh_sequences", path);
33 static inline mode_t mh_umask (CONTEXT* ctx)
35 for (i = 0; !r && i <= mhs.max; i++)
36 if (mhs_check (&mhs, i) & MH_SEQ_UNSEEN)
38 + mhs_free_sequences (&mhs);
44 if (ctx->magic == M_MH)
46 - if (mh_read_sequences (&mhs, ctx->path) >= 0)
47 + if (mh_read_sequences (&mhs, ctx->path) < 0)
49 mh_update_maildir (md, &mhs);
50 mhs_free_sequences (&mhs);