1 --- mutt-1.5.11+cvs20060126.orig/Muttrc.head.in
2 +++ mutt-1.5.11+cvs20060126/Muttrc.head.in
5 ignore "from " received content- mime-version status x-status message-id
6 ignore sender references return-path lines
7 +ignore date delivered-to precedence errors-to in-reply-to user-agent
8 +ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
9 +ignore x-accept-language x-authentication-warning thread- priority importance
10 +ignore x-original-to domainkey-signature dkim-signature
12 +# emacs-like bindings
13 +bind editor "\e<delete>" kill-word
14 +bind editor "\e<backspace>" kill-word
16 +# map delete-char to a sane value
17 +bind editor <delete> delete-char
19 +# some people actually like these settings
21 +#bind pager <up> previous-line
22 +#bind pager <down> next-line
24 +# don't add the hostname to the From header
26 +# don't generate a From header
29 +# Specifies how to sort messages in the index menu.
32 +# Exim does not remove Bcc headers
34 +# Postfix and qmail use Delivered-To for detecting loops
35 +unset bounce_delivered
37 +# weed out binary-only announcements to -devel-changes
38 +#macro index \CW T!~s\(.*source.*\)\nWn^T~A\n "Weed out binary-only announcements"
40 # imitate the old search-body function
41 macro index \eb "<search>~b " "search in message bodies"
43 macro index,pager \cb "<pipe-message>urlview<Enter>" "call urlview to extract URLs out of a message"
45 # Show documentation when pressing F1
46 -macro generic,pager <F1> "<shell-escape>less @docdir@/manual.txt<Enter>" "show Mutt documentation"
47 +macro generic <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
48 +macro index <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
49 +macro pager <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
51 +# Use folders which match on \\.gz$ or \\.bz2$ as [gb]zipped folders:
52 +open-hook \\.gz$ "gzip -cd %f > %t"
53 +close-hook \\.gz$ "gzip -c %t > %f"
54 +append-hook \\.gz$ "gzip -c %t >> %f"
55 +open-hook \\.bz2$ "bzip2 -cd %f > %t"
56 +close-hook \\.bz2$ "bzip2 -c %t > %f"
57 +append-hook \\.bz2$ "bzip2 -c %t >> %f"
59 # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
60 macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
62 attachments -A message/external-body
63 attachments -I message/external-body
69 +color normal white black
70 +color attachment brightyellow black
71 +color hdrdefault cyan black
72 +color indicator black cyan
73 +color markers brightred black
74 +color quoted green black
75 +color signature cyan black
76 +color status brightgreen blue
77 +color tilde blue black
79 +#color header brightgreen black ^From:
80 +#color header brightcyan black ^To:
81 +#color header brightcyan black ^Reply-To:
82 +#color header brightcyan black ^Cc:
83 +#color header brightblue black ^Subject:
84 +#color body brightred black [\-\.+_a-zA-Z0-9]+@[\-\.a-zA-Z0-9]+
85 +#color body brightblue black (https?|ftp)://[\-\.,/%~_:?&=\#a-zA-Z0-9]+