1 diff -ru mutt-1.5.11+cvs20060126.orig/Makefile.in mutt-1.5.11+cvs20060126/Makefile.in
2 --- mutt-1.5.11+cvs20060126.orig/Makefile.in 2006-02-02 04:15:38.000000000 +0100
3 +++ mutt-1.5.11+cvs20060126/Makefile.in 2006-02-02 04:40:04.000000000 +0100
5 am_mutt_OBJECTS = $(am__objects_1) addrbook.$(OBJEXT) alias.$(OBJEXT) \
6 attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
7 buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
8 - cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
9 - compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
10 - curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
11 - enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
12 + cryptglue.$(OBJEXT) compress.$(OBJEXT) commands.$(OBJEXT) \
13 + complete.$(OBJEXT) compose.$(OBJEXT) copy.$(OBJEXT) \
14 + curs_lib.$(OBJEXT) curs_main.$(OBJEXT) date.$(OBJEXT) \
15 + edit.$(OBJEXT) enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
16 filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
17 group.$(OBJEXT) handler.$(OBJEXT) hash.$(OBJEXT) \
18 hdrline.$(OBJEXT) headers.$(OBJEXT) help.$(OBJEXT) \
20 BUILT_SOURCES = keymap_defs.h patchlist.c
21 mutt_SOURCES = $(BUILT_SOURCES) \
22 addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
23 - crypt.c cryptglue.c \
24 + crypt.c cryptglue.c compress.c \
25 commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
26 edit.c enter.c flags.c init.c filter.c from.c \
29 crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
31 EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
32 - configure account.h \
33 + configure account.h compress.h \
34 attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
35 globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
36 mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
38 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
39 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
40 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
41 +@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
42 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
43 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
44 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
45 Only in mutt-1.5.11+cvs20060126: autom4te.cache
46 diff -ru mutt-1.5.11+cvs20060126.orig/config.h.in mutt-1.5.11+cvs20060126/config.h.in
47 --- mutt-1.5.11+cvs20060126.orig/config.h.in 2006-02-02 04:14:49.000000000 +0100
48 +++ mutt-1.5.11+cvs20060126/config.h.in 2006-02-02 04:40:00.000000000 +0100
50 /* Define to enable Sun mailtool attachments support. */
53 +/* Define to support compressed folders. */
54 +#undef USE_COMPRESSED
56 /* Define to use dotlocking for mailboxes. */
59 Only in mutt-1.5.11+cvs20060126: config.h.in~
60 diff -ru mutt-1.5.11+cvs20060126.orig/configure mutt-1.5.11+cvs20060126/configure
61 --- mutt-1.5.11+cvs20060126.orig/configure 2006-02-02 04:39:52.000000000 +0100
62 +++ mutt-1.5.11+cvs20060126/configure 2006-02-02 04:40:05.000000000 +0100
64 --enable-buffy-size Use file size attribute instead of access time
65 --enable-mailtool Enable Sun mailtool attachments support
66 --enable-locales-fix The result of isprint() is unreliable
67 + --enable-compressed Enable compressed folders support
68 --enable-exact-address Enable regeneration of email addresses
69 --enable-hcache Enable header caching
70 --disable-iconv Disable iconv support
71 @@ -14682,6 +14682,18 @@
75 +# Check whether --enable-compressed or --disable-compressed was given.
76 +if test "${enable_compressed+set}" = set; then
77 + enableval="$enable_compressed"
78 + if test x$enableval = xyes; then
80 +cat >>confdefs.h <<\_ACEOF
81 +#define USE_COMPRESSED 1
88 # Check whether --with-exec-shell or --without-exec-shell was given.
89 if test "${with_exec_shell+set}" = set; then
90 Only in mutt-1.5.11+cvs20060126: diff.zHFCuH