]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/use_usr_bin_editor.diff
Import mutt_1.5.11+cvs20060126-1
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
1 --- mutt-1.5.11.orig/init.c
2 +++ mutt-1.5.11/init.c
3 @@ -2920,7 +2920,7 @@
4    {
5      p = getenv ("EDITOR");
6      if (!p)
7 -      p = "vi";
8 +      p = "/usr/bin/editor";
9    }
10    Editor = safe_strdup (p);
11    Visual = safe_strdup (p);
12 --- mutt-1.5.11.orig/init.h
13 +++ mutt-1.5.11/init.h
14 @@ -547,7 +547,7 @@
15    ** .pp
16    ** This variable specifies which editor is used by mutt.
17    ** It defaults to the value of the VISUAL, or EDITOR, environment
18 -  ** variable, or to the string "vi" if neither of those are set.
19 +  ** variable, or to the string "/usr/bin/editor" if neither of those are set.
20    */
21    { "encode_from",     DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
22    /*