]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/mutt-patched/sidebar-utf8
sidebar-utf8: rewrites make_sidebar_entry() to allow correct padding of utf-8 strings...
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-utf8
1 This patch fixes a problem with utf-8 strings and the sidebar, it rewrites
2 entirely make_sidebar_entry so it also fixes some segfaults due to
3 misallocations and overflows.
4
5 See:
6 http://bugs.debian.org/584581
7 http://bugs.debian.org/603287
8
9 Author: Antonio Radici <antonio@dyne.org>
10
11 Index: mutt/sidebar.c
12 ===================================================================
13 --- mutt.orig/sidebar.c 2011-05-02 13:36:10.000000000 +0000
14 +++ mutt/sidebar.c      2011-05-02 13:36:30.000000000 +0000
15 @@ -30,6 +30,7 @@
16  #include <libgen.h>
17  #include "keymap.h"
18  #include <stdbool.h>
19 +#include <wchar.h>
20  
21  /*BUFFY *CurBuffy = 0;*/
22  static BUFFY *TopBuffy = 0;
23 @@ -111,36 +112,72 @@
24  
25  char *make_sidebar_entry(char *box, int size, int new, int flagged)
26  {
27 -       static char *entry = 0;
28 -       char *c;
29 -       int i = 0;
30 -       int delim_len = strlen(SidebarDelim);
31 -
32 -       c = realloc(entry, SidebarWidth - delim_len + 2);
33 -       if ( c ) entry = c;
34 -       entry[SidebarWidth - delim_len + 1] = 0;
35 -       for (; i < SidebarWidth - delim_len + 1; entry[i++] = ' ' );
36 -       i = strlen(box);
37 -       strncpy( entry, box, i < (SidebarWidth - delim_len + 1) ? i : (SidebarWidth - delim_len + 1) );
38 -
39 -        if (size == -1)
40 -                sprintf(entry + SidebarWidth - delim_len - 3, "?");
41 -        else if ( new ) {
42 -          if (flagged > 0) {
43 -              sprintf(
44 -                       entry + SidebarWidth - delim_len - 5 - quick_log10(size) - quick_log10(new) - quick_log10(flagged),
45 -                       "% d(%d)[%d]", size, new, flagged);
46 -          } else {
47 -              sprintf(
48 -                      entry + SidebarWidth - delim_len - 3 - quick_log10(size) - quick_log10(new),
49 -                      "% d(%d)", size, new);
50 -          }
51 -        } else if (flagged > 0) {
52 -              sprintf( entry + SidebarWidth - delim_len - 3 - quick_log10(size) - quick_log10(flagged), "% d[%d]", size, flagged);
53 -        } else {
54 -              sprintf( entry + SidebarWidth - delim_len - 1 - quick_log10(size), "% d", size);
55 -        }
56 -       return entry;
57 +    char int_store[20]; // up to 64 bits integers
58 +    int right_width, left_width;
59 +    int box_len, box_bytes;
60 +    int int_len;
61 +    int right_offset = 0;
62 +    int delim_len = strlen(SidebarDelim);
63 +    static char *entry;
64 +
65 +    right_width = left_width = 0;
66 +    box_len = box_bytes = 0;
67 +
68 +    // allocate an entry big enough to contain SidebarWidth wide chars
69 +    entry = malloc((SidebarWidth*4)+1); // TODO: error check
70 +
71 +    // determine the right space (i.e.: how big are the numbers that we want to print)
72 +    if ( size > 0 ) {
73 +        int_len = snprintf(int_store, sizeof(int_store), "%d", size);
74 +        right_width += int_len;
75 +    } else {
76 +        right_width = 1; // to represent 0
77 +    }
78 +    if ( new > 0 ) {
79 +        int_len = snprintf(int_store, sizeof(int_store), "%d", new);
80 +        right_width += int_len + 2; // 2 is for ()
81 +    }
82 +    if ( flagged > 0 ) {
83 +        int_len = snprintf(int_store, sizeof(int_store), "%d", flagged);
84 +        right_width += int_len + 2; // 2 is for []
85 +    }
86 +
87 +    // determine how much space we have for *box and its padding (if any)
88 +    left_width = SidebarWidth - right_width - 1 - delim_len; // 1 is for the space
89 +    //fprintf(stdout, "left_width: %d right_width: %d\n", left_width, right_width);
90 +    // right side overflow case
91 +    if ( left_width <= 0 ) {
92 +        snprintf(entry, SidebarWidth*4, "%-*.*s ...", SidebarWidth-4-delim_len, SidebarWidth-4-delim_len, box);
93 +        return entry;
94 +    }
95 +    right_width -= delim_len;
96 +
97 +    // to support utf-8 chars we need to add enough space padding in case there
98 +    // are less chars than bytes in *box
99 +    box_len = mbstowcs(NULL, box, 0);
100 +    box_bytes = strlen(box);
101 +    // debug
102 +    //fprintf(stdout, "box_len: %d box_bytes: %d (diff: %d)\n", box_len, box_bytes, (box_bytes-box_len));
103 +    // if there is less string than the space we allow, then we will add the
104 +    // spaces
105 +    if ( box_len != -1 && box_len < left_width ) {
106 +        left_width += (box_bytes - box_len);
107 +    }
108 +    // otherwise sprintf will truncate the string for us (therefore, no else case)
109 +
110 +    // print the sidebar entry (without new and flagged messages, at the moment)
111 +    //fprintf(stdout, "left_width: %d right_width: %d\n", left_width, right_width);
112 +    right_offset = snprintf(entry, SidebarWidth*4, "%-*.*s %d", left_width, left_width, box, size);
113 +
114 +    // then pad new and flagged messages if any
115 +    if ( new > 0 ) {
116 +        right_offset += snprintf(entry+right_offset, SidebarWidth*4-right_offset, "(%d)", new);
117 +    }
118 +    if ( flagged > 0 ) {
119 +        right_offset += snprintf(entry+right_offset, SidebarWidth*4-right_offset, "[%d]", flagged);
120 +    }
121 +
122 +    return entry;
123  }
124  
125  void set_curbuffy(char buf[LONG_STRING])