]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/build_doc_adjustments.diff
removing commented patches already integrated upstream
[software/mutt-debian.git] / debian / patches / debian-specific / build_doc_adjustments.diff
1 Use links(1) to generate the HTML manual page
2
3 --- a/doc/Makefile.am
4 +++ b/doc/Makefile.am
5 @@ -100,7 +100,8 @@
6  
7  check:
8  manual.txt: manual.html
9 -       -LC_ALL=C lynx -dump -nolist -with_backspaces manual.html > $@ || \
10 +       links.main -dump $< > $@ || links -dump $< > $@ || \
11 +       LC_ALL=C lynx -dump -nolist -with_backspaces manual.html > $@ || \
12         LC_ALL=C w3m -dump manual.html > $@ || \
13         LC_ALL=C elinks -dump -no-numbering -no-references manual.html | sed -e 's,\\001, ,g' > $@
14  
15 @@ -114,10 +115,10 @@
16         touch stamp-doc-rc
17  
18  manual.html: $(srcdir)/html.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
19 -       -xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
20 +       xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
21  
22  stamp-doc-chunked: $(srcdir)/chunk.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
23 -       -xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
24 +       xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
25         touch stamp-doc-chunked
26  
27  $(CHUNKED_DOCFILES): stamp-doc-chunked