]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features-old/patch-1.5.4.vk.pgp_verbose_mime
removing Makefile.in from sidebar patch, allow some patches to correctly update PATCHES
[software/mutt-debian.git] / debian / patches / features-old / patch-1.5.4.vk.pgp_verbose_mime
1 --- a/globals.h
2 +++ b/globals.h
3 @@ -241,6 +241,8 @@
4  WHERE char *PgpListSecringCommand;
5  WHERE char *PgpListPubringCommand;
6  WHERE char *PgpGetkeysCommand;
7 +WHERE char *PgpMimeSignatureFilename;
8 +WHERE char *PgpMimeSignatureDescription;
9  
10  /*-- formerly in smime.h --*/
11  WHERE char *SmimeDefaultKey;
12 --- a/init.h
13 +++ b/init.h
14 @@ -1790,6 +1790,18 @@
15    ** checked with the \fC$<check-traditional-pgp>\fP function, mutt will automatically
16    ** check the message for traditional pgp.
17    */
18 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
19 +  /*
20 +  ** .pp
21 +  ** This option sets the filename used for signature parts in PGP/MIME
22 +  ** signed messages.
23 +  */
24 +  { "pgp_mime_signature_description", DT_STR, R_NONE, UL &PgpMimeSignatureDescription, UL "Digital signature"},
25 +  /*
26 +  ** .pp
27 +  ** This option sets the Content-Description used for signature parts in
28 +  ** PGP/MIME signed messages.
29 +  */
30  
31    /* XXX Default values! */
32  
33 --- a/pgp.c
34 +++ b/pgp.c
35 @@ -1113,6 +1113,8 @@
36    t->disposition = DISPINLINE;
37    t->encoding = ENC7BIT;
38    t->unlink = 1; /* ok to remove this file after sending. */
39 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
40 +  t->description = safe_strdup (PgpMimeSignatureDescription);
41  
42    return (a);
43  }