2 [continued from sidebar-compat-revert]
4 After having applied the sidebar patch, we now re-apply the relevant part of
5 the maildir-mtime patch. The hunk is considerably shorter as we are always
6 counting messages; the if..break part has been dropped.
9 @@ -409,6 +409,11 @@ int mutt_buffy_check (int force)
10 tmp->has_new = tmp->new = 1;
13 + snprintf (path, sizeof (path), "%s/new/%s", tmp->path, de->d_name);
14 + if (!stat (path, &smd) && smd.st_mtime > tmp->mtime)
16 + tmp->mtime = smd.st_mtime;
23 @@ -26,6 +26,7 @@ typedef struct buffy_t
27 + time_t mtime; /* for maildirs...time of newest entry */
28 short new; /* mailbox has new mail */
29 short has_new; /* set it new if new and not read */
30 int msgcount; /* total number of messages */