]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/508988-inode-sort.patch
restoring debian/ for master
[software/mutt-debian.git] / debian / patches / upstream / 508988-inode-sort.patch
1 fixed by http://dev.mutt.org/trac/ticket/3163
2 changeset http://dev.mutt.org/trac/changeset/eb918af802ec
3 resolves http://bugs.debian.org/508988
4
5 This commit introduces an unconditional inode-sort to fix the slowness with big
6 maildirs
7
8 --- mutt-1.5.19/mh.c    2009-01-05 19:20:53.000000000 +0000
9 +++ mutt-7ddf1d1cc490/mh.c      2009-01-27 20:58:15.000000000 +0000
10 @@ -1,5 +1,5 @@
11  /*
12 - * Copyright (C) 1996-2002,2007 Michael R. Elkins <me@mutt.org>
13 + * Copyright (C) 1996-2002,2007,2009 Michael R. Elkins <me@mutt.org>
14   * Copyright (C) 1999-2005 Thomas Roessler <roessler@does-not-exist.org>
15   * 
16   *     This program is free software; you can redistribute it and/or modify
17 @@ -1027,13 +1027,14 @@
18      if (!ctx->quiet && progress)
19        mutt_progress_update (progress, count, -1);
20  
21 +    DO_SORT();
22 +
23      snprintf (fn, sizeof (fn), "%s/%s", ctx->path, p->h->path);
24  
25  #if USE_HCACHE
26      if (option(OPTHCACHEVERIFY))
27      {
28 -      DO_SORT();
29 -      ret = stat(fn, &lastchanged);
30 +       ret = stat(fn, &lastchanged);
31      }
32      else
33      {
34 @@ -1057,7 +1058,6 @@
35      {
36  #endif /* USE_HCACHE */
37  
38 -    DO_SORT();
39      if (maildir_parse_message (ctx->magic, fn, p->h->old, p->h))
40      {
41        p->header_parsed = 1;