]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/patch.asp.fix-bug-266493.1
mutt (1.5.9-2sarge2) stable-security; urgency=high
[software/mutt-debian.git] / debian / patches / patch.asp.fix-bug-266493.1
1 --- a/curs_main.c       2004-06-28 04:57:39.000000000 +0200
2 +++ b/curs_main.c       2004-06-28 04:57:49.000000000 +0200
3 @@ -576,10 +576,6 @@
4         move (menu->current - menu->top + menu->offset, COLS - 1);
5        mutt_refresh ();
6  
7 -      op = km_dokey (MENU_MAIN);
8 -
9 -      dprint(4, (debugfile, "mutt_index_menu[%d]: Got op %d\n", __LINE__, op));
10 -
11  #if defined (USE_SLANG_CURSES) || defined (HAVE_RESIZETERM)
12        if (SigWinch)
13        {
14 @@ -598,6 +594,10 @@
15        }
16  #endif
17  
18 +      op = km_dokey (MENU_MAIN);
19 +
20 +      dprint(4, (debugfile, "mutt_index_menu[%d]: Got op %d\n", __LINE__, op));
21 +
22        if (op == -1)
23         continue; /* either user abort or timeout */
24