]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/Muttrc
Introduce two new patches that revert the conflicting part of the
[software/mutt-debian.git] / debian / patches / debian-specific / Muttrc
1 --- a/doc/Muttrc.head
2 +++ b/doc/Muttrc.head
3 @@ -6,6 +6,36 @@
4  #
5  ignore "from " received content- mime-version status x-status message-id
6  ignore sender references return-path lines
7 +ignore date delivered-to precedence errors-to in-reply-to user-agent
8 +ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
9 +ignore x-accept-language x-authentication-warning thread- priority importance
10 +ignore x-original-to domainkey-signature dkim-signature
11 +
12 +# emacs-like bindings
13 +bind editor    "\e<delete>"    kill-word
14 +bind editor    "\e<backspace>" kill-word
15 +
16 +# map delete-char to a sane value
17 +bind editor     <delete>  delete-char
18 +
19 +# some people actually like these settings
20 +#set pager_stop
21 +#bind pager <up> previous-line
22 +#bind pager <down> next-line
23 +
24 +# Specifies how to sort messages in the index menu.
25 +set sort=threads
26 +
27 +# Uncomment if your MTA does not strip Bcc: headers.
28 +# (exim4 and postfix strip them, exim(3) does not.)
29 +#unset write_bcc
30 +# Postfix and qmail use Delivered-To for detecting loops
31 +unset bounce_delivered
32 +
33 +set mixmaster="mixmaster-filter"
34 +
35 +# System-wide CA file managed by the ca-certificates package
36 +set ssl_ca_certificates_file="/etc/ssl/certs/ca-certificates.crt"
37  
38  # imitate the old search-body function
39  macro index \eb "<search>~b " "search in message bodies"
40 @@ -18,7 +48,7 @@ macro index,pager,attach,compose \cb "\
41  "call urlview to extract URLs out of a message"
42  
43  # Show documentation when pressing F1
44 -macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
45 +macro generic,pager <F1> "<shell-escape> zcat @docdir@/mutt/manual.txt.gz | sensible-pager<enter>" "show Mutt documentation"
46  
47  # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
48  macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
49 @@ -30,7 +60,7 @@ bind browser y exit
50  # append-hook \\.gz$ "gzip -c %t >> %f"
51  
52  # If Mutt is unable to determine your site's domain name correctly, you can
53 -# set the default here.
54 +# set the default here. (better: fix /etc/mailname)
55  #
56  # set hostname=cs.hmc.edu
57  
58 @@ -92,6 +122,9 @@ attachments   +I text/plain
59  attachments   -A message/external-body
60  attachments   -I message/external-body
61  
62 +# enable mime lookup by extension
63 +mime_lookup application/octet-stream
64 +
65  ##
66  ## More settings
67  ##