2 The sidebar and maildir-mtime patches touch the same part of buffy.c and
3 generate a non-trivial conflict. This patch reverts the affected hunk from the
4 maildir-mtime patch so we can cleanly apply the sidebar patch from the patch
5 upstream site. While we are at it, we also revert the trivial buffy.h change.
7 Previously, the mutt maintainer would manually re-resolve the conflict for each
8 new sidebar patch version which turned out to be too error-prone.
11 [see sidebar-compat-apply for part 2]
14 @@ -383,20 +383,10 @@ int mutt_buffy_check (int force)
15 if (*de->d_name != '.' &&
16 (!(p = strstr (de->d_name, ":2,")) || !strchr (p + 3, 'T')))
20 - /* one new and undeleted message is enough */
24 - if (! option (OPTMAILDIRMTIME)) /* prevent stat calls */
27 - snprintf (path, sizeof (path), "%s/new/%s", tmp->path, de->d_name);
28 - if (!stat (path, &smd) && smd.st_mtime > tmp->mtime)
30 - tmp->mtime = smd.st_mtime;
32 + /* one new and undeleted message is enough */
41 @@ -25,7 +25,6 @@ typedef struct buffy_t
45 - time_t mtime; /* for maildirs...time of newest entry */
46 short new; /* mailbox has new mail */
47 short notified; /* user has been notified */
48 short magic; /* mailbox type */