]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/531430-imapuser.patch
upstream/528233-readonly-open.patch: open attachments in read-only (Closes: 528233)
[software/mutt-debian.git] / debian / patches / upstream / 531430-imapuser.patch
1 fixes a problem where the imap->login has the precedence so the user
2 is asked with wrong informaton, see upstream #3240
3
4 --- a/account.c
5 +++ b/account.c
6 @@ -218,7 +218,7 @@
7    else
8    {
9      snprintf (prompt, sizeof (prompt), _("Password for %s@%s: "),
10 -              account->flags & M_ACCT_LOGIN ? account->login : account->user,
11 +              ((account->flags & M_ACCT_LOGIN) && !(account->user)) ? account->login : account->user,
12                account->host);
13      account->pass[0] = '\0';
14      if (mutt_get_password (prompt, account->pass, sizeof (account->pass)))