]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/548577-gpgme-1.2.patch
upstream/528233-readonly-open.patch: open attachments in read-only (Closes: 528233)
[software/mutt-debian.git] / debian / patches / upstream / 548577-gpgme-1.2.patch
1 this patch fixes upstream bug http://bugs.mutt.org/3300 so that
2 mutt will be able to open pgp crypted/signed message with gpgme
3
4 --- a/init.c
5 +++ b/init.c
6 @@ -51,6 +51,10 @@
7  #include <errno.h>
8  #include <sys/wait.h>
9  
10 +#if defined(CRYPT_BACKEND_GPGME)
11 +#include <gpgme.h>
12 +#endif
13 +
14  #define CHECK_PAGER \
15    if ((CurrentMenu == MENU_PAGER) && (idx >= 0) &&     \
16             (MuttVars[idx].flags & R_RESORT)) \
17 @@ -3266,6 +3270,10 @@
18  
19    mutt_read_histfile ();
20  
21 +#ifdef CRYPT_BACKEND_GPGME
22 +  gpgme_check_version (NULL);
23 +#endif
24 +
25  #if 0
26    set_option (OPTWEED); /* turn weeding on by default */
27  #endif