]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features-old/patch-1.5.4.vk.pgp_verbose_mime
refreshed all patches up to mutt.org
[software/mutt-debian.git] / debian / patches / features-old / patch-1.5.4.vk.pgp_verbose_mime
1 Enable pgp_mime_signature_filename and pgp_mime_signature_description
2
3 --- a/globals.h
4 +++ b/globals.h
5 @@ -243,6 +243,8 @@
6  WHERE char *PgpListSecringCommand;
7  WHERE char *PgpListPubringCommand;
8  WHERE char *PgpGetkeysCommand;
9 +WHERE char *PgpMimeSignatureFilename;
10 +WHERE char *PgpMimeSignatureDescription;
11  
12  /*-- formerly in smime.h --*/
13  WHERE char *SmimeDefaultKey;
14 --- a/init.h
15 +++ b/init.h
16 @@ -2556,6 +2556,18 @@
17    ** a line quoted text if it also matches $$smileys. This mostly
18    ** happens at the beginning of a line.
19    */
20 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
21 +  /*
22 +  ** .pp
23 +  ** This option sets the filename used for signature parts in PGP/MIME
24 +  ** signed messages.
25 +  */
26 +  { "pgp_mime_signature_description", DT_STR, R_NONE, UL &PgpMimeSignatureDescription, UL "Digital signature"},
27 +  /*
28 +  ** .pp
29 +  ** This option sets the Content-Description used for signature parts in
30 +  ** PGP/MIME signed messages.
31 +  */
32  
33  
34  
35 --- a/pgp.c
36 +++ b/pgp.c
37 @@ -1129,6 +1129,8 @@
38    t->disposition = DISPNONE;
39    t->encoding = ENC7BIT;
40    t->unlink = 1; /* ok to remove this file after sending. */
41 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
42 +  t->description = safe_strdup (PgpMimeSignatureDescription);
43  
44    return (a);
45  }