]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/misc/smime.rc
Merge branch 'upstream' of ssh://antonio-guest@git.debian.org/git/pkg-mutt/mutt
[software/mutt-debian.git] / debian / patches / misc / smime.rc
1 add CA's provided by ca-certificates to the ones distributed by
2 the default installation of mutt
3
4 --- a/contrib/smime.rc
5 +++ b/contrib/smime.rc
6 @@ -4,33 +4,34 @@
7  
8  # If you compiled mutt with support for both PGP and S/MIME, PGP
9  # will be the default method unless the following option is set
10 -set smime_is_default
11 +#set smime_is_default
12  
13  # Uncoment this if you don't want to set labels for certificates you add.
14  # unset smime_ask_cert_label
15  
16  # Passphrase expiration
17 -set smime_timeout=300
18 +#set smime_timeout=300
19  
20  # Global crypto options -- these affect PGP operations as well.
21 -set crypt_autosign = yes
22 -set crypt_replyencrypt = yes
23 -set crypt_replysign = yes
24 -set crypt_replysignencrypted = yes
25 -set crypt_verify_sig = yes
26 +#set crypt_autosign = yes
27 +#set crypt_replyencrypt = yes
28 +#set crypt_replysign = yes
29 +#set crypt_replysignencrypted = yes
30 +#set crypt_verify_sig = yes
31  
32  # Section A: Key Management.
33  
34  # The (default) keyfile for signing/decrypting.  Uncomment the following
35  # line and replace the keyid with your own.
36 -set smime_default_key="12345678.0"
37 +#set smime_default_key="12345678.0"
38  
39  # Uncommen to make mutt ask what key to use when trying to decrypt a message.
40  # It will use the default key above (if that was set) else.
41  # unset smime_decrypt_use_default_key
42  
43  # Path to a file or directory with trusted certificates
44 -set smime_ca_location="~/.smime/ca-bundle.crt"
45 +#set smime_ca_location="~/.smime/ca-bundle.crt"
46 +set smime_ca_location=`for f in $HOME/.smime/ca-certificates.crt $HOME/.smime/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt ; do if [ -e $f ] ; then echo $f ; exit ; fi ; done`
47  
48  # Path to where all known certificates go. (must exist!)
49  set smime_certificates="~/.smime/certificates"