]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/document_debian_defaults
display bcc for postponed message if there is no To (Closes: 350957)
[software/mutt-debian.git] / debian / patches / debian-specific / document_debian_defaults
1 Some customization of the option which are straying from the default
2 only on Debian systems
3
4 --- a/init.h
5 +++ b/init.h
6 @@ -304,6 +304,9 @@ struct option_t MuttVars[] = {
7    ** .pp
8    ** When this variable is \fIset\fP, mutt will include Delivered-To headers when
9    ** bouncing messages.  Postfix users may wish to \fIunset\fP this variable.
10 +  ** .pp
11 +  ** \fBNote:\fP On Debian systems, this option is unset by default in
12 +  ** /etc/Muttrc.
13    */
14    { "braille_friendly", DT_BOOL, R_NONE, OPTBRAILLEFRIENDLY, 0 },
15    /*
16 @@ -866,6 +869,9 @@ struct option_t MuttVars[] = {
17    ** one is not used.
18    ** .pp
19    ** Also see $$use_domain and $$hidden_host.
20 +  ** .pp
21 +  ** \fBNote:\fP On Debian systems, the default for this variable is obtained
22 +  ** from /etc/mailname when Mutt starts.
23    */
24    { "ignore_linear_white_space",    DT_BOOL, R_NONE, OPTIGNORELWS, 0 },
25    /*
26 @@ -1399,6 +1405,9 @@ struct option_t MuttVars[] = {
27    ** system.  It is used with various sets of parameters to gather the
28    ** list of known remailers, and to finally send a message through the
29    ** mixmaster chain.
30 +  ** .pp
31 +  ** \fBNote:\fP On Debian systems, this option is set by default to
32 +  ** ``mixmaster-filter'' in /etc/Muttrc.
33    */
34  #endif
35    { "move",            DT_QUAD, R_NONE, OPT_MOVE, M_NO },
36 @@ -1999,6 +2008,10 @@ struct option_t MuttVars[] = {
37    ** This variable contains the name of either a directory, or a file which
38    ** contains trusted certificates for use with OpenSSL.
39    ** (S/MIME only)
40 +  ** .pp
41 +  ** \fBNote:\fP On Debian systems, this defaults to the first existing file in
42 +  ** the following list: ~/.smime/ca-certificates.crt ~/.smime/ca-bundle.crt
43 +  ** /etc/ssl/certs/ca-certificates.crt.
44    */
45    { "smime_certificates",      DT_PATH, R_NONE, UL &SmimeCertificates, 0 },
46    /*
47 @@ -2237,6 +2250,9 @@ struct option_t MuttVars[] = {
48    ** .ts
49    ** set ssl_ca_certificates_file=/etc/ssl/certs/ca-certificates.crt
50    ** .te
51 +  ** .pp
52 +  ** \fBNote:\fP On Debian systems, this variable defaults to the example
53 +  ** mentioned. This file is managed by the ``ca-certificates'' package.
54    */
55  # endif /* USE_SSL_GNUTLS */
56  #endif /* defined(USE_SSL) */
57 @@ -2873,6 +2889,9 @@ struct option_t MuttVars[] = {
58    ** .pp
59    ** You may optionally use the ``reverse-'' prefix to specify reverse sorting
60    ** order (example: ``\fCset sort=reverse-date-sent\fP'').
61 +  ** .pp
62 +  ** \fBNote:\fP On Debian systems, this option is set by default to
63 +  ** ``threads'' in /etc/Muttrc.
64    */
65    { "sort_alias",      DT_SORT|DT_SORT_ALIAS,  R_NONE, UL &SortAlias, SORT_ALIAS },
66    /*
67 @@ -3306,6 +3325,9 @@ struct option_t MuttVars[] = {
68    ** is set to deliver directly via SMTP (see $$smtp_url), this
69    ** option does nothing: mutt will never write out the ``Bcc:'' header
70    ** in this case.
71 +  ** .pp
72 +  ** \fBNote:\fP On Debian systems, exim4 and postfix strip BCC headers by
73 +  ** default. The above warning applies to exim3 users, see /etc/Muttrc.
74    */
75    {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
76    /*