1 Enable pgp_mime_signature_filename and pgp_mime_signature_description
4 ===================================================================
5 --- mutt.orig/globals.h 2009-06-25 12:35:48.000000000 +0200
6 +++ mutt/globals.h 2009-06-25 12:36:22.000000000 +0200
8 WHERE char *PgpListSecringCommand;
9 WHERE char *PgpListPubringCommand;
10 WHERE char *PgpGetkeysCommand;
11 +WHERE char *PgpMimeSignatureFilename;
12 +WHERE char *PgpMimeSignatureDescription;
14 /*-- formerly in smime.h --*/
15 WHERE char *SmimeDefaultKey;
17 ===================================================================
18 --- mutt.orig/init.h 2009-06-25 12:35:48.000000000 +0200
19 +++ mutt/init.h 2009-06-25 12:36:22.000000000 +0200
20 @@ -2541,6 +2541,18 @@
21 ** a line quoted text if it also matches $$smileys. This mostly
22 ** happens at the beginning of a line.
24 + { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
27 + ** This option sets the filename used for signature parts in PGP/MIME
30 + { "pgp_mime_signature_description", DT_STR, R_NONE, UL &PgpMimeSignatureDescription, UL "Digital signature"},
33 + ** This option sets the Content-Description used for signature parts in
34 + ** PGP/MIME signed messages.
40 ===================================================================
41 --- mutt.orig/pgp.c 2009-06-25 12:35:36.000000000 +0200
42 +++ mutt/pgp.c 2009-06-25 12:36:22.000000000 +0200
44 t->disposition = DISPINLINE;
45 t->encoding = ENC7BIT;
46 t->unlink = 1; /* ok to remove this file after sending. */
47 + mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
48 + t->description = safe_strdup (PgpMimeSignatureDescription);