]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features/compressed-folders
Merge commit 'upstream/1.5.21'
[software/mutt-debian.git] / debian / patches / features / compressed-folders
1 # vi: ft=diff
2 This is the compressed folders patch by Roland Rosenfeld
3 <roland@spinnaker.de>.
4
5 The home page for this patch is:
6
7   http://www.spinnaker.de/mutt/compressed/
8
9 * Patch last synced with upstream:
10   - Date: 2008-05-20
11   - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
12
13 * Changes made:
14   - 2008-05-20 myon: refreshed to remove hunks in auto* files
15   - 2009-09-15 myon: refreshed for mutt-1.5.19
16                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
17   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
18   - 2009-09-11 antonio: removed DefaultMagic, see 541360
19   - 2010-05-31 myon: remove commented paragraph "Use folders..." in
20                      doc/Muttrc.head, see #578096
21
22 == END PATCH
23 --- /dev/null
24 +++ b/compress.c
25 @@ -0,0 +1,496 @@
26 +/*
27 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
28 + *
29 + *     This program is free software; you can redistribute it and/or modify
30 + *     it under the terms of the GNU General Public License as published by
31 + *     the Free Software Foundation; either version 2 of the License, or
32 + *     (at your option) any later version.
33 + *
34 + *     This program is distributed in the hope that it will be useful,
35 + *     but WITHOUT ANY WARRANTY; without even the implied warranty of
36 + *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
37 + *     GNU General Public License for more details.
38 + *
39 + *     You should have received a copy of the GNU General Public License
40 + *     along with this program; if not, write to the Free Software
41 + *     Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
42 + */
43 +
44 +#if HAVE_CONFIG_H
45 +# include "config.h"
46 +#endif
47 +
48 +#include "mutt.h"
49 +
50 +#ifdef USE_COMPRESSED
51 +
52 +#include "mx.h"
53 +#include "mailbox.h"
54 +#include "mutt_curses.h"
55 +
56 +#include <errno.h>
57 +#include <string.h>
58 +#include <unistd.h>
59 +#include <sys/stat.h>
60 +
61 +typedef struct
62 +{
63 +  const char *close;   /* close-hook  command */
64 +  const char *open;    /* open-hook   command */
65 +  const char *append;  /* append-hook command */
66 +  off_t size;          /* size of real folder */
67 +} COMPRESS_INFO;
68 +
69 +
70 +/*
71 + * ctx - context to lock
72 + * excl - exclusive lock?
73 + * retry - should retry if unable to lock?
74 + */
75 +int mbox_lock_compressed (CONTEXT *ctx, FILE *fp, int excl, int retry)
76 +{
77 +  int r;
78 +
79 +  if ((r = mx_lock_file (ctx->realpath, fileno (fp), excl, 1, retry)) == 0)
80 +    ctx->locked = 1;
81 +  else if (retry && !excl)
82 +  {
83 +    ctx->readonly = 1;
84 +    return 0;
85 +  }
86 +
87 +  return (r);
88 +}
89 +
90 +void mbox_unlock_compressed (CONTEXT *ctx, FILE *fp)
91 +{
92 +  if (ctx->locked)
93 +  {
94 +    fflush (fp);
95 +
96 +    mx_unlock_file (ctx->realpath, fileno (fp), 1);
97 +    ctx->locked = 0;
98 +  }
99 +}
100 +
101 +static int is_new (const char *path)
102 +{
103 +  return (access (path, W_OK) != 0 && errno == ENOENT) ? 1 : 0;
104 +}
105 +
106 +static const char* find_compress_hook (int type, const char *path)
107 +{
108 +  const char* c = mutt_find_hook (type, path);
109 +  return (!c || !*c) ? NULL : c;
110 +}
111 +
112 +int mutt_can_read_compressed (const char *path)
113 +{
114 +  return find_compress_hook (M_OPENHOOK, path) ? 1 : 0;
115 +}
116 +
117 +/*
118 + * if the file is new, we really do not append, but create, and so use
119 + * close-hook, and not append-hook
120 + */
121 +static const char* get_append_command (const char *path, const CONTEXT* ctx)
122 +{
123 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
124 +  return (is_new (path)) ? ci->close : ci->append;
125 +}
126 +
127 +int mutt_can_append_compressed (const char *path)
128 +{
129 +  int magic;
130 +
131 +  if (is_new (path))
132 +  {
133 +    char *dir_path = safe_strdup(path);
134 +    char *aux = strrchr(dir_path, '/');
135 +    int dir_valid = 1;
136 +    if (aux)
137 +    {
138 +      *aux='\0';
139 +      if (access(dir_path, W_OK|X_OK))
140 +        dir_valid = 0;
141 +    }
142 +    safe_free((void**)&dir_path);
143 +    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
144 +  }
145 +
146 +  magic = mx_get_magic (path);
147 +
148 +  if (magic != 0 && magic != M_COMPRESSED)
149 +    return 0;
150 +
151 +  return (find_compress_hook (M_APPENDHOOK, path)
152 +         || (find_compress_hook (M_OPENHOOK, path)
153 +             && find_compress_hook (M_CLOSEHOOK, path))) ? 1 : 0;
154 +}
155 +
156 +/* open a compressed mailbox */
157 +static COMPRESS_INFO *set_compress_info (CONTEXT *ctx)
158 +{
159 +  COMPRESS_INFO *ci;
160 +
161 +  /* Now lets uncompress this thing */
162 +  ci = safe_malloc (sizeof (COMPRESS_INFO));
163 +  ctx->compressinfo = (void*) ci;
164 +  ci->append = find_compress_hook (M_APPENDHOOK, ctx->path);
165 +  ci->open = find_compress_hook (M_OPENHOOK, ctx->path);
166 +  ci->close = find_compress_hook (M_CLOSEHOOK, ctx->path);
167 +  return ci;
168 +}
169 +
170 +static void set_path (CONTEXT* ctx)
171 +{
172 +  char tmppath[_POSIX_PATH_MAX];
173 +
174 +  /* Setup the right paths */
175 +  ctx->realpath = ctx->path;
176 +
177 +  /* Uncompress to /tmp */
178 +  mutt_mktemp (tmppath);
179 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
180 +  strcpy (ctx->path, tmppath);
181 +}
182 +
183 +static int get_size (const char* path)
184 +{
185 +  struct stat sb;
186 +  if (stat (path, &sb) != 0)
187 +    return 0;
188 +  return (sb.st_size);
189 +}
190 +
191 +static void store_size (CONTEXT* ctx)
192 +{
193 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
194 +  ci->size = get_size (ctx->realpath);
195 +}
196 +
197 +static const char *
198 +compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
199 +                        const char *src, const char *fmt,
200 +                        const char *ifstring, const char *elsestring,
201 +                        unsigned long data, format_flag flags)
202 +{
203 +  char tmp[SHORT_STRING];
204 +
205 +  CONTEXT *ctx = (CONTEXT *) data;
206 +  switch (op)
207 +  {
208 +  case 'f':
209 +    snprintf (tmp, sizeof (tmp), "%%%ss", fmt);
210 +    snprintf (dest, destlen, tmp, ctx->realpath);
211 +    break;
212 +  case 't':
213 +    snprintf (tmp, sizeof (tmp), "%%%ss", fmt);
214 +    snprintf (dest, destlen, tmp, ctx->path);
215 +    break;
216 +  }
217 +  return (src);
218 +}
219 +
220 +/*
221 + * check that the command has both %f and %t
222 + * 0 means OK, -1 means error
223 + */
224 +int mutt_test_compress_command (const char* cmd)
225 +{
226 +  return (strstr (cmd, "%f") && strstr (cmd, "%t")) ? 0 : -1;
227 +}
228 +
229 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
230 +{
231 +  char expanded[_POSIX_PATH_MAX];
232 +  mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
233 +                    compresshook_format_str, (unsigned long) ctx, 0);
234 +  return safe_strdup (expanded);
235 +}
236 +
237 +int mutt_check_mailbox_compressed (CONTEXT* ctx)
238 +{
239 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
240 +  if (ci->size != get_size (ctx->realpath))
241 +  {
242 +    FREE (&ctx->compressinfo);
243 +    FREE (&ctx->realpath);
244 +    mutt_error _("Mailbox was corrupted!");
245 +    return (-1);
246 +  }
247 +  return (0);
248 +}
249 +
250 +int mutt_open_read_compressed (CONTEXT *ctx)
251 +{
252 +  char *cmd;
253 +  FILE *fp;
254 +  int rc;
255 +
256 +  COMPRESS_INFO *ci = set_compress_info (ctx);
257 +  if (!ci->open) {
258 +    ctx->magic = 0;
259 +    FREE (&ctx->compressinfo);
260 +    return (-1);
261 +  }
262 +  if (!ci->close || access (ctx->path, W_OK) != 0)
263 +    ctx->readonly = 1;
264 +
265 +  set_path (ctx);
266 +  store_size (ctx);
267 +
268 +  if (!ctx->quiet)
269 +    mutt_message (_("Decompressing %s..."), ctx->realpath);
270 +
271 +  cmd = get_compression_cmd (ci->open, ctx);
272 +  if (cmd == NULL)
273 +    return (-1);
274 +  dprint (2, (debugfile, "DecompressCmd: '%s'\n", cmd));
275 +
276 +  if ((fp = fopen (ctx->realpath, "r")) == NULL)
277 +  {
278 +    mutt_perror (ctx->realpath);
279 +    FREE (&cmd);
280 +    return (-1);
281 +  }
282 +  mutt_block_signals ();
283 +  if (mbox_lock_compressed (ctx, fp, 0, 1) == -1)
284 +  {
285 +    fclose (fp);
286 +    mutt_unblock_signals ();
287 +    mutt_error _("Unable to lock mailbox!");
288 +    FREE (&cmd);
289 +    return (-1);
290 +  }
291 +
292 +  endwin ();
293 +  fflush (stdout);
294 +  fprintf (stderr, _("Decompressing %s...\n"),ctx->realpath);
295 +  rc = mutt_system (cmd);
296 +  mbox_unlock_compressed (ctx, fp);
297 +  mutt_unblock_signals ();
298 +  fclose (fp);
299 +
300 +  if (rc)
301 +  {
302 +    mutt_any_key_to_continue (NULL);
303 +    ctx->magic = 0;
304 +    FREE (&ctx->compressinfo);
305 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
306 +  }
307 +  FREE (&cmd);
308 +  if (rc)
309 +    return (-1);
310 +
311 +  if (mutt_check_mailbox_compressed (ctx))
312 +    return (-1);
313 +
314 +  ctx->magic = mx_get_magic (ctx->path);
315 +
316 +  return (0);
317 +}
318 +
319 +void restore_path (CONTEXT* ctx)
320 +{
321 +  FREE (&ctx->path);
322 +  ctx->path = ctx->realpath;
323 +}
324 +
325 +/* remove the temporary mailbox */
326 +void remove_file (CONTEXT* ctx)
327 +{
328 +  if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
329 +    remove (ctx->path);
330 +}
331 +
332 +int mutt_open_append_compressed (CONTEXT *ctx)
333 +{
334 +  FILE *fh;
335 +  COMPRESS_INFO *ci = set_compress_info (ctx);
336 +
337 +  if (!get_append_command (ctx->path, ctx))
338 +  {
339 +    if (ci->open && ci->close)
340 +      return (mutt_open_read_compressed (ctx));
341 +
342 +    ctx->magic = 0;
343 +    FREE (&ctx->compressinfo);
344 +    return (-1);
345 +  }
346 +
347 +  set_path (ctx);
348 +
349 +  if (!is_new (ctx->realpath))
350 +      if ((fh = fopen (ctx->path, "w")))
351 +       fclose (fh);
352 +  /* No error checking - the parent function will catch it */
353 +
354 +  return (0);
355 +}
356 +
357 +/* close a compressed mailbox */
358 +void mutt_fast_close_compressed (CONTEXT *ctx)
359 +{
360 +  dprint (2, (debugfile, "mutt_fast_close_compressed called on '%s'\n",
361 +             ctx->path));
362 +
363 +  if (ctx->compressinfo)
364 +  {
365 +    if (ctx->fp)
366 +      fclose (ctx->fp);
367 +    ctx->fp = NULL;
368 +    /* if the folder was removed, remove the gzipped folder too */
369 +    if ((ctx->magic > 0)
370 +       && (access (ctx->path, F_OK) != 0)
371 +       && ! option (OPTSAVEEMPTY))
372 +      remove (ctx->realpath);
373 +    else
374 +      remove_file (ctx);
375 +
376 +    restore_path (ctx);
377 +    FREE (&ctx->compressinfo);
378 +  }
379 +}
380 +
381 +/* return 0 on success, -1 on failure */
382 +int mutt_sync_compressed (CONTEXT* ctx)
383 +{
384 +  char *cmd;
385 +  int rc = 0;
386 +  FILE *fp;
387 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
388 +
389 +  if (!ctx->quiet)
390 +    mutt_message (_("Compressing %s..."), ctx->realpath);
391 +
392 +  cmd = get_compression_cmd (ci->close, ctx);
393 +  if (cmd == NULL)
394 +    return (-1);
395 +
396 +  if ((fp = fopen (ctx->realpath, "a")) == NULL)
397 +  {
398 +    mutt_perror (ctx->realpath);
399 +    FREE (&cmd);
400 +    return (-1);
401 +  }
402 +  mutt_block_signals ();
403 +  if (mbox_lock_compressed (ctx, fp, 1, 1) == -1)
404 +  {
405 +    fclose (fp);
406 +    mutt_unblock_signals ();
407 +    mutt_error _("Unable to lock mailbox!");
408 +    store_size (ctx);
409 +    FREE (&cmd);
410 +    return (-1);
411 +  }
412 +
413 +  dprint (2, (debugfile, "CompressCommand: '%s'\n", cmd));
414 +
415 +  endwin ();
416 +  fflush (stdout);
417 +  fprintf (stderr, _("Compressing %s...\n"), ctx->realpath);
418 +  if (mutt_system (cmd))
419 +  {
420 +    mutt_any_key_to_continue (NULL);
421 +    mutt_error (_("%s: Error compressing mailbox! Original mailbox deleted, uncompressed one kept!\n"), ctx->path);
422 +    rc = -1;
423 +  }
424 +
425 +  mbox_unlock_compressed (ctx, fp);
426 +  mutt_unblock_signals ();
427 +  fclose (fp);
428 +
429 +  FREE (&cmd);
430 +
431 +  store_size (ctx);
432 +
433 +  return (rc);
434 +}
435 +
436 +int mutt_slow_close_compressed (CONTEXT *ctx)
437 +{
438 +  FILE *fp;
439 +  const char *append;
440 +  char *cmd;
441 +  COMPRESS_INFO *ci = (COMPRESS_INFO *) ctx->compressinfo;
442 +
443 +  dprint (2, (debugfile, "mutt_slow_close_compressed called on '%s'\n",
444 +             ctx->path));
445 +
446 +  if (! (ctx->append
447 +        && ((append = get_append_command (ctx->realpath, ctx))
448 +            || (append = ci->close))))
449 +  {
450 +    /* if we can not or should not append, we only have to remove the */
451 +    /* compressed info, because sync was already called               */
452 +    mutt_fast_close_compressed (ctx);
453 +    return (0);
454 +  }
455 +
456 +  if (ctx->fp)
457 +    fclose (ctx->fp);
458 +  ctx->fp = NULL;
459 +
460 +  if (!ctx->quiet)
461 +  {
462 +    if (append == ci->close)
463 +      mutt_message (_("Compressing %s..."), ctx->realpath);
464 +    else
465 +      mutt_message (_("Compressed-appending to %s..."), ctx->realpath);
466 +  }
467 +
468 +  cmd = get_compression_cmd (append, ctx);
469 +  if (cmd == NULL)
470 +    return (-1);
471 +
472 +  if ((fp = fopen (ctx->realpath, "a")) == NULL)
473 +  {
474 +    mutt_perror (ctx->realpath);
475 +    FREE (&cmd);
476 +    return (-1);
477 +  }
478 +  mutt_block_signals ();
479 +  if (mbox_lock_compressed (ctx, fp, 1, 1) == -1)
480 +  {
481 +    fclose (fp);
482 +    mutt_unblock_signals ();
483 +    mutt_error _("Unable to lock mailbox!");
484 +    FREE (&cmd);
485 +    return (-1);
486 +  }
487 +
488 +  dprint (2, (debugfile, "CompressCmd: '%s'\n", cmd));
489 +
490 +  endwin ();
491 +  fflush (stdout);
492 +
493 +  if (append == ci->close)
494 +    fprintf (stderr, _("Compressing %s...\n"), ctx->realpath);
495 +  else
496 +    fprintf (stderr, _("Compressed-appending to %s...\n"), ctx->realpath);
497 +
498 +  if (mutt_system (cmd))
499 +  {
500 +    mutt_any_key_to_continue (NULL);
501 +    mutt_error (_(" %s: Error compressing mailbox!  Uncompressed one kept!\n"),
502 +               ctx->path);
503 +    FREE (&cmd);
504 +    mbox_unlock_compressed (ctx, fp);
505 +    mutt_unblock_signals ();
506 +    fclose (fp);
507 +    return (-1);
508 +  }
509 +
510 +  mbox_unlock_compressed (ctx, fp);
511 +  mutt_unblock_signals ();
512 +  fclose (fp);
513 +  remove_file (ctx);
514 +  restore_path (ctx);
515 +  FREE (&cmd);
516 +  FREE (&ctx->compressinfo);
517 +
518 +  return (0);
519 +}
520 +
521 +#endif /* USE_COMPRESSED */
522 --- /dev/null
523 +++ b/compress.h
524 @@ -0,0 +1,27 @@
525 +/*
526 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
527 + *
528 + *     This program is free software; you can redistribute it and/or modify
529 + *     it under the terms of the GNU General Public License as published by
530 + *     the Free Software Foundation; either version 2 of the License, or
531 + *     (at your option) any later version.
532 + *
533 + *     This program is distributed in the hope that it will be useful,
534 + *     but WITHOUT ANY WARRANTY; without even the implied warranty of
535 + *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
536 + *     GNU General Public License for more details.
537 + *
538 + *     You should have received a copy of the GNU General Public License
539 + *     along with this program; if not, write to the Free Software
540 + *     Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
541 + */
542 +
543 +int mutt_can_read_compressed (const char *);
544 +int mutt_can_append_compressed (const char *);
545 +int mutt_open_read_compressed (CONTEXT *);
546 +int mutt_open_append_compressed (CONTEXT *);
547 +int mutt_slow_close_compressed (CONTEXT *);
548 +int mutt_sync_compressed (CONTEXT *);
549 +int mutt_test_compress_command (const char *);
550 +int mutt_check_mailbox_compressed (CONTEXT *);
551 +void mutt_fast_close_compressed (CONTEXT *);
552 --- a/configure.ac
553 +++ b/configure.ac
554 @@ -805,6 +805,11 @@
555                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
556          fi])
557  
558 +AC_ARG_ENABLE(compressed, AC_HELP_STRING([--enable-compressed], [Enable compressed folders support]),
559 +       [if test x$enableval = xyes; then
560 +                AC_DEFINE(USE_COMPRESSED,1, [ Define to support compressed folders. ])
561 +        fi])
562 +
563  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
564          [if test $withval != yes; then
565                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
566 --- a/curs_main.c
567 +++ b/curs_main.c
568 @@ -1135,6 +1135,11 @@
569          {
570           int check;
571  
572 +#ifdef USE_COMPRESSED
573 +         if (Context->compressinfo && Context->realpath)
574 +           mutt_str_replace (&LastFolder, Context->realpath);
575 +         else
576 +#endif
577           mutt_str_replace (&LastFolder, Context->path);
578           oldcount = Context ? Context->msgcount : 0;
579  
580 --- a/doc/manual.xml.head
581 +++ b/doc/manual.xml.head
582 @@ -5678,6 +5678,205 @@
583  
584  </chapter>
585  
586 +<sect1 id="compressedfolders">
587 +<title>Compressed folders Support (OPTIONAL)</title>
588 +
589 +<para>
590 +If Mutt was compiled with compressed folders support (by running the
591 +<emphasis>configure</emphasis> script with the
592 +<emphasis>--enable-compressed</emphasis> flag), Mutt can open folders
593 +stored in an arbitrary format, provided that the user has a script to
594 +convert from/to this format to one of the accepted.
595 +
596 +The most common use is to open compressed archived folders e.g. with
597 +gzip.
598 +
599 +In addition, the user can provide a script that gets a folder in an
600 +accepted format and appends its context to the folder in the
601 +user-defined format, which may be faster than converting the entire
602 +folder to the accepted format, appending to it and converting back to
603 +the user-defined format.
604 +
605 +There are three hooks defined (<link
606 +linkend="open-hook">open-hook</link>, <link
607 +linkend="close-hook">close-hook</link> and <link
608 +linkend="append-hook">append-hook</link>) which define commands to
609 +uncompress and compress a folder and to append messages to an existing
610 +compressed folder respectively.
611 +
612 +For example:
613 +
614 +<screen>
615 +open-hook \\.gz$ "gzip -cd %f &gt; %t"
616 +close-hook \\.gz$ "gzip -c %t &gt; %f"
617 +append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
618 +</screen>
619 +
620 +You do not have to specify all of the commands. If you omit <link
621 +linkend="append-hook">append-hook</link>, the folder will be open and
622 +closed again each time you will add to it. If you omit <link
623 +linkend="close-hook">close-hook</link> (or give empty command) , the
624 +folder will be open in the mode. If you specify <link
625 +linkend="append-hook">append-hook</link> though you'll be able to
626 +append to the folder.
627 +
628 +Note that Mutt will only try to use hooks if the file is not in one of
629 +the accepted formats. In particular, if the file is empty, mutt
630 +supposes it is not compressed. This is important because it allows the
631 +use of programs that do not have well defined extensions. Just use
632 +&quot;.&quot; as a regexp. But this may be surprising if your
633 +compressing script produces empty files. In this situation, unset
634 +<link linkend="save-empty">&dollar;save&lowbar;empty</link>, so that
635 +the compressed file will be removed if you delete all of the messages.
636 +</para>
637 +
638 +<sect2 id="open-hook">
639 +<title>Open a compressed mailbox for reading</title>
640 +
641 +<para>
642 +Usage: <literal>open-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
643 +
644 +The <emphasis>command</emphasis> is the command that can be used for
645 +opening the folders whose names match <emphasis>regexp</emphasis>.
646 +
647 +The <emphasis>command</emphasis> string is the printf-like format
648 +string, and it should accept two parameters: &percnt;f, which is
649 +replaced with the (compressed) folder name, and &percnt;t which is
650 +replaced with the name of the temporary folder to which to write.
651 +
652 +&percnt;f and &percnt;t can be repeated any number of times in the
653 +command string, and all of the entries are replaced with the
654 +appropriate folder name. In addition, &percnt;&percnt; is replaced by
655 +&percnt;, as in printf, and any other &percnt;anything is left as is.
656 +
657 +The <emphasis>command</emphasis> should <emphasis
658 +role="bold">not</emphasis> remove the original compressed file.  The
659 +<emphasis>command</emphasis> should return non-zero exit status if it
660 +fails, so mutt knows something's wrong.
661 +
662 +Example:
663 +
664 +<screen>
665 +open-hook \\.gz$ "gzip -cd %f &gt; %t"
666 +</screen>
667 +
668 +If the <emphasis>command</emphasis> is empty, this operation is
669 +disabled for this file type.
670 +</para>
671 +</sect2>
672 +
673 +<sect2 id="close-hook">
674 +<title>Write a compressed mailbox</title>
675 +
676 +<para>
677 +Usage: <literal>close-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
678 +
679 +This is used to close the folder that was open with the <link
680 +linkend="open-hook">open-hook</link> command after some changes were
681 +made to it.
682 +
683 +The <emphasis>command</emphasis> string is the command that can be
684 +used for closing the folders whose names match
685 +<emphasis>regexp</emphasis>. It has the same format as in the <link
686 +linkend="open-hook">open-hook</link> command. Temporary folder in this
687 +case is the folder previously produced by the <link
688 +linkend="open-hook">open-hook</link> command.
689 +
690 +The <emphasis>command</emphasis> should <emphasis
691 +role="bold">not</emphasis> remove the decompressed file. The
692 +<emphasis>command</emphasis> should return non-zero exit status if it
693 +fails, so mutt knows something's wrong.
694 +
695 +Example:
696 +
697 +<screen>
698 +close-hook \\.gz$ "gzip -c %t &gt; %f"
699 +</screen>
700 +
701 +If the <emphasis>command</emphasis> is empty, this operation is
702 +disabled for this file type, and the file can only be open in the
703 +read-only mode.
704 +
705 +<link linkend="close-hook">close-hook</link> is not called when you
706 +exit from the folder if the folder was not changed.
707 +</para>
708 +</sect2>
709 +
710 +<sect2 id="append-hook">
711 +<title>Append a message to a compressed mailbox</title>
712 +
713 +<para>
714 +Usage: <literal>append-hook</literal> <emphasis>regexp</emphasis> &quot;<emphasis>command</emphasis>&quot;
715 +
716 +This command is used for saving to an existing compressed folder.  The
717 +<emphasis>command</emphasis> is the command that can be used for
718 +appending to the folders whose names match
719 +<emphasis>regexp</emphasis>. It has the same format as in the <link
720 +linkend="open-hook">open-hook</link> command.  The temporary folder in
721 +this case contains the messages that are being appended.
722 +
723 +The <emphasis>command</emphasis> should <emphasis
724 +role="bold">not</emphasis> remove the decompressed file. The
725 +<emphasis>command</emphasis> should return non-zero exit status if it
726 +fails, so mutt knows something's wrong.
727 +
728 +Example:
729 +
730 +<screen>
731 +append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
732 +</screen>
733 +
734 +When <link linkend="append-hook">append-hook</link> is used, the folder
735 +is not opened, which saves time, but this means that we can not find
736 +out what the folder type is. Thus the default (<link
737 +linkend="mbox-type">&dollar;mbox&lowbar;type</link>) type is always
738 +supposed (i.e.  this is the format used for the temporary folder).
739 +
740 +If the file does not exist when you save to it, <link
741 +linkend="close-hook">close-hook</link> is called, and not <link
742 +linkend="append-hook">append-hook</link>. <link
743 +linkend="append-hook">append-hook</link> is only for appending to
744 +existing folders.
745 +
746 +If the <emphasis>command</emphasis> is empty, this operation is
747 +disabled for this file type. In this case, the folder will be open and
748 +closed again (using <link linkend="open-hook">open-hook</link> and
749 +<link linkend="close-hook">close-hook</link>respectively) each time you
750 +will add to it.
751 +</para>
752 +</sect2>
753 +
754 +<sect2>
755 +<title>Encrypted folders</title>
756 +
757 +<para>
758 +The compressed folders support can also be used to handle encrypted
759 +folders. If you want to encrypt a folder with PGP, you may want to use
760 +the following hooks:
761 +
762 +<screen>
763 +open-hook  \\.pgp$ "pgp -f &lt; %f &gt; %t"
764 +close-hook \\.pgp$ "pgp -fe YourPgpUserIdOrKeyId &lt; %t &gt; %f"
765 +</screen>
766 +
767 +Please note, that PGP does not support appending to an encrypted
768 +folder, so there is no append-hook defined.
769 +
770 +If you are using GnuPG instead of PGP, you may use the following hooks
771 +instead:
772 +
773 +<screen>
774 +open-hook  \\.gpg$ "gpg --decrypt &lt; %f &gt; %t"
775 +close-hook \\.gpg$ "gpg --encrypt --recipient YourGpgUserIdOrKeyId &lt; %t &gt; %f"
776 +</screen>
777 +
778 +<emphasis role="bold">Note:</emphasis> the folder is temporary stored
779 +decrypted in the /tmp directory, where it can be read by your system
780 +administrator. So think about the security aspects of this.
781 +</para>
782 +</sect2>
783 +</sect1>
784 +
785  <chapter id="mimesupport">
786  <title>Mutt's MIME Support</title>
787  
788 --- a/doc/muttrc.man.head
789 +++ b/doc/muttrc.man.head
790 @@ -345,6 +345,24 @@
791  to a certain recipient.  The meaning of "key ID" is to be taken
792  broadly: This can be a different e-mail address, a numerical key ID,
793  or even just an arbitrary search string.
794 +.PP
795 +.nf
796 +\fBopen-hook\fP \fIregexp\fP "\fIcommand\fP"
797 +\fBclose-hook\fP \fIregexp\fP "\fIcommand\fP"
798 +\fBappend-hook\fP \fIregexp\fP "\fIcommand\fP"
799 +.fi
800 +.IP
801 +These commands provide a way to handle compressed folders. The given
802 +\fBregexp\fP specifies which folders are taken as compressed (e.g.
803 +"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
804 +(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
805 +compressed mail to a compressed folder (\fBappend-hook\fP). The
806 +\fIcommand\fP string is the
807 +.BR printf (3)
808 +like format string, and it should accept two parameters: \fB%f\fP,
809 +which is replaced with the (compressed) folder name, and \fB%t\fP
810 +which is replaced with the name of the temporary folder to which to
811 +write.
812  .TP
813  \fBpush\fP \fIstring\fP
814  This command adds the named \fIstring\fP to the keyboard buffer.
815 --- a/hook.c
816 +++ b/hook.c
817 @@ -24,6 +24,10 @@
818  #include "mailbox.h"
819  #include "mutt_crypt.h"
820  
821 +#ifdef USE_COMPRESSED
822 +#include "compress.h"
823 +#endif
824 +
825  #include <limits.h>
826  #include <string.h>
827  #include <stdlib.h>
828 @@ -92,6 +96,16 @@
829      memset (&pattern, 0, sizeof (pattern));
830      pattern.data = safe_strdup (path);
831    }
832 +#ifdef USE_COMPRESSED
833 +  else if (data & (M_APPENDHOOK | M_OPENHOOK | M_CLOSEHOOK))
834 +  {
835 +    if (mutt_test_compress_command (command.data))
836 +    {
837 +      strfcpy (err->data, _("badly formatted command string"), err->dsize);
838 +      return (-1);
839 +    }
840 +  }
841 +#endif
842    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
843             && (!WithCrypto || !(data & M_CRYPTHOOK))
844        )
845 --- a/init.h
846 +++ b/init.h
847 @@ -3504,6 +3504,11 @@
848    { "fcc-hook",                mutt_parse_hook,        M_FCCHOOK },
849    { "fcc-save-hook",   mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
850    { "folder-hook",     mutt_parse_hook,        M_FOLDERHOOK },
851 +#ifdef USE_COMPRESSED
852 +  { "open-hook",       mutt_parse_hook,        M_OPENHOOK },
853 +  { "close-hook",      mutt_parse_hook,        M_CLOSEHOOK },
854 +  { "append-hook",     mutt_parse_hook,        M_APPENDHOOK },
855 +#endif
856    { "group",           parse_group,            0 },
857    { "ungroup",         parse_ungroup,          0 },
858    { "hdr_order",       parse_list,             UL &HeaderOrderList },
859 --- a/main.c
860 +++ b/main.c
861 @@ -402,6 +402,12 @@
862  #else
863         "-LOCALES_HACK  "
864  #endif
865 +
866 +#ifdef USE_COMPRESSED
867 +       "+COMPRESSED  "
868 +#else
869 +       "-COMPRESSED  "
870 +#endif
871               
872  #ifdef HAVE_WC_FUNCS
873         "+HAVE_WC_FUNCS  "
874 --- a/Makefile.am
875 +++ b/Makefile.am
876 @@ -18,7 +18,7 @@
877  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
878  mutt_SOURCES = \
879         addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
880 -       crypt.c cryptglue.c \
881 +       crypt.c cryptglue.c compress.c \
882         commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
883         edit.c enter.c flags.c init.c filter.c from.c \
884         getdomain.c group.c \
885 @@ -57,7 +57,7 @@
886         bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
887  
888  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
889 -       configure account.h \
890 +       configure account.h compress.h \
891         attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
892         globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
893         mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
894 --- a/mbox.c
895 +++ b/mbox.c
896 @@ -29,6 +29,10 @@
897  #include "copy.h"
898  #include "mutt_curses.h"
899  
900 +#ifdef USE_COMPRESSED
901 +#include "compress.h"
902 +#endif
903 +
904  #include <sys/stat.h>
905  #include <dirent.h>
906  #include <string.h>
907 @@ -1048,6 +1052,12 @@
908  int mbox_close_mailbox (CONTEXT *ctx)
909  {
910    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
911 +
912 +#ifdef USE_COMPRESSED
913 +  if (ctx->compressinfo)
914 +    mutt_slow_close_compressed (ctx);
915 +#endif
916 +
917    mutt_unblock_signals ();
918    mx_fastclose_mailbox (ctx);
919    return 0;
920 --- a/mutt.h
921 +++ b/mutt.h
922 @@ -146,6 +146,11 @@
923  #define M_ACCOUNTHOOK  (1<<9)
924  #define M_REPLYHOOK    (1<<10)
925  #define M_SEND2HOOK     (1<<11)
926 +#ifdef USE_COMPRESSED
927 +#define M_OPENHOOK     (1<<12)
928 +#define M_APPENDHOOK   (1<<13)
929 +#define M_CLOSEHOOK    (1<<14)
930 +#endif
931  
932  /* tree characters for linearize_tree and print_enriched_string */
933  #define M_TREE_LLCORNER                1
934 @@ -882,6 +887,11 @@
935    int flagged;                 /* how many flagged messages */
936    int msgnotreadyet;           /* which msg "new" in pager, -1 if none */
937  
938 +#ifdef USE_COMPRESSED
939 +  void *compressinfo;          /* compressed mbox module private data */
940 +  char *realpath;              /* path to compressed mailbox */
941 +#endif /* USE_COMPRESSED */
942 +
943    short magic;                 /* mailbox type */
944  
945    unsigned char rights[(RIGHTSMAX + 7)/8];     /* ACL bits */
946 --- a/mx.c
947 +++ b/mx.c
948 @@ -30,6 +30,10 @@
949  #include "keymap.h"
950  #include "url.h"
951  
952 +#ifdef USE_COMPRESSED
953 +#include "compress.h"
954 +#endif
955 +
956  #ifdef USE_IMAP
957  #include "imap.h"
958  #endif
959 @@ -415,6 +419,10 @@
960      return (-1);
961    }
962  
963 +#ifdef USE_COMPRESSED
964 +  if (magic == 0 && mutt_can_read_compressed (path))
965 +    return M_COMPRESSED;
966 +#endif
967    return (magic);
968  }
969  
970 @@ -454,6 +462,13 @@
971  {
972    struct stat sb;
973  
974 +#ifdef USE_COMPRESSED
975 +  /* special case for appending to compressed folders -
976 +   * even if we can not open them for reading */
977 +  if (mutt_can_append_compressed (ctx->path))
978 +    mutt_open_append_compressed (ctx);
979 +#endif
980 +
981    ctx->append = 1;
982  
983  #ifdef USE_IMAP
984 @@ -617,7 +632,12 @@
985    }
986  
987    ctx->magic = mx_get_magic (path);
988 -  
989 +
990 +#ifdef USE_COMPRESSED
991 +  if (ctx->magic == M_COMPRESSED)
992 +    mutt_open_read_compressed (ctx);
993 +#endif
994 +
995    if(ctx->magic == 0)
996      mutt_error (_("%s is not a mailbox."), path);
997  
998 @@ -718,6 +738,10 @@
999      mutt_free_header (&ctx->hdrs[i]);
1000    FREE (&ctx->hdrs);
1001    FREE (&ctx->v2r);
1002 +#ifdef USE_COMPRESSED
1003 +  if (ctx->compressinfo)
1004 +    mutt_fast_close_compressed (ctx);
1005 +#endif
1006    FREE (&ctx->path);
1007    FREE (&ctx->pattern);
1008    if (ctx->limit_pattern) 
1009 @@ -770,6 +794,12 @@
1010    
1011    if (tmp && tmp->new == 0)
1012      mutt_update_mailbox (tmp);
1013 +
1014 +#ifdef USE_COMPRESSED
1015 +  if (rc == 0 && ctx->compressinfo)
1016 +    return mutt_sync_compressed (ctx);
1017 +#endif
1018 +
1019    return rc;
1020  }
1021  
1022 @@ -1033,6 +1063,11 @@
1023        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
1024      mx_unlink_empty (ctx->path);
1025  
1026 +#ifdef USE_COMPRESSED
1027 +  if (ctx->compressinfo && mutt_slow_close_compressed (ctx))
1028 +    return (-1);
1029 +#endif
1030 +
1031    mx_fastclose_mailbox (ctx);
1032  
1033    return 0;
1034 @@ -1355,6 +1390,11 @@
1035  {
1036    int rc;
1037  
1038 +#ifdef USE_COMPRESSED
1039 +  if (ctx->compressinfo)
1040 +    return mutt_check_mailbox_compressed (ctx);
1041 +#endif
1042 +
1043    if (ctx)
1044    {
1045      if (ctx->locked) lock = 0;
1046 --- a/mx.h
1047 +++ b/mx.h
1048 @@ -40,6 +40,9 @@
1049  #ifdef USE_POP
1050    , M_POP
1051  #endif
1052 +#ifdef USE_COMPRESSED
1053 +  , M_COMPRESSED
1054 +#endif
1055  };
1056  
1057  WHERE short DefaultMagic INITVAL (M_MBOX);
1058 --- a/po/de.po
1059 +++ b/po/de.po
1060 @@ -2005,6 +2005,10 @@
1061  msgid "Bad history file format (line %d)"
1062  msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
1063  
1064 +#: hook.c:96
1065 +msgid "badly formatted command string"
1066 +msgstr "Hook enthält nicht die Muster %f und %t"
1067 +
1068  #: hook.c:251
1069  #, c-format
1070  msgid "unhook: Can't do unhook * from within a hook."
1071 @@ -2766,7 +2770,7 @@
1072  msgid "Mailbox is corrupt!"
1073  msgstr "Mailbox fehlerhaft!"
1074  
1075 -#: mbox.c:678
1076 +#: mbox.c:678 compress.c:203 mbox.c:661
1077  msgid "Mailbox was corrupted!"
1078  msgstr "Mailbox wurde zerstört!"
1079  
1080 @@ -2774,10 +2778,11 @@
1081  msgid "Fatal error!  Could not reopen mailbox!"
1082  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
1083  
1084 -#: mbox.c:746
1085 +#: mbox.c:746 compress.c:264 compress.c:246 compress.c:367 compress.c:443 mbox.c:706
1086  msgid "Unable to lock mailbox!"
1087  msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
1088  
1089 +
1090  #. this means ctx->changed or ctx->deleted was set, but no
1091  #. * messages were found to be changed or deleted.  This should
1092  #. * never happen, is we presume it is a bug in mutt.
1093 @@ -5378,3 +5383,32 @@
1094  
1095  #~ msgid "Authentication method is unknown."
1096  #~ msgstr "Authentifizierungsmethode unbekannt."
1097 +
1098 +#: compress.c:228 compress.c:253
1099 +#, c-format
1100 +msgid "Decompressing %s...\n"
1101 +msgstr "Entpacke %s...\n"
1102 +
1103 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
1104 +#, c-format
1105 +msgid "Compressing %s...\n"
1106 +msgstr "Komprimiere %s...\n"
1107 +
1108 +#: compress.c:381
1109 +#, c-format
1110 +msgid ""
1111 +"%s: Error compressing mailbox! Original mailbox deleted, uncompressed one "
1112 +"kept!\n"
1113 +msgstr ""
1114 +"%s: Fehler beim Komprimieren der Mailbox! Ursprüngliche Mailbox gelöscht, "
1115 +"entpackte gespeichert!\n"
1116 +
1117 +#: compress.c:425 compress.c:456
1118 +#, c-format
1119 +msgid "Compressed-appending to %s...\n"
1120 +msgstr "Hänge komprimiert an %s... an\n"
1121 +
1122 +#: compress.c:461
1123 +#, c-format
1124 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
1125 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
1126 --- a/po/POTFILES.in
1127 +++ b/po/POTFILES.in
1128 @@ -8,6 +8,7 @@
1129  color.c
1130  commands.c
1131  compose.c
1132 +compress.c
1133  crypt-gpgme.c
1134  crypt.c
1135  cryptglue.c
1136 --- a/status.c
1137 +++ b/status.c
1138 @@ -96,6 +96,14 @@
1139  
1140      case 'f':
1141        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
1142 +#ifdef USE_COMPRESSED
1143 +      if (Context && Context->compressinfo && Context->realpath)
1144 +      {
1145 +        strfcpy (tmp, Context->realpath, sizeof (tmp));
1146 +        mutt_pretty_mailbox (tmp, sizeof (tmp));
1147 +      }
1148 +      else
1149 +#endif
1150        if (Context && Context->path)
1151        {
1152         strfcpy (tmp, Context->path, sizeof (tmp));