]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/500016-temp-cache-fix.patch
Merge commit 'upstream/1.5.21'
[software/mutt-debian.git] / debian / patches / upstream / 500016-temp-cache-fix.patch
1 message cache partially invalid after network problem
2 fixed by http://dev.mutt.org/trac/ticket/3163
3 changeset http://dev.mutt.org/trac/changeset/da94a92c3ba0
4 resolves http://bugs.debian.org/500016
5
6 --- mutt-1.5.19/bcache.c        2009-01-05 19:20:53.000000000 +0000
7 +++ mutt-7ddf1d1cc490/bcache.c  2009-01-27 20:58:15.000000000 +0000
8 @@ -136,6 +136,13 @@
9    snprintf (path, sizeof (path), "%s%s%s", bcache->path, id,
10              tmp ? ".tmp" : "");
11  
12 +  if ((fp = safe_fopen (path, "w+")))
13 +    goto out;
14 +
15 +  if (errno == EEXIST)
16 +    /* clean up leftover tmp file */
17 +    mutt_unlink (path);
18 +
19    s = strchr (path + 1, '/');
20    while (!(fp = safe_fopen (path, "w+")) && errno == ENOENT && s)
21    {
22 @@ -147,6 +154,7 @@
23      s = strchr (s + 1, '/');
24    }
25  
26 +  out:
27    dprint (3, (debugfile, "bcache: put: '%s'\n", path));
28  
29    return fp;