2 This patch by Manuel Estrada Sainz <ranty@debian.org> is an improvement
3 to the compressed folder patch.
5 It was received at Debian's BTS, Bug#210429.
7 * Patch last synced with upstream:
8 - Date: unknown (mutt_1.5.6-20040523+1)
9 - File: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=210429&msg=11
14 --- mutt.orig/compress.c 2003-09-11 19:26:34.000000000 +0200
15 +++ mutt/compress.c 2003-09-11 19:58:05.000000000 +0200
17 int mutt_can_append_compressed (const char *path)
22 - return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
24 + char *dir_path = safe_strdup(path);
25 + char *aux = strrchr(dir_path, '/');
30 + if (access(dir_path, W_OK|X_OK))
33 + safe_free((void**)&dir_path);
34 + return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
37 magic = mx_get_magic (path);
39 if (magic != 0 && magic != M_COMPRESSED)